summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD30
2 files changed, 22 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ae19f9b75fc..ab8e07d8b971 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,20 @@
pkgbase = qemu-arm-static
pkgdesc = Statically linked qemu-arm, qemu-armeb and qemu-aarch64 executables from Alpine
- pkgver = 4.2.0r2
+ pkgver = 5.0.0r0
pkgrel = 1
url = https://alpinelinux.org/
install = qemu-arm-static.install
arch = x86_64
license = GPL2
- source = https://alpine.global.ssl.fastly.net/alpine/edge/community/x86_64/qemu-aarch64-4.2.0-r2.apk
- source = https://alpine.global.ssl.fastly.net/alpine/edge/community/x86_64/qemu-arm-4.2.0-r2.apk
- source = https://alpine.global.ssl.fastly.net/alpine/edge/community/x86_64/qemu-armeb-4.2.0-r2.apk
+ source = https://alpine.global.ssl.fastly.net/alpine/edge/community/x86_64/qemu-aarch64-5.0.0-r0.apk
+ source = https://alpine.global.ssl.fastly.net/alpine/edge/community/x86_64/qemu-arm-5.0.0-r0.apk
+ source = https://alpine.global.ssl.fastly.net/alpine/edge/community/x86_64/qemu-armeb-5.0.0-r0.apk
source = aarch64.binfmt
source = arm.binfmt
source = armeb.binfmt
- md5sums = 88a8e9915732e8efa4002576ce62e673
- md5sums = c79f2a3881ab0475629245b7e6cc1c70
- md5sums = 0c3d205a9ededc238ffc47e7200fb89e
+ md5sums = 98374a8d5cf5ec17b49e2562466525bb
+ md5sums = 0bffd1bca446f5f6218886e5b73629ae
+ md5sums = c686f4c423b2468639f8adfecc23c740
md5sums = 11c56ac5b0463055b7e3bc1216fe639e
md5sums = 990e3e260665c1da56b5b1c71f480664
md5sums = 89569b9c545af650dfeab24d4f8bb677
diff --git a/PKGBUILD b/PKGBUILD
index 739c606a8480..aa036588561f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: Bartłomiej Piotrowski <bpiotrowski@archlinux.org>
pkgname=qemu-arm-static
-pkgver=4.2.0r2
+pkgver=5.0.0r0
_pkgver=${pkgver/r/-r}
pkgrel=1
pkgdesc='Statically linked qemu-arm, qemu-armeb and qemu-aarch64 executables from Alpine'
@@ -10,22 +10,22 @@ arch=(x86_64)
url='https://alpinelinux.org/'
license=(GPL2)
install=$pkgname.install
-source=(https://alpine.global.ssl.fastly.net/alpine/edge/community/x86_64/qemu-aarch64-$_pkgver.apk
- https://alpine.global.ssl.fastly.net/alpine/edge/community/x86_64/qemu-arm-$_pkgver.apk
- https://alpine.global.ssl.fastly.net/alpine/edge/community/x86_64/qemu-armeb-$_pkgver.apk
- aarch64.binfmt arm.binfmt armeb.binfmt
+source=("https://alpine.global.ssl.fastly.net/alpine/edge/community/x86_64/qemu-aarch64-$_pkgver.apk"
+ "https://alpine.global.ssl.fastly.net/alpine/edge/community/x86_64/qemu-arm-$_pkgver.apk"
+ "https://alpine.global.ssl.fastly.net/alpine/edge/community/x86_64/qemu-armeb-$_pkgver.apk"
+ aarch64.binfmt arm.binfmt armeb.binfmt
)
package() {
- for arch in aarch64 arm armeb; do
- install -Dm755 usr/bin/qemu-$arch "$pkgdir/usr/bin/qemu-${arch}-static"
- install -Dm644 ${arch}.binfmt "$pkgdir/usr/lib/binfmt.d/${arch}.conf"
- done
+ for arch in aarch64 arm armeb; do
+ install -Dm755 usr/bin/qemu-"$arch" "$pkgdir/usr/bin/qemu-${arch}-static"
+ install -Dm644 "${arch}".binfmt "$pkgdir/usr/lib/binfmt.d/${arch}.conf"
+ done
}
-md5sums=('88a8e9915732e8efa4002576ce62e673'
- 'c79f2a3881ab0475629245b7e6cc1c70'
- '0c3d205a9ededc238ffc47e7200fb89e'
- '11c56ac5b0463055b7e3bc1216fe639e'
- '990e3e260665c1da56b5b1c71f480664'
- '89569b9c545af650dfeab24d4f8bb677')
+md5sums=('98374a8d5cf5ec17b49e2562466525bb'
+ '0bffd1bca446f5f6218886e5b73629ae'
+ 'c686f4c423b2468639f8adfecc23c740'
+ '11c56ac5b0463055b7e3bc1216fe639e'
+ '990e3e260665c1da56b5b1c71f480664'
+'89569b9c545af650dfeab24d4f8bb677')