summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD13
-rw-r--r--allow_elf64.patch18
-rw-r--r--remove-problematic-evdev-86-key-from-en-us-keymap.patch32
4 files changed, 56 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6a703d404429..169e2b286da5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qemu-minimal
pkgdesc = A generic and open source machine emulator and virtualizer. This is a stripped-down version of the official package and requires only the bare essentials for running on a headless server.
- pkgver = 2.11.0
- pkgrel = 4
+ pkgver = 2.12.0
+ pkgrel = 1
url = http://wiki.qemu.org/
arch = x86_64
license = GPL2
@@ -18,17 +18,19 @@ pkgbase = qemu-minimal
provides = qemu-headless
conflicts = qemu
conflicts = qemu-headless
- source = https://download.qemu.org/qemu-2.11.0.tar.xz
- source = https://download.qemu.org/qemu-2.11.0.tar.xz.sig
+ source = https://download.qemu.org/qemu-2.12.0.tar.xz
+ source = https://download.qemu.org/qemu-2.12.0.tar.xz.sig
source = qemu-ga.service
source = 65-kvm.rules
+ source = remove-problematic-evdev-86-key-from-en-us-keymap.patch
source = allow_elf64.patch
validpgpkeys = CEACC9E15534EBABB82D3FA03353C9CEF108B584
- sha256sums = c9d34a79024eae080ce3853aa9afe503824520eefb440190383003081ce7f437
+ sha256sums = e69301f361ff65bf5dabd8a19196aeaa5613c1b5ae1678f0823bdf50e7d5c6fc
sha256sums = SKIP
sha256sums = c39bcde4a09165e64419fd2033b3532378bba84d509d39e2d51694d44c1f8d88
sha256sums = a66f0e791b16b03b91049aac61a25950d93e962e1b2ba64a38c6ad7f609b532c
- sha256sums = 13a6d9e678bdc9e1f051006cfd0555f5a80582368f54c8a1bb5a78ece3832ac4
+ sha256sums = 3cefabbab32ab21cd3b5a8cc1165c96db0c6c93e7ee8dc9d2ca09be5fb5eccda
+ sha256sums = 59751f1ed26ea61b2a37ebee4be6979e584a450b611282138a0893aa9173e2e4
pkgname = qemu-minimal
diff --git a/PKGBUILD b/PKGBUILD
index 98b66dae06f5..6dc2d4794dc2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,4 @@
-# $Id: PKGBUILD 313398 2017-12-20 17:55:01Z anatolik $
+# $Id: PKGBUILD 323214 2018-05-01 16:45:25Z anatolik $
# Maintainer: Tobias Powalowski <tpowa@archlinux.org>
# Contributor: Sébastien "Seblu" Luttringer <seblu@seblu.net>
@@ -8,8 +8,8 @@
pkgname='qemu-minimal'
#pkgdesc="A generic and open source machine emulator and virtualizer"
pkgdesc="A generic and open source machine emulator and virtualizer. This is a stripped-down version of the official package and requires only the bare essentials for running on a headless server."
-pkgver=2.11.0
-pkgrel=4
+pkgver=2.12.0
+pkgrel=1
arch=(x86_64)
license=(GPL2 LGPL2.1)
url="http://wiki.qemu.org/"
@@ -26,12 +26,14 @@ provides=('qemu' 'qemu-headless')
source=(https://download.qemu.org/qemu-$pkgver.tar.xz{,.sig}
qemu-ga.service
65-kvm.rules
+ remove-problematic-evdev-86-key-from-en-us-keymap.patch
allow_elf64.patch)
-sha256sums=('c9d34a79024eae080ce3853aa9afe503824520eefb440190383003081ce7f437'
+sha256sums=('e69301f361ff65bf5dabd8a19196aeaa5613c1b5ae1678f0823bdf50e7d5c6fc'
'SKIP'
'c39bcde4a09165e64419fd2033b3532378bba84d509d39e2d51694d44c1f8d88'
'a66f0e791b16b03b91049aac61a25950d93e962e1b2ba64a38c6ad7f609b532c'
- '13a6d9e678bdc9e1f051006cfd0555f5a80582368f54c8a1bb5a78ece3832ac4')
+ '3cefabbab32ab21cd3b5a8cc1165c96db0c6c93e7ee8dc9d2ca09be5fb5eccda'
+ '59751f1ed26ea61b2a37ebee4be6979e584a450b611282138a0893aa9173e2e4')
validpgpkeys=('CEACC9E15534EBABB82D3FA03353C9CEF108B584')
case $CARCH in
@@ -47,6 +49,7 @@ prepare() {
cd ${pkgname:0:-8}-${pkgver}
sed -i 's/vte-2\.90/vte-2.91/g' configure
+ patch -p1 < ../remove-problematic-evdev-86-key-from-en-us-keymap.patch
patch -p1 < ../allow_elf64.patch
}
diff --git a/allow_elf64.patch b/allow_elf64.patch
index 07f27a038b1b..0c5f6917c6ba 100644
--- a/allow_elf64.patch
+++ b/allow_elf64.patch
@@ -1,24 +1,22 @@
-commit 3c72765ec760a51f0e879dc792be82c93141e318
+commit cb61bc8a42da1a971079767e63df4503b6ab2efb
Author: Anatol Pomozov <anatol.pomozov@gmail.com>
-Date: Tue Jun 6 20:07:03 2017 -0700
+Date: Mon Jan 29 10:08:53 2018 -0800
- Remove restriction that prevents bootimg elf64 images
+ multiboot: Make elf64 loading functionality compatible with GRUB
- It is possible to create a 64 bit elf image that has valid multiboot header.
- qemu should be able to boot such images.
-
- Signed-off-by: Anatol Pomozov <anatol.pomozov@gmail.com>
+ GRUB is a reference multiboot implementation and supports loading elf64
+ binaries. Make QEMU to work similar was as GRUB.
diff --git a/hw/i386/multiboot.c b/hw/i386/multiboot.c
-index 663f35a658..cf1b4f5fb3 100644
+index 5bc0a2cddb..0907e42a39 100644
--- a/hw/i386/multiboot.c
+++ b/hw/i386/multiboot.c
-@@ -192,11 +192,6 @@ int load_multiboot(FWCfgState *fw_cfg,
+@@ -193,11 +193,6 @@ int load_multiboot(FWCfgState *fw_cfg,
int kernel_size;
fclose(f);
- if (((struct elf64_hdr*)header)->e_machine == EM_X86_64) {
-- fprintf(stderr, "Cannot load x86-64 image, give a 32bit one.\n");
+- error_report("Cannot load x86-64 image, give a 32bit one.");
- exit(1);
- }
-
diff --git a/remove-problematic-evdev-86-key-from-en-us-keymap.patch b/remove-problematic-evdev-86-key-from-en-us-keymap.patch
new file mode 100644
index 000000000000..837be82595de
--- /dev/null
+++ b/remove-problematic-evdev-86-key-from-en-us-keymap.patch
@@ -0,0 +1,32 @@
+From 2c25ad161d7714f15b1951c69c50844ea81f4186 Mon Sep 17 00:00:00 2001
+From: Adam Williamson <awilliam@redhat.com>
+Date: Wed, 20 Dec 2017 15:43:07 -0800
+Subject: [PATCH] Remove problematic 'evdev 86' key from en-us keymap
+
+This causes LP#1738283. Gerd will have to come up with a better
+fix, but just hacking out the problematic key definition should
+work for now.
+---
+ pc-bios/keymaps/en-us | 6 ------
+ 1 file changed, 6 deletions(-)
+
+diff --git a/pc-bios/keymaps/en-us b/pc-bios/keymaps/en-us
+index a70e03adc0..e518a9dc35 100644
+--- a/pc-bios/keymaps/en-us
++++ b/pc-bios/keymaps/en-us
+@@ -343,12 +343,6 @@ KP_Decimal 0x53 numlock
+
+ # evdev 85 (0x55): no evdev -> QKeyCode mapping (xkb keysym NoSymbol)
+
+-# evdev 86 (0x56), QKeyCode "less", number 0x56
+-less 0x56
+-greater 0x56 shift
+-bar 0x56 altgr
+-brokenbar 0x56 shift altgr
+-
+ # evdev 87 (0x57), QKeyCode "f11", number 0x57
+ F11 0x57
+
+--
+2.15.1
+