summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO63
-rw-r--r--65-kvm.rules3
-rw-r--r--PKGBUILD65
-rw-r--r--qemu.install26
4 files changed, 157 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5159cbecb487
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,63 @@
+pkgbase = qemu-git
+ pkgdesc = A generic and open source processor emulator which achieves a good emulation speed by using dynamic translation. Git version.
+ pkgver = 2.4.r39316.gb041114
+ pkgrel = 1
+ url = http://wiki.qemu.org/Index.html
+ install = qemu.install
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ license = LGPL2
+ makedepends = git
+ makedepends = texi2html
+ makedepends = perl
+ makedepends = python2
+ makedepends = spice-protocol
+ depends = pixman
+ depends = libjpeg
+ depends = libpng
+ depends = sdl
+ depends = alsa-lib
+ depends = nss
+ depends = glib2
+ depends = gnutls>=2.4.1
+ depends = bluez-libs
+ depends = vde2
+ depends = util-linux
+ depends = curl
+ depends = libsasl
+ depends = libgl
+ depends = libpulse
+ depends = libcap-ng
+ depends = libaio
+ depends = libseccomp
+ depends = libiscsi
+ depends = spice
+ depends = usbredir
+ depends = dtc
+ depends = snappy
+ optdepends = ovmf: Tianocore UEFI firmware for qemu
+ provides = qemu
+ provides = qemu-kvm
+ provides = qemu-spice
+ provides = libcacard
+ provides = seabios
+ provides = seabios-git
+ conflicts = qemu
+ conflicts = kvm
+ conflicts = kvm-git
+ conflicts = qemu-spice
+ conflicts = libcacard
+ conflicts = seabios
+ conflicts = seabios-git
+ options = !strip
+ backup = etc/qemu/target-x86_64.conf
+ source = git://git.qemu.org/qemu.git
+ source = 65-kvm.rules
+ source = qemu.install
+ sha256sums = SKIP
+ sha256sums = 9c8a15c34461a9481a34ca9e0ab4ae3825eabe8fd863227f2445325413cd755c
+ sha256sums = 9970c3050e8dc6153c5955d018d114f9fcbc091843b85f9e7b247eb28f09ba10
+
+pkgname = qemu-git
+
diff --git a/65-kvm.rules b/65-kvm.rules
new file mode 100644
index 000000000000..90913c36830b
--- /dev/null
+++ b/65-kvm.rules
@@ -0,0 +1,3 @@
+KERNEL=="kvm", GROUP="kvm", MODE="0660"
+KERNEL=="vhost-net", GROUP="kvm", MODE="0660", TAG+="uaccess", OPTIONS+="static_node=vhost-net"
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0abeb20df9e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: ajs124 < aur at ajs124 dot de>
+# Contributor: Devin Cofer <ranguvar{AT]archlinux[DOT}us>
+# Contributor: Tobias Powalowski <tpowa@archlinux.org>
+# Contributor: Frederic Bezies <fredbezies@gmail.com>
+
+pkgname=qemu-git
+_gitname=qemu
+pkgver=2.4.r39316.gb041114
+pkgrel=1
+pkgdesc="A generic and open source processor emulator which achieves a good emulation speed by using dynamic translation. Git version."
+arch=('i686' 'x86_64')
+license=('GPL2' 'LGPL2')
+url="http://wiki.qemu.org/Index.html"
+depends=('pixman' 'libjpeg' 'libpng' 'sdl' 'alsa-lib' 'nss' 'glib2'
+ 'gnutls>=2.4.1' 'bluez-libs' 'vde2' 'util-linux' 'curl' 'libsasl'
+ 'libgl' 'libpulse' 'libcap-ng' 'libaio' 'libseccomp'
+ 'libiscsi' 'spice' 'usbredir' 'dtc' 'snappy')
+makedepends=('git' 'texi2html' 'perl' 'python2' 'spice-protocol')
+optdepends=('ovmf: Tianocore UEFI firmware for qemu')
+conflicts=('qemu' 'kvm' 'kvm-git' 'qemu-spice' 'libcacard' 'seabios' 'seabios-git')
+provides=('qemu' 'qemu-kvm' 'qemu-spice' 'libcacard' 'seabios' 'seabios-git')
+backup=('etc/qemu/target-x86_64.conf')
+source=('git://git.qemu.org/qemu.git'
+ '65-kvm.rules'
+ 'qemu.install')
+sha256sums=('SKIP'
+ '9c8a15c34461a9481a34ca9e0ab4ae3825eabe8fd863227f2445325413cd755c'
+ '9970c3050e8dc6153c5955d018d114f9fcbc091843b85f9e7b247eb28f09ba10')
+install='qemu.install'
+options=('!strip')
+
+pkgver() {
+ cd "${srcdir}/$_gitname"
+ echo "2.4.r$(git rev-list --count master).g$(git log -1 --format="%h")"
+}
+
+build() {
+ cd $_gitname
+ # qemu vs. make 4 == bad
+ export ARFLAGS="rv"
+ # http://permalink.gmane.org/gmane.comp.emulators.qemu/238740
+ # gtk gui breaks keymappings at the moment
+ ./configure --prefix=/usr --sysconfdir=/etc --audio-drv-list='pa alsa sdl' \
+ --python=/usr/bin/python2 --smbd=/usr/bin/smbd \
+ --enable-docs --libexecdir=/usr/lib/qemu \
+ --disable-gtk --enable-linux-aio --enable-seccomp \
+ --enable-spice --localstatedir=/var --disable-werror
+ make V=99
+}
+
+package() {
+ cd $_gitname
+
+ make DESTDIR="${pkgdir}" libexecdir="/usr/lib/qemu" install
+ # remove conflicting /var/run directory
+ rm -r "${pkgdir}/var"
+ install -D -m644 "${srcdir}/65-kvm.rules" \
+ "${pkgdir}/usr/lib/udev/rules.d/65-kvm.rules"
+ # bridge_helper needs suid
+ # https://bugs.archlinux.org/task/32565
+ chmod u+s "${pkgdir}/usr/lib/qemu/qemu-bridge-helper"
+ # add sample config
+ mkdir -p ${pkgdir}/etc/qemu/
+ echo "allow br0" > ${pkgdir}/etc/qemu/bridge.conf.sample
+}
diff --git a/qemu.install b/qemu.install
new file mode 100644
index 000000000000..7a384814cb3b
--- /dev/null
+++ b/qemu.install
@@ -0,0 +1,26 @@
+# kvm: the new package version
+post_install() {
+ #
+ groupadd kvm -f -g 78
+ echo "As of revision 31714, there is no need to add -bios /usr/share/qemu/bios.bin"
+ echo "anymore to your qemu command line"
+}
+
+post_upgrade() {
+ if [ "$(vercmp $2 0.11)" -lt 0 ]; then
+ echo "With the release of qemu and qemu-kvm 0.12.X, the kqemu kernel module"
+ echo "is no longer supported and will be removed from the repositories. You"
+ echo "can safely uninstall it from your system."
+ fi
+ if [ "$(vercmp $2 1.3.1)" -lt 0 ]; then
+ echo "With the release of qemu 1.3.0, qemu-kvm binary is removed."
+ echo "You need to change the emulator path, if you use libvirt by using:"
+ echo "'virsh edit <vm-name>'"
+ fi
+}
+
+post_remove() {
+ #
+ groupdel kvm
+}
+