summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD57
2 files changed, 32 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7b328653a5e..49e90b349f42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qemu-user-static-bin
pkgdesc = A generic and open source machine emulator, statically linked
pkgver = 5.2
- pkgrel = 3
+ pkgrel = 4
url = http://wiki.qemu.org
arch = x86_64
arch = i686
@@ -11,11 +11,17 @@ pkgbase = qemu-user-static-bin
license = GPL2
license = LGPL2.1
depends = binfmt-qemu-static
- provides = qemu-user-static
provides = qemu-user
- conflicts = qemu-user-static
conflicts = qemu-user
- source = https://deb.debian.org/debian/pool/main/q/qemu/qemu-user-static_5.2+dfsg-6_amd64.deb
- sha256sums = SKIP
+ source_x86_64 = https://deb.debian.org/debian/pool/main/q/qemu/qemu-user-static_5.2+dfsg-9_amd64.deb
+ sha256sums_x86_64 = a3b74bc11b3ae2d9be96e9a013cbd3546ca9aa9c4ed9e95ab2d9945d32e7c2c4
+ source_i686 = https://deb.debian.org/debian/pool/main/q/qemu/qemu-user-static_5.2+dfsg-8_i386.deb
+ sha256sums_i686 = d7a8c166f0b5cf00e8aa1517bec5a420a5ce1a5b053919841d016b0c014aaa56
+ source_aarch64 = https://deb.debian.org/debian/pool/main/q/qemu/qemu-user-static_5.2+dfsg-9_arm64.deb
+ sha256sums_aarch64 = 7dadc7a82aaee50bf2f9c9a90ede89ef9d13a6bddf00a4ca00128a29639e60f8
+ source_armv7h = https://deb.debian.org/debian/pool/main/q/qemu/qemu-user-static_5.2+dfsg-9_armhf.deb
+ sha256sums_armv7h = 64c838f401913f56345dc084716ae78945721760dda124e4adca0fad0a892047
+ source_armv6h = https://deb.debian.org/debian/pool/main/q/qemu/qemu-user-static_5.2+dfsg-8_armel.deb
+ sha256sums_armv6h = ce920e7c532e090c46d78d2fbd370eaa40400078d929dfaecd0efa9dda686816
pkgname = qemu-user-static-bin
diff --git a/PKGBUILD b/PKGBUILD
index 8446e7fff090..4e7b42d6d451 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,53 +1,38 @@
-# Maintainer: Jerry <isjerryxiao at outlook dot com>
# Maintainer: Leonidas P. <jpegxguy at outlook dot com>
+# Maintainer: Jerry <isjerryxiao at outlook dot com>
# Contributor: Anes Belfodil <ans.belfodil at gmail dot com>
# Contributor: David Rheinsberg <david.rheinsberg at gmail dot com>
# Contributor: David Herrmann <dh.herrmann at gmail dot com>
_pkgname=qemu-user-static
-pkgdesc='A generic and open source machine emulator, statically linked'
-pkgver=5.2
-pkgrel=3
-
pkgname=$_pkgname-bin
+pkgver=5.2
+pkgrel=4
+pkgdesc='A generic and open source machine emulator, statically linked'
arch=('x86_64' 'i686' 'aarch64' 'armv7h' 'armv6h')
url="http://wiki.qemu.org"
license=('GPL2' 'LGPL2.1')
depends=('binfmt-qemu-static')
-makedepends=()
-provides=("$_pkgname" "qemu-user")
-conflicts=("$_pkgname" "qemu-user")
-
-pkgadditver="+dfsg-6"
-case $CARCH in
- # Add pkgadditver="something" to override for specific arch
- "x86_64") _debarch="amd64" ;;
- "i686") _debarch="i386" ;;
- "aarch64") _debarch="arm64" ;;
- "armv7h") _debarch="armhf" ;;
- "armv6h") _debarch="armel" ;;
- *) _debarch="$CARCH"
-esac
+provides=("qemu-user")
+conflicts=("qemu-user")
-source=("https://deb.debian.org/debian/pool/main/q/qemu/${_pkgname}_${pkgver}${pkgadditver}_${_debarch}.deb")
-sha256sums=("SKIP")
+_pkgadditver="+dfsg-8"
+source_i686=("https://deb.debian.org/debian/pool/main/q/qemu/${_pkgname}_${pkgver}${_pkgadditver}_i386.deb")
+source_armv6h=("https://deb.debian.org/debian/pool/main/q/qemu/${_pkgname}_${pkgver}${_pkgadditver}_armel.deb")
-prepare() {
- rm -Rf build
- mkdir build
-}
+_pkgadditver="+dfsg-9"
+source_x86_64=("https://deb.debian.org/debian/pool/main/q/qemu/${_pkgname}_${pkgver}${_pkgadditver}_amd64.deb")
+source_aarch64=("https://deb.debian.org/debian/pool/main/q/qemu/${_pkgname}_${pkgver}${_pkgadditver}_arm64.deb")
+source_armv7h=("https://deb.debian.org/debian/pool/main/q/qemu/${_pkgname}_${pkgver}${_pkgadditver}_armhf.deb")
-build() {
- cd build
- tar -xJf ../data.tar.xz -C .
-}
+sha256sums_x86_64=("a3b74bc11b3ae2d9be96e9a013cbd3546ca9aa9c4ed9e95ab2d9945d32e7c2c4")
+sha256sums_i686=("d7a8c166f0b5cf00e8aa1517bec5a420a5ce1a5b053919841d016b0c014aaa56")
+sha256sums_aarch64=("7dadc7a82aaee50bf2f9c9a90ede89ef9d13a6bddf00a4ca00128a29639e60f8")
+sha256sums_armv7h=("64c838f401913f56345dc084716ae78945721760dda124e4adca0fad0a892047")
+sha256sums_armv6h=("ce920e7c532e090c46d78d2fbd370eaa40400078d929dfaecd0efa9dda686816")
package() {
- cd build
-
- mkdir -p "$pkgdir"/usr/bin/
- cp usr/bin/qemu-*-static "$pkgdir"/usr/bin/
-
- mkdir -p "$pkgdir"/usr/share/man/man1
- cp usr/share/man/man1/qemu-*-static.1.gz "$pkgdir"/usr/share/man/man1/
+ cd "${pkgdir}"
+ tar -xf "${srcdir}/data.tar.xz" ./usr/bin ./usr/share/man
+ rm -r ./usr/share/man/man1/qemu-debootstrap.1.gz
}