summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD18
2 files changed, 20 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fa188d6b5006..1e016e5a7722 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qgis
pkgdesc = Geographic Information System (GIS) that supports vector, raster & database formats
- pkgver = 2.18.4
+ pkgver = 2.18.5
pkgrel = 1
url = http://qgis.org/
arch = i686
@@ -10,8 +10,6 @@ pkgbase = qgis
makedepends = gsl
makedepends = perl
makedepends = txt2tags
- makedepends = sip<4.19.1
- makedepends = python2-sip<4.19.1
depends = expat
depends = gcc-libs
depends = gdal
@@ -20,9 +18,9 @@ pkgbase = qgis
depends = libspatialite
depends = postgresql-libs
depends = proj
- depends = qca-qt4
- depends = qscintilla-qt4<2.10
depends = qt4
+ depends = qca-qt4
+ depends = qscintilla-qt4
depends = qwt
depends = qwtpolar
depends = spatialindex
@@ -30,10 +28,9 @@ pkgbase = qgis
depends = python2
depends = python2-httplib2
depends = python2-future
- depends = python2-qscintilla-qt4<2.10
+ depends = python2-qscintilla-qt4
depends = python2-sip
depends = python2-six
- depends = python-qscintilla-qt4-common<2.10
optdepends = gpsbabel: GPS Tool plugin
optdepends = gsl: Georeferencer plugin
optdepends = python2-jinja: MetaSearch plugin
@@ -45,8 +42,10 @@ pkgbase = qgis
optdepends = python2-psycopg2: Processing plugin
optdepends = python2-pyspatialite: Processing plugin
optdepends = python2-yaml: Processing plugin
- source = https://qgis.org/downloads/qgis-2.18.4.tar.bz2
- md5sums = 4b7607d66f1d91a827495facca487544
+ source = https://qgis.org/downloads/qgis-2.18.5.tar.bz2
+ source = https://src.fedoraproject.org/cgit/rpms/qgis.git/plain/qgis_sip-ftbfs.patch
+ md5sums = dd2fdd649613a9ff14f2e2da86a59aa5
+ md5sums = 0575d848604f0fc6dda0a643523e7e48
pkgname = qgis
diff --git a/PKGBUILD b/PKGBUILD
index f385a4e19a96..08942109b909 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,16 +12,16 @@
# You will also need to install osgearth-qt4 or fcgi, respectively, before building.
pkgname=qgis
-pkgver=2.18.4
+pkgver=2.18.5
pkgrel=1
pkgdesc='Geographic Information System (GIS) that supports vector, raster & database formats'
url='http://qgis.org/'
license=('GPL')
arch=('i686' 'x86_64')
depends=('expat' 'gcc-libs' 'gdal' 'geos' 'glibc' 'libspatialite' 'postgresql-libs' 'proj'
- 'qca-qt4' 'qscintilla-qt4<2.10' 'qt4' 'qwt' 'qwtpolar' 'spatialindex' 'sqlite'
- 'python2' 'python2-httplib2' 'python2-future' 'python2-qscintilla-qt4<2.10' 'python2-sip' 'python2-six' 'python-qscintilla-qt4-common<2.10')
-makedepends=('cmake' 'gsl' 'perl' 'txt2tags' 'sip<4.19.1' 'python2-sip<4.19.1')
+ 'qt4' 'qca-qt4' 'qscintilla-qt4' 'qwt' 'qwtpolar' 'spatialindex' 'sqlite'
+ 'python2' 'python2-httplib2' 'python2-future' 'python2-qscintilla-qt4' 'python2-sip' 'python2-six')
+makedepends=('cmake' 'gsl' 'perl' 'txt2tags')
optdepends=('gpsbabel: GPS Tool plugin'
'gsl: Georeferencer plugin'
'python2-jinja: MetaSearch plugin'
@@ -33,12 +33,18 @@ optdepends=('gpsbabel: GPS Tool plugin'
'python2-psycopg2: Processing plugin'
'python2-pyspatialite: Processing plugin'
'python2-yaml: Processing plugin')
-source=("https://qgis.org/downloads/$pkgname-$pkgver.tar.bz2")
-md5sums=('4b7607d66f1d91a827495facca487544')
+source=("https://qgis.org/downloads/$pkgname-$pkgver.tar.bz2"
+ "https://src.fedoraproject.org/cgit/rpms/qgis.git/plain/qgis_sip-ftbfs.patch")
+md5sums=('dd2fdd649613a9ff14f2e2da86a59aa5'
+ '0575d848604f0fc6dda0a643523e7e48')
prepare() {
cd $pkgname-$pkgver
+ # Fedora patch to fix with newer sip/pyqt4
+ sed -i '184,$d' ../qgis_sip-ftbfs.patch
+ patch -Np1 -i ../qgis_sip-ftbfs.patch
+
# Fix references to "python"
sed -i 's/\(env \|\/usr\/bin\/\)python$/&2/' $(find . -iname "*.py")