summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD6
-rw-r--r--qgroundcontrol-mavlink-warn.patch10
3 files changed, 20 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 72dabcdc7fd5..7437f73d819a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qgroundcontrol
pkgdesc = Micro air vehicle ground control station.
- pkgver = 3.5.4
+ pkgver = 3.5.5
pkgrel = 1
url = http://qgroundcontrol.org/
arch = x86_64
@@ -39,10 +39,11 @@ pkgbase = qgroundcontrol
depends = qt5-quickcontrols2
depends = qt5-location
depends = qt5-svg
- source = qgroundcontrol-3.5.4.tar.gz::https://github.com/mavlink/qgroundcontrol/archive/v3.5.4.tar.gz
- source = mavlink-v2.0-qgc3.5.4.zip::https://github.com/mavlink/c_library_v2/archive/d240d0986710045663894aebcea89e71ce981ee4.zip
- source = gps-drivers-qgc3.5.4.zip::https://github.com/PX4/GpsDrivers/archive/2a4865adc3808687d6c6f550f497a02eb920c382.zip
- sha256sums = 653f8e47b6452f3b3d5c3a073834468342a2af9783c6db1b8a1859e9f2abc2a9
+ depends = qt5-graphicaleffects
+ source = qgroundcontrol-3.5.5.tar.gz::https://github.com/mavlink/qgroundcontrol/archive/v3.5.5.tar.gz
+ source = mavlink-v2.0-qgc3.5.5.zip::https://github.com/mavlink/c_library_v2/archive/d240d0986710045663894aebcea89e71ce981ee4.zip
+ source = gps-drivers-qgc3.5.5.zip::https://github.com/PX4/GpsDrivers/archive/2a4865adc3808687d6c6f550f497a02eb920c382.zip
+ sha256sums = 0fa99ea10d9d82ab5702cf9f1fd694ecc2656e89c5a83b15a3174c7fd9ec8852
sha256sums = 65c0fc60be9435375f74990a5c83fb0cdef6d15c100245759d2465d480a5b9b5
sha256sums = 1ab58c633edcfff9288bd868bf33e2c9990afa27fa5df8f1731675d98a4ce6e4
diff --git a/PKGBUILD b/PKGBUILD
index d5272e1adc6d..6729c5b41cbc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: K. Morton <pryre.dev@outlook.com>
# Contributor: Anselmo L. S. Melo <anselmo.melo@intel.com>
pkgname=qgroundcontrol
-pkgver=3.5.4
+pkgver=3.5.5
pkgrel=1
pkgdesc="Micro air vehicle ground control station."
arch=('x86_64')
@@ -44,6 +44,7 @@ depends=('bzip2'
'qt5-quickcontrols2'
'qt5-location'
'qt5-svg'
+ 'qt5-graphicaleffects'
)
makedepends=('git' 'qt5-base')
@@ -53,7 +54,7 @@ source=("qgroundcontrol-${pkgver}.tar.gz::https://github.com/mavlink/qgroundcont
"gps-drivers-qgc${pkgver}.zip::https://github.com/PX4/GpsDrivers/archive/${pkgver_gps}.zip"
)
-sha256sums=('653f8e47b6452f3b3d5c3a073834468342a2af9783c6db1b8a1859e9f2abc2a9'
+sha256sums=('0fa99ea10d9d82ab5702cf9f1fd694ecc2656e89c5a83b15a3174c7fd9ec8852'
'65c0fc60be9435375f74990a5c83fb0cdef6d15c100245759d2465d480a5b9b5'
'1ab58c633edcfff9288bd868bf33e2c9990afa27fa5df8f1731675d98a4ce6e4'
)
@@ -75,6 +76,7 @@ prepare() {
cd "${srcdir}/${pkgname}-${pkgver}/"
patch --strip=1 < "${startdir}/${pkgname}-libicudata.patch"
+ patch --strip=1 < "${startdir}/${pkgname}-mavlink-warn.patch"
}
build() {
diff --git a/qgroundcontrol-mavlink-warn.patch b/qgroundcontrol-mavlink-warn.patch
new file mode 100644
index 000000000000..4bf9ba758eb5
--- /dev/null
+++ b/qgroundcontrol-mavlink-warn.patch
@@ -0,0 +1,10 @@
+--- qgroundcontrol-3.5.5/QGCCommon.pri.old 2019-10-21 11:49:43.026322877 +1000
++++ qgroundcontrol-3.5.5/QGCCommon.pri 2019-10-21 11:49:33.886275250 +1000
+@@ -26,6 +26,7 @@
+ message("Linux clang")
+ QMAKE_CXXFLAGS += -Qunused-arguments -fcolor-diagnostics
+ }
++ QMAKE_CXXFLAGS += -Wno-address-of-packed-member
+ } else : linux-rasp-pi2-g++ {
+ message("Linux R-Pi2 build")
+ CONFIG += LinuxBuild