summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD20
2 files changed, 12 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 14ebc90ee456..bd389ae5eb29 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qimgv
pkgdesc = Qt5 image viewer with experimental webm playback
- pkgver = 0.6.3
+ pkgver = 0.7
pkgrel = 1
url = https://github.com/easymodo/qimgv
arch = x86_64
@@ -12,10 +12,8 @@ pkgbase = qimgv
depends = qt5-imageformats
depends = qt5-svg
depends = mpv
- provides = qimgv
- conflicts = qimgv
- source = https://github.com/easymodo/qimgv/archive/v0.6.3.tar.gz
- md5sums = ab8056ccefda185f685fecb86d109e59
+ source = qimgv-0.7.tar.gz::https://github.com/easymodo/qimgv/archive/v0.7.tar.gz
+ md5sums = f919ba5c0647b62a7e0118746ec846f0
pkgname = qimgv
diff --git a/PKGBUILD b/PKGBUILD
index 490b80450649..a245327b4d81 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,24 @@
# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
pkgname=qimgv
-pkgver=0.6.3
+pkgver=0.7
pkgrel=1
pkgdesc="Qt5 image viewer with experimental webm playback"
-arch=('x86_64' 'i686')
+arch=(x86_64 i686)
url="https://github.com/easymodo/qimgv"
license=(GPL3)
-depends=('qt5-base' 'qt5-imageformats' 'qt5-svg' 'mpv')
-makedepends=('cmake' 'qt5-tools')
-provides=('qimgv')
-conflicts=('qimgv')
-source=("https://github.com/easymodo/qimgv/archive/v${pkgver}.tar.gz")
-md5sums=('ab8056ccefda185f685fecb86d109e59')
+depends=(qt5-base qt5-imageformats qt5-svg mpv)
+makedepends=(cmake qt5-tools)
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/easymodo/qimgv/archive/v${pkgver}.tar.gz")
+md5sums=('f919ba5c0647b62a7e0118746ec846f0')
prepare() {
- cd ${srcdir}/${pkgname}-${pkgver}
+ cd "${srcdir}/${pkgname}-${pkgver}"
install -d build
}
build() {
- cd ${srcdir}/${pkgname}-${pkgver}/build
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
cmake .. \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr
@@ -28,6 +26,6 @@ build() {
}
package() {
- cd ${srcdir}/${pkgname}-${pkgver}/build
+ cd "${srcdir}/${pkgname}-${pkgver}/build"
make DESTDIR=${pkgdir} install
}