summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD11
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 60d8505fa4dc..169cf2630b96 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qimgv
pkgdesc = Qt5 image viewer with experimental webm playback
- pkgver = 0.7.3
+ pkgver = 0.8.2
pkgrel = 1
url = https://github.com/easymodo/qimgv
arch = x86_64
@@ -15,8 +15,9 @@ pkgbase = qimgv
depends = qt5-imageformats
depends = qt5-svg
depends = mpv
- source = qimgv-0.7.3.tar.gz::https://github.com/easymodo/qimgv/archive/v0.7.3.tar.gz
- sha256sums = f5c9e4dfdc0e9842c6cec5d2d546e6f77b2c33312f5cb416eaf50a29a0dc65a1
+ depends = exiv2
+ source = qimgv-0.8.2.tar.gz::https://github.com/easymodo/qimgv/archive/v0.8.2.tar.gz
+ sha256sums = a0edf03f71ea94d1bcd441cd21b8bb1eef07db27e2e8abf469449479c32479f8
pkgname = qimgv
diff --git a/PKGBUILD b/PKGBUILD
index 0c9ea1e33786..9c9ad0fc559a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,18 @@
# Maintainer: Fabio 'Lolix' Loli <lolix@disroot.org> -> https://github.com/FabioLolix
pkgname=qimgv
-pkgver=0.7.3
+pkgver=0.8.2
pkgrel=1
pkgdesc="Qt5 image viewer with experimental webm playback"
arch=(x86_64 i686 armv6h armv7h aarch64)
url="https://github.com/easymodo/qimgv"
license=(GPL3)
-depends=(qt5-base qt5-imageformats qt5-svg mpv)
+depends=(qt5-base qt5-imageformats qt5-svg mpv exiv2)
makedepends=(cmake qt5-tools)
+optdepednds=('qt5-apng-plugin: animated png support'
+ 'qtraw: raw images support')
source=("${pkgname}-${pkgver}.tar.gz::https://github.com/easymodo/qimgv/archive/v${pkgver}.tar.gz")
-sha256sums=('f5c9e4dfdc0e9842c6cec5d2d546e6f77b2c33312f5cb416eaf50a29a0dc65a1')
+sha256sums=('a0edf03f71ea94d1bcd441cd21b8bb1eef07db27e2e8abf469449479c32479f8')
prepare() {
cd "${srcdir}/${pkgname}-${pkgver}"
@@ -22,7 +24,8 @@ build() {
cmake .. \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DVIDEO_SUPPORT=ON
+ -DCMAKE_INSTALL_LIBDIR=lib
+
make
}