summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD47
-rw-r--r--qliveplayer.desktop9
3 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6fa78f128f24
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = qliveplayer-git
+ pkgdesc = Cute and useful Live Stream Player with danmaku support.
+ pkgver = 3.3.0.r0.g5c898b5
+ pkgrel = 1
+ url = https://github.com/IsoaSFlus/QLivePlayer
+ arch = x86_64
+ license = GPL2
+ makedepends = cmake
+ makedepends = git
+ makedepends = extra-cmake-modules
+ makedepends = qt5-base
+ depends = mpv
+ depends = ffmpeg
+ depends = python-aiohttp
+ depends = qt5-quickcontrols2
+ depends = python
+ depends = ykdl-git
+ source = QLivePlayer::git+https://github.com/IsoaSFlus/QLivePlayer.git
+ source = qliveplayer.desktop
+ sha256sums = SKIP
+ sha256sums = 50d922dc6454f3b589d410de8a6468b300412aa3eb0297cb18242b97a0118ee4
+
+pkgname = qliveplayer-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ed87c612a74
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Megumi_fox <i@megumifox.com>
+
+pkgname=qliveplayer-git
+pkgver=3.3.0.r0.g5c898b5
+pkgrel=1
+pkgdesc='Cute and useful Live Stream Player with danmaku support.'
+arch=('x86_64')
+url="https://github.com/IsoaSFlus/QLivePlayer"
+license=('GPL2')
+depends=('mpv'
+ 'ffmpeg'
+ 'python-aiohttp'
+ 'qt5-quickcontrols2'
+ 'python'
+ 'ykdl-git')
+makedepends=('cmake'
+ 'git'
+ 'extra-cmake-modules'
+ 'qt5-base')
+source=(
+ "QLivePlayer::git+https://github.com/IsoaSFlus/QLivePlayer.git"
+ "qliveplayer.desktop"
+)
+
+pkgver() {
+ cd QLivePlayer
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+sha256sums=('SKIP'
+ '50d922dc6454f3b589d410de8a6468b300412aa3eb0297cb18242b97a0118ee4')
+
+build() {
+ cd $srcdir/QLivePlayer
+ mkdir -p build
+ cd build
+ cmake -DCMAKE_INSTALL_PREFIX="$pkgdir/usr" -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_LIBDIR=lib ..
+ make
+}
+
+package() {
+ cd $srcdir/QLivePlayer/build
+ make install
+
+ install -d "$pkgdir/usr/share/applications"
+ install -m644 "$srcdir/qliveplayer.desktop" "$pkgdir/usr/share/applications/qliveplayer.desktop"
+}
diff --git a/qliveplayer.desktop b/qliveplayer.desktop
new file mode 100644
index 000000000000..acba07cfe475
--- /dev/null
+++ b/qliveplayer.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Version=0.0.1
+Name=QLivePlayer
+Comment=A cute and useful Live Stream Player with danmaku support
+Exec=qliveplayer
+Terminal=false
+Type=Application
+Categories=AudioVideo;Audio;Video;Player;TV;
+