summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rwxr-xr-xPKGBUILD23
2 files changed, 16 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cda9c9cccd25..aeb2ccf60b1f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Tue Aug 23 10:43:03 UTC 2016
pkgbase = qmlfmt-git
pkgdesc = Command line application that formats QML files
- pkgver = 0.1.0.r12.e0f7ec7
+ pkgver = r41.ae27bff
pkgrel = 1
url = https://github.com/jesperhh/qmlfmt
arch = i686
@@ -15,7 +13,7 @@ pkgbase = qmlfmt-git
depends = qt5-base
provides = qmlfmt
conflicts = qmlfmt
- source = git://github.com/jesperhh/qmlfmt.git
+ source = git+https://github.com/jesperhh/qmlfmt.git
sha512sums = SKIP
pkgname = qmlfmt-git
diff --git a/PKGBUILD b/PKGBUILD
index 37cf22aaa3d3..05476d10c8ab 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,9 @@
-# Maintainer: Michael Yang <ohmyarchlinux@gmail.com>
+# Maintainer: Nico <d3sox at protonmail dot com>
+# Contributor Michael Yang <ohmyarchlinux@gmail.com>
pkgname=qmlfmt-git
-pkgver=0.1.0.r12.e0f7ec7
+_gitname=${pkgname%-git}
+pkgver=r41.ae27bff
pkgrel=1
pkgdesc="Command line application that formats QML files"
arch=('i686' 'x86_64')
@@ -11,27 +13,30 @@ depends=('qt5-base')
makedepends=('git' 'cmake>=3.0' 'qt5-script' 'qt5-declarative')
conflicts=('qmlfmt')
provides=('qmlfmt')
-source=("git://github.com/jesperhh/qmlfmt.git")
+source=("git+https://github.com/jesperhh/${_gitname}.git")
sha512sums=('SKIP')
pkgver() {
- cd qmlfmt
- echo "0.1.0.r$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+ cd "${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
prepare() {
+ cd "${_gitname}"
+ git submodule update --init qt-creator
mkdir -p build
}
build() {
- cd build
- cmake ../qmlfmt \
+ cd "${_gitname}/build"
+ cmake .. \
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr
make
}
package() {
- mkdir -p ${pkgdir}/usr/bin
- cp build/qmlfmt ${pkgdir}/usr/bin
+ cd "${_gitname}"
+ mkdir -p "${pkgdir}/usr/bin"
+ install -Dm 755 build/qmlfmt "${pkgdir}/usr/bin"
}