summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD48
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..706941cfbeaf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = qmodbus-git
+ pkgdesc = QModBus is a free Qt-based implementation of a ModBus master application. A graphical user interface allows easy communication with ModBus slaves over serial line interface. QModBus also includes a bus monitor for examining all traffic on the bus.
+ pkgver = r125.2186db8
+ pkgrel = 1
+ url = http://qmodbus.sourceforge.net/
+ arch = x86_64
+ arch = i686
+ license = GPLv2
+ makedepends = git
+ depends = qt4
+ source = git+https://github.com/ed-chemnitz/qmodbus.git
+ md5sums = SKIP
+
+pkgname = qmodbus-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..127c7ee0d93b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Christopher Hamilton <marker5a@gmail.com>
+
+pkgname=qmodbus-git
+_gitname=qmodbus
+pkgver=r125.2186db8
+pkgrel=1
+pkgdesc='QModBus is a free Qt-based implementation of a ModBus master application. A graphical user interface allows easy communication with ModBus slaves over serial line interface. QModBus also includes a bus monitor for examining all traffic on the bus.'
+arch=('x86_64' 'i686')
+url='http://qmodbus.sourceforge.net/'
+
+license=('GPLv2')
+depends=('qt4')
+makedepends=('git')
+optdepends=()
+provides=()
+conflicts=()
+
+source=('git+https://github.com/ed-chemnitz/qmodbus.git')
+md5sums=('SKIP')
+pkgver() {
+ cd "$srcdir/$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$srcdir/$_gitname"
+
+ qmake-qt4 .
+ make
+}
+
+package() {
+
+
+ mkdir -p "$pkgdir/usr/share/qmodbus/build/"
+ mkdir -p "$pkgdir/usr/share/qmodbus/data/"
+ mkdir -p "$pkgdir/usr/share/applications"
+ mkdir -p "$pkgdir/usr/bin"
+
+ cp "$srcdir/$_gitname/QModBus" "$pkgdir/usr/share/qmodbus/build/qmodbus"
+ cp "$srcdir/$_gitname/data/logo.png" "$pkgdir/usr/share/qmodbus/data/"
+ cp "$srcdir/$_gitname/qmodbus.desktop" "$pkgdir/usr/share/applications/"
+
+ ln -s "/usr/share/qmodbus/build/qmodbus" "$pkgdir/usr/bin/qmodbus"
+
+}
+
+# vim:set ts=2 sw=2 et: