summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD41
-rw-r--r--get_qsci.sh.patch11
-rw-r--r--qscite.pro.patch38
4 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..903f1c3cc8ea
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = qscite
+ pkgdesc = A code editor written in C++ and Qt4; A clone of SciTE
+ pkgver = 0.5_svn211
+ pkgrel = 2
+ url = http://qscite.googlecode.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = qt4
+ source = http://qscite.googlecode.com/files/qscite-r211.tar.gz
+ source = get_qsci.sh.patch
+ source = qscite.pro.patch
+ md5sums = 2ce7a915e5560725d897816688a4bef7
+ md5sums = 0bb49a6179912d6d0b674c5623a45a34
+ md5sums = c13cc624b2ed1ce7a980afbb2d2bbc15
+
+pkgname = qscite
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ba16c8442e4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Evgeniy Alekseev <esalexeev@gmail.com>
+
+pkgname=qscite
+pkgver=0.5_svn211
+_pkgrev=211
+pkgrel=2
+pkgdesc="A code editor written in C++ and Qt4; A clone of SciTE"
+arch=('i686' 'x86_64')
+url="http://qscite.googlecode.com/"
+license=('GPL')
+depends=('qt4')
+source=(http://qscite.googlecode.com/files/${pkgname}-r${_pkgrev}.tar.gz
+ get_qsci.sh.patch
+ qscite.pro.patch)
+md5sums=('2ce7a915e5560725d897816688a4bef7'
+ '0bb49a6179912d6d0b674c5623a45a34'
+ 'c13cc624b2ed1ce7a980afbb2d2bbc15')
+
+prepare()
+{
+ cd "${srcdir}/${pkgname}"
+ # fix scintilla2 download path
+ patch -p0 < "${srcdir}/get_qsci.sh.patch"
+ # add install section and fix filepath
+ patch -p0 < "${srcdir}/qscite.pro.patch"
+ # fix version
+ sed -i "s#0.5-svn190#${pkgver//_/-}#" qscite.desktop
+}
+
+build()
+{
+ cd "${srcdir}/${pkgname}"
+ qmake-qt4 PREFIX=/usr -Wnone qscite-release.pro
+ make
+}
+
+package()
+{
+ cd "${srcdir}/${pkgname}"
+ make INSTALL_ROOT="${pkgdir}" install
+}
diff --git a/get_qsci.sh.patch b/get_qsci.sh.patch
new file mode 100644
index 000000000000..0104f79b491a
--- /dev/null
+++ b/get_qsci.sh.patch
@@ -0,0 +1,11 @@
+--- get_qsci.sh.old 2011-03-22 15:20:40.000000000 +0300
++++ get_qsci.sh 2013-09-17 01:46:11.755695009 +0400
+@@ -6,7 +6,7 @@
+ /snapshot/ {next}
+ /tar\.gz/ { print $2 }
+ ' )
+-_download_link="http://www.riverbankcomputing.co.uk$_download_path"
++_download_link=`echo $_download_path | sed "s#http://#http://optimate.dl.#" | sed "s#projects/pyqt/files#project/pyqt#"`
+ _archive_filename=$( basename "$_download_path" )
+ _archive_dir=$( echo "$_archive_filename" | sed 's/.tar.gz//' )
+ _archive_size=$(
diff --git a/qscite.pro.patch b/qscite.pro.patch
new file mode 100644
index 000000000000..10d62e04401f
--- /dev/null
+++ b/qscite.pro.patch
@@ -0,0 +1,38 @@
+--- qscite.pro.old 2011-03-22 15:20:40.000000000 +0300
++++ qscite.pro 2013-09-17 02:36:51.998947959 +0400
+@@ -13,14 +13,14 @@
+ }
+
+ unix {
+- qsci_project.target = QScintilla2/Qt4/qscintilla.pro
++ qsci_project.target = QScintilla2/Qt4Qt5/qscintilla.pro
+ qsci_project.commands = ./get_qsci.sh
+
+ qsci_lib.target = $$OBJECTS_DIR/libqscintilla2.a
+- qsci_lib.commands = cd QScintilla2/Qt4 &&
++ qsci_lib.commands = cd QScintilla2/Qt4Qt5 &&
+ qsci_lib.commands += $(QMAKE) -after \"CONFIG += static\" qscintilla.pro &&
+ qsci_lib.commands += $(MAKE) &&
+- qsci_lib.commands += cd ../.. && cp QScintilla2/Qt4/libqscintilla2.a $(OBJECTS_DIR)
++ qsci_lib.commands += cd ../.. && cp QScintilla2/Qt4Qt5/libqscintilla2.a $(OBJECTS_DIR)
+ qsci_lib.depends = qsci_project
+
+ QMAKE_EXTRA_TARGETS += qsci_project qsci_lib
+@@ -68,11 +68,16 @@
+ unix {
+ HEADERS += qterminal_pty.h
+ SOURCES += qterminal_pty.cpp
+- INCLUDEPATH += QScintilla2/Qt4
++ INCLUDEPATH += QScintilla2/Qt4Qt5
+ LIBS += build/libqscintilla2.a
+ !macx {
+ LIBS += -lutil
+ DEFINES += QSCITE_MONO_FAMILY='\\"Monospace\\"'
++ TARGET = qscite
++ target.path = $$PREFIX/bin/
++ desktopfile.files = qscite.desktop
++ desktopfile.path = $$PREFIX/share/applications/
++ INSTALLS += target desktopfile
+ } else {
+ TARGET = QSciTE
+ DEFINES += QSCITE_MONO_FAMILY='\\"Monaco\\"'