summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO15
-rwxr-xr-xPKGBUILD80
-rw-r--r--qsyncthingtray.desktop4
3 files changed, 54 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 99306e347b00..d204f5e51235 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,22 @@
pkgbase = qsyncthingtray-git
- pkgdesc = Syncs files among devices, and shows the sync status on a tray icon. Version with the latest unreleased improvements.
- pkgver = 421
- pkgrel = 3
+ pkgdesc = Tray icon for syncthing (master branch)
+ pkgver = 0.5.8.r17.g11936bc
+ pkgrel = 4
url = https://github.com/sieren/QSyncthingTray
arch = i686
arch = x86_64
- license = LGPL3
- makedepends = cmake
+ license = LGPL3.0
makedepends = git
+ makedepends = cmake
depends = qt5-location
depends = qt5-webengine
- depends = startup-settings-git
depends = syncthing
provides = qsyncthingtray
conflicts = qsyncthingtray
- source = git+https://github.com/sieren/QSyncthingTray.git
+ source = qsyncthingtray::git+https://github.com/sieren/QSyncthingTray.git
source = qsyncthingtray.desktop
md5sums = SKIP
- md5sums = SKIP
+ md5sums = 730d2ae862656d39f7b1980f20d8d8bf
pkgname = qsyncthingtray-git
diff --git a/PKGBUILD b/PKGBUILD
index 1df747a0c15f..4d8caa0ef4a8 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,44 +1,54 @@
-#! /bin/bash
-
-Name="QSyncthingTray"
-LowercaseName=$(echo "${Name,,}")
-pkgname="${LowercaseName}-git"
-provides=("${LowercaseName}")
-conflicts=("${LowercaseName}")
-
-pkgdesc="Syncs files among devices, and shows the sync status on a tray icon. Version with the latest unreleased improvements."
-url="https://github.com/sieren/${Name}"
-license=("LGPL3")
-
-pkgver=421
-pkgrel=3
-arch=("i686" "x86_64")
-
-makedepends=("cmake" "git")
-depends=("qt5-location" "qt5-webengine" "startup-settings-git" "syncthing")
-source=("git+${url}.git" "${LowercaseName}.desktop")
-md5sums=("SKIP" "SKIP")
-
-
-pkgver () {
- cd "${Name}"
- git rev-list --count HEAD
+# Maintainer: Matthias Jaros <jaros@mailbox.org>
+# Contributor: Alberto Salvia Novella <es20490446e@gmail.com>
+pkgname=qsyncthingtray-git
+pkgver=0.5.8.r17.g11936bc
+pkgrel=4
+pkgdesc="Tray icon for syncthing (master branch)"
+arch=('i686' 'x86_64')
+url="https://github.com/sieren/QSyncthingTray"
+license=('LGPL3.0')
+groups=()
+depends=('qt5-location' 'qt5-webengine' 'syncthing')
+makedepends=('git' 'cmake')
+provides=("${pkgname%-git}")
+conflicts=("qsyncthingtray")
+replaces=()
+backup=()
+options=()
+install=
+source=("${pkgname%-git}::git+https://github.com/sieren/QSyncthingTray.git"
+ "${pkgname%-git}.desktop")
+noextract=()
+md5sums=('SKIP'
+ '730d2ae862656d39f7b1980f20d8d8bf')
+_pkgname=QSyncthingTray
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tag 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//'
}
+prepare() {
+ cd "$srcdir/${pkgname%-git}"
+ [ -d build ] || mkdir build
+}
build() {
- cd "${srcdir}/${Name}"
- mkdir "build"
- cd "build"
-
- cmake ".."
+ cd "$srcdir/${pkgname%-git}/build"
+ QTDIR=/usr/lib/qt cmake ..
make
}
-
-package() {
- install -Dm755 "${srcdir}/${Name}/build/${Name}" "${pkgdir}/usr/bin/${LowercaseName}"
- install -Dm644 "${srcdir}/${Name}/resources/images/Icon1024.png" "${pkgdir}/usr/share/pixmaps/${LowercaseName}.png"
- install -Dm644 "${srcdir}/${LowercaseName}.desktop" "${pkgdir}/usr/share/applications/${LowercaseName}.desktop"
+check() {
+ cd "$srcdir/${pkgname%-git}/build"
+ [ -f "$_pkgname" ] || exit 1
}
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ install -Dm755 "build/$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+
+ # install .desktop file
+ install -Dm755 "$srcdir/${pkgname%-git}.desktop" "$pkgdir/usr/share/applications/${pkgname%-git}.desktop"
+ install -Dm755 "resources/images/Icon1024.png" "$pkgdir/usr/share/pixmaps/${pkgname%-git}.png"
+} \ No newline at end of file
diff --git a/qsyncthingtray.desktop b/qsyncthingtray.desktop
index 95343106d508..9b0b29adc736 100644
--- a/qsyncthingtray.desktop
+++ b/qsyncthingtray.desktop
@@ -1,7 +1,7 @@
[Desktop Entry]
Name=QSyncthingTray
-Comment=Syncs files among devices
-Exec=qsyncthingtray %U
+Comment=Desktop wrapper for Syncthing
+Exec=QSyncthingTray %U
Icon=qsyncthingtray
StartupNotify=false
Categories=Network;Internet;