summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..431b1cc4d635
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = qsynth-git
+ pkgdesc = A fluidsynth Qt GUI Interface (GIT version)
+ pkgver = r531.999e198
+ pkgrel = 1
+ url = https://qsynth.sourceforge.io/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = qt5-tools
+ depends = fluidsynth
+ depends = qt5-x11extras
+ provides = qsynth
+ conflicts = qsynth
+ source = qsynth::git+https://git.code.sf.net/p/qsynth/code
+ sha256sums = SKIP
+
+pkgname = qsynth-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..764b7ad0bde5
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Konstantinos Foutzopoulos <mail@konfou.xyz>
+
+_pkgname=qsynth
+pkgname=${_pkgname}-git
+pkgver=r531.999e198
+pkgrel=1
+pkgdesc="A fluidsynth Qt GUI Interface (GIT version)"
+arch=('i686' 'x86_64')
+url="https://qsynth.sourceforge.io/"
+license=('GPL2')
+depends=('fluidsynth' 'qt5-x11extras')
+makedepends=('qt5-tools')
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+https://git.code.sf.net/p/${_pkgname}/code")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ${_pkgname}
+ git describe --long | sed -e 's/qsynth_//;s/_/./g;s/-/.r/;s/-/./'
+}
+
+build() {
+ cd ${_pkgname}
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr \
+ -DCMAKE_BUILD_TYPE=release
+ make
+}
+
+package() {
+ cd ${_pkgname}
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et: