summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 5 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 421bf073f978..3d3b7ad8df4b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qt-heic-image-plugin
pkgdesc = Qt plug-in to allow Qt and KDE based applications to read/write HEIF/HEIC images.
pkgver = 0.3.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/novomesk/qt-heic-image-plugin
arch = x86_64
license = LGPL-2.1-only
@@ -11,7 +11,7 @@ pkgbase = qt-heic-image-plugin
makedepends = qt6-base
depends = libheif
source = https://github.com/novomesk/qt-heic-image-plugin/archive/refs/tags/v0.3.1.tar.gz
- source = 0001-Add-QT_MAJOR_VERSION.diff::https://github.com/arenekosreal/qt-heic-image-plugin/commit/dada91b071b6f2900638fd0f3ea8eb82b6de479b.diff
+ source = 0001-Add-QT_MAJOR_VERSION.diff::https://github.com/novomesk/qt-heic-image-plugin/commit/dada91b071b6f2900638fd0f3ea8eb82b6de479b.diff
sha256sums = f3e611cecb4918cb17d089e1912451b2ec42cb1f9efc496428b219f78a334cb6
sha256sums = 1ddadd5676f43fdd11d3a452eae253699b64baf213d13942f44cb6c87b3dccfd
diff --git a/PKGBUILD b/PKGBUILD
index 37b5e8103cd0..f99b27fb57e2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
pkgbase=qt-heic-image-plugin
pkgname=(qt5-heic-image-plugin qt6-heic-image-plugin)
pkgver=0.3.1
-pkgrel=2
+pkgrel=3
pkgdesc="Qt plug-in to allow Qt and KDE based applications to read/write HEIF/HEIC images."
arch=("x86_64")
url="https://github.com/novomesk/qt-heic-image-plugin"
@@ -11,7 +11,7 @@ makedepends=(cmake extra-cmake-modules qt5-base qt6-base)
source=(
"$url/archive/refs/tags/v$pkgver.tar.gz"
# Add QT_MAJOR_VERSION to switch between qt versions easily
- "0001-Add-QT_MAJOR_VERSION.diff::https://github.com/arenekosreal/qt-heic-image-plugin/commit/dada91b071b6f2900638fd0f3ea8eb82b6de479b.diff")
+ "0001-Add-QT_MAJOR_VERSION.diff::https://github.com/novomesk/qt-heic-image-plugin/commit/dada91b071b6f2900638fd0f3ea8eb82b6de479b.diff")
sha256sums=('f3e611cecb4918cb17d089e1912451b2ec42cb1f9efc496428b219f78a334cb6'
'1ddadd5676f43fdd11d3a452eae253699b64baf213d13942f44cb6c87b3dccfd')
@@ -30,6 +30,7 @@ build() {
msg2 "Building QT6 version..."
cmake -B build-qt6 -S qt-heic-image-plugin-$pkgver \
+ -DCMAKE_SKIP_INSTALL_RPATH=ON \
-DCMAKE_INSTALL_PREFIX="/usr" \
-DCMAKE_BUILD_TYPE=None \
-DQT_MAJOR_VERSION=6