summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD14
2 files changed, 11 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e77e09538161..2f675f0955b5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = qt-ponies-git
pkgdesc = Desktop ponies in Qt
- pkgver = v0.9.3.g882a8cf
- pkgrel = 3
+ pkgver = 0.9.r3.g882a8cf
+ pkgrel = 1
url = https://github.com/myszha/qt-ponies
- arch = i686
arch = x86_64
- license = GPL
+ license = GPL-3.0-or-later
makedepends = git
depends = qt5-base
depends = libxfixes
provides = qt-ponies
- source = git://github.com/myszha/qt-ponies.git
+ source = git+https://github.com/myszha/qt-ponies.git
source = qt-ponies-qt5.patch
source = qt-ponies-qt5.14.patch
sha256sums = SKIP
@@ -18,4 +17,3 @@ pkgbase = qt-ponies-git
sha256sums = cb7019e0dd6bdbf335ffd52748cd60a58e1ef15e81974b4db58fb5bee1db5f88
pkgname = qt-ponies-git
-
diff --git a/PKGBUILD b/PKGBUILD
index d7bb2943c21c..d7238dc2fd8e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
-# Maintainer: Daniel Maslowski <info@oragnecms.org>
+# Contributor: Daniel Maslowski <info@oragnecms.org>
# Contributor: mid-kid <esteve.varela@gmail.com>
# based on https://github.com/aur-archive/qt-ponies-git/blob/master/PKGBUILD
_gitname="qt-ponies"
pkgname=qt-ponies-git
-pkgver=v0.9.3.g882a8cf
-pkgrel=3
+pkgver=0.9.r3.g882a8cf
+pkgrel=1
pkgdesc="Desktop ponies in Qt"
-arch=("i686" "x86_64")
+arch=("x86_64")
url="https://github.com/myszha/qt-ponies"
-license=('GPL')
+license=('GPL-3.0-or-later')
depends=("qt5-base" "libxfixes")
makedepends=("git")
provides=("qt-ponies")
source=(
- "git://github.com/myszha/$_gitname.git"
+ "git+${url}.git"
"qt-ponies-qt5.patch"
"qt-ponies-qt5.14.patch"
)
@@ -24,7 +24,7 @@ sha256sums=('SKIP'
pkgver() {
cd "$srcdir/$_gitname"
- git describe --tags | sed 's|-|.|g'
+ git describe --tags --long | sed 's/^v//;s/-/.r/;s/-/./g'
}
prepare() {