summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD36
2 files changed, 20 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3614f17877e5..6649836ce1b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qt5-datasync
pkgdesc = A simple offline-first synchronisation framework, to synchronize data of Qt applications between devices
pkgver = 3.0.1
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/Skycoder42/QtDataSync
arch = i686
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 29ef55cff0e5..b886f85a074b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,36 +1,38 @@
# Maintainer: Felix Barz <skycoder42.de@gmx.de>
pkgname=qt5-datasync
pkgver=3.0.1
-pkgrel=2
+pkgrel=3
pkgdesc="A simple offline-first synchronisation framework, to synchronize data of Qt applications between devices"
arch=('i686' 'x86_64')
url="https://github.com/Skycoder42/QtDataSync"
license=('BSD')
depends=('qt5-base' 'qt5-tools' 'qt5-jsonserializer>=2.1.0' 'qt5-backgroundprocess>=1.5.0' 'qt5-websockets')
makedepends=('git' 'qpm')
-source=("$pkgname-$pkgver::git+https://github.com/Skycoder42/QtDataSync.git#tag=$pkgver")
+_pkgfqn=$pkgname-$pkgver
+source=("$_pkgfqn::git+https://github.com/Skycoder42/QtDataSync.git#tag=$pkgver")
md5sums=('SKIP')
-build() {
- cd "$pkgname-$pkgver"
-
- cd src/3rdparty
+prepare() {
+ mkdir -p build
+
+ cd "$_pkgfqn/src/3rdparty"
qpm install
- cd ../..
+}
- qmake
- make qmake_all
+build() {
+ cd build
+
+ qmake -r "../$_pkgfqn/"
make
}
package() {
- cd "$pkgname-$pkgver"
-
+ cd build
make INSTALL_ROOT="$pkgdir" install
-
- FILE=$pkgdir/usr/lib/libQt5DataSync.prl
- tail -n +2 "$FILE" > "$FILE.tmp"
- mv "$FILE.tmp" "$FILE"
-
- install -D -m644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ install -D -m644 "../$_pkgfqn/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}