summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD18
-rw-r--r--logcat-include.patch12
3 files changed, 11 insertions, 30 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2552b3447123..6b29be7dfa3b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = qt5-datasync
pkgdesc = A simple offline-first synchronisation framework, to synchronize data of Qt applications between devices
- pkgver = 4.2.1
- pkgrel = 2
+ pkgver = 4.2.2
+ pkgrel = 1
url = https://github.com/Skycoder42/QtDataSync
arch = i686
arch = x86_64
license = BSD
makedepends = qt5-tools
makedepends = git
- makedepends = qpmx-qpmsource
+ makedepends = qdep
makedepends = qt5-declarative
makedepends = pkg-config
makedepends = python
@@ -26,14 +26,13 @@ pkgbase = qt5-datasync
optdepends = repkg: Automatically rebuild the package on dependency updates
optdepends = qt5-datasync-kwallet-keystore: Support for KWallet as keystore
optdepends = qt5-datasync-secret-keystore: Support for secret service as keystore (includes gnome keyring)
- source = qt5-datasync-4.2.1::git+https://github.com/Skycoder42/QtDataSync.git#tag=4.2.1
+ backup = etc/qdsapp.conf
+ source = qt5-datasync-4.2.2::git+https://github.com/Skycoder42/QtDataSync.git#tag=4.2.2
source = qt5-datasync.rule
source = subpkg.rule
- source = logcat-include.patch
sha256sums = SKIP
sha256sums = ba8f2e738359436ad1a4faa8ad6268372441c60a34363c13aa9f0eec5d0378cc
sha256sums = 321d7d24f490983f54acb9e7f58ebc2a170b520cd978c4989e28bc1a76513f3b
- sha256sums = 3d48ebbaccb4e7e349895b73289a04ebcfc53253cf07e9374a2f2edaebd9bd12
pkgname = qt5-datasync
diff --git a/PKGBUILD b/PKGBUILD
index fc4e23113b3c..d475202271f3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,41 +2,35 @@
pkgbase=qt5-datasync
pkgname=(qt5-datasync qt5-datasync-kwallet-keystore qt5-datasync-secret-keystore qt5-datasync-doc)
group=qt5-datasync-full
-pkgver=4.2.1
-pkgrel=2
+pkgver=4.2.2
+pkgrel=1
pkgdesc="A simple offline-first synchronisation framework, to synchronize data of Qt applications between devices"
arch=('i686' 'x86_64')
url="https://github.com/Skycoder42/QtDataSync"
license=('BSD')
depends=('qt5-base' 'qt5-jsonserializer' 'qt5-websockets' 'qt5-scxml' 'qt5-remoteobjects>=5.12.0' 'qt5-service>=1.1.0' 'crypto++')
-makedepends=('qt5-tools' 'git' 'qpmx-qpmsource' 'qt5-declarative' 'pkg-config' 'python' 'doxygen' 'graphviz' 'libsecret' 'kwallet')
+makedepends=('qt5-tools' 'git' 'qdep' 'qt5-declarative' 'pkg-config' 'python' 'doxygen' 'graphviz' 'libsecret' 'kwallet')
optdepends=("repkg: Automatically rebuild the package on dependency updates"
"qt5-datasync-kwallet-keystore: Support for KWallet as keystore"
"qt5-datasync-secret-keystore: Support for secret service as keystore (includes gnome keyring)")
_pkgfqn=$pkgname-$pkgver
source=("$_pkgfqn::git+https://github.com/Skycoder42/QtDataSync.git#tag=${pkgver}"
"${pkgname}.rule"
- "subpkg.rule"
- "logcat-include.patch")
+ "subpkg.rule")
sha256sums=('SKIP'
'ba8f2e738359436ad1a4faa8ad6268372441c60a34363c13aa9f0eec5d0378cc'
- '321d7d24f490983f54acb9e7f58ebc2a170b520cd978c4989e28bc1a76513f3b'
- '3d48ebbaccb4e7e349895b73289a04ebcfc53253cf07e9374a2f2edaebd9bd12')
+ '321d7d24f490983f54acb9e7f58ebc2a170b520cd978c4989e28bc1a76513f3b')
+backup=('etc/qdsapp.conf')
prepare() {
mkdir -p build
-
- cd "$_pkgfqn"
- git apply ../logcat-include.patch
}
build() {
cd build
qmake "CONFIG+=system_cryptopp install_system_service" "../$_pkgfqn/"
- make qmake_all
make
- make lrelease
make doxygen
}
diff --git a/logcat-include.patch b/logcat-include.patch
deleted file mode 100644
index 51d30477f601..000000000000
--- a/logcat-include.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/datasync/datatypestore.h b/src/datasync/datatypestore.h
-index f63f281..3734b6b 100644
---- a/src/datasync/datatypestore.h
-+++ b/src/datasync/datatypestore.h
-@@ -5,6 +5,7 @@
-
- #include <QtCore/qobject.h>
- #include <QtCore/qdebug.h>
-+#include <QtCore/qloggingcategory.h>
-
- #include "QtDataSync/qtdatasync_global.h"
- #include "QtDataSync/datastore.h"