summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD9
-rw-r--r--logcat-include.patch12
3 files changed, 21 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46f834a78779..2552b3447123 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qt5-datasync
pkgdesc = A simple offline-first synchronisation framework, to synchronize data of Qt applications between devices
pkgver = 4.2.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/Skycoder42/QtDataSync
arch = i686
arch = x86_64
@@ -29,9 +29,11 @@ pkgbase = qt5-datasync
source = qt5-datasync-4.2.1::git+https://github.com/Skycoder42/QtDataSync.git#tag=4.2.1
source = qt5-datasync.rule
source = subpkg.rule
+ source = logcat-include.patch
sha256sums = SKIP
sha256sums = ba8f2e738359436ad1a4faa8ad6268372441c60a34363c13aa9f0eec5d0378cc
sha256sums = 321d7d24f490983f54acb9e7f58ebc2a170b520cd978c4989e28bc1a76513f3b
+ sha256sums = 3d48ebbaccb4e7e349895b73289a04ebcfc53253cf07e9374a2f2edaebd9bd12
pkgname = qt5-datasync
diff --git a/PKGBUILD b/PKGBUILD
index ef9081fed486..fc4e23113b3c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgbase=qt5-datasync
pkgname=(qt5-datasync qt5-datasync-kwallet-keystore qt5-datasync-secret-keystore qt5-datasync-doc)
group=qt5-datasync-full
pkgver=4.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="A simple offline-first synchronisation framework, to synchronize data of Qt applications between devices"
arch=('i686' 'x86_64')
url="https://github.com/Skycoder42/QtDataSync"
@@ -16,15 +16,18 @@ optdepends=("repkg: Automatically rebuild the package on dependency updates"
_pkgfqn=$pkgname-$pkgver
source=("$_pkgfqn::git+https://github.com/Skycoder42/QtDataSync.git#tag=${pkgver}"
"${pkgname}.rule"
- "subpkg.rule")
+ "subpkg.rule"
+ "logcat-include.patch")
sha256sums=('SKIP'
'ba8f2e738359436ad1a4faa8ad6268372441c60a34363c13aa9f0eec5d0378cc'
- '321d7d24f490983f54acb9e7f58ebc2a170b520cd978c4989e28bc1a76513f3b')
+ '321d7d24f490983f54acb9e7f58ebc2a170b520cd978c4989e28bc1a76513f3b'
+ '3d48ebbaccb4e7e349895b73289a04ebcfc53253cf07e9374a2f2edaebd9bd12')
prepare() {
mkdir -p build
cd "$_pkgfqn"
+ git apply ../logcat-include.patch
}
build() {
diff --git a/logcat-include.patch b/logcat-include.patch
new file mode 100644
index 000000000000..51d30477f601
--- /dev/null
+++ b/logcat-include.patch
@@ -0,0 +1,12 @@
+diff --git a/src/datasync/datatypestore.h b/src/datasync/datatypestore.h
+index f63f281..3734b6b 100644
+--- a/src/datasync/datatypestore.h
++++ b/src/datasync/datatypestore.h
+@@ -5,6 +5,7 @@
+
+ #include <QtCore/qobject.h>
+ #include <QtCore/qdebug.h>
++#include <QtCore/qloggingcategory.h>
+
+ #include "QtDataSync/qtdatasync_global.h"
+ #include "QtDataSync/datastore.h"