summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e1a73d9f153..cb86e09525cd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qt5-networkauth-git
pkgdesc = Qt5 network authentication module
- pkgver = 5.15.1.r1.gc4563c2
+ pkgver = 5.15.9.r0.g59311ee
pkgrel = 1
url = https://www.qt.io/
arch = i686
@@ -10,10 +10,9 @@ pkgbase = qt5-networkauth-git
license = custom
makedepends = git
depends = qt5-base
- provides = qt5-networkauth
+ provides = qt5-networkauth=5.15.9.r0.g59311ee
conflicts = qt5-networkauth
source = git+https://code.qt.io/qt/qtnetworkauth.git#branch=5.15
sha256sums = SKIP
pkgname = qt5-networkauth-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f0bcf75cd380..ceb112db282a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=qt5-networkauth-git
-pkgver=5.15.1.r1.gc4563c2
+pkgver=5.15.9.r0.g59311ee
pkgrel=1
pkgdesc="Qt5 network authentication module"
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ url="https://www.qt.io/"
license=('FDL' 'GPL' 'custom')
depends=('qt5-base')
makedepends=('git')
-provides=('qt5-networkauth')
+provides=("qt5-networkauth=$pkgver")
conflicts=('qt5-networkauth')
source=("git+https://code.qt.io/qt/qtnetworkauth.git#branch=5.15")
sha256sums=('SKIP')
@@ -24,10 +24,10 @@ prepare() {
pkgver() {
cd "qtnetworkauth"
- _tag=$(git tag -l --sort -v:refname | head -n1)
+ _tag=$(git tag -l --sort -creatordate | grep -E '^v5\.15[0-9\.]+' | head -n1)
_rev=$(git rev-list --count $_tag..HEAD)
_hash=$(git rev-parse --short HEAD)
- printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//;s/-/_/g'
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//;s/-lts-lgpl//'
}
build() {