summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD51
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..75e1e78b4769
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = qt5-networkauth-git
+ pkgdesc = Qt5 Network authentication module
+ pkgver = 5.12.1.r12.g297e842
+ pkgrel = 1
+ url = https://www.qt.io/
+ arch = i686
+ arch = x86_64
+ license = FDL
+ license = GPL
+ license = custom
+ makedepends = git
+ depends = qt5-base
+ provides = qt5-networkauth
+ conflicts = qt5-networkauth
+ source = git+https://code.qt.io/qt/qtnetworkauth.git#branch=dev
+ sha256sums = SKIP
+
+pkgname = qt5-networkauth-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8956c7bd02d9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=qt5-networkauth-git
+pkgver=5.12.1.r12.g297e842
+pkgrel=1
+pkgdesc="Qt5 Network authentication module"
+arch=('i686' 'x86_64')
+url="https://www.qt.io/"
+license=('FDL' 'GPL' 'custom')
+depends=('qt5-base')
+makedepends=('git')
+provides=('qt5-networkauth')
+conflicts=('qt5-networkauth')
+source=("git+https://code.qt.io/qt/qtnetworkauth.git#branch=dev")
+sha256sums=('SKIP')
+
+
+prepare() {
+ cd "$srcdir"
+
+ mkdir -p "_build"
+}
+
+pkgver() {
+ cd "qtnetworkauth"
+
+ _tag=$(git tag -l --sort -v:refname | sed -n '1,1{s/v//p}')
+ _rev=$(git rev-list --count v$_tag..HEAD)
+ _hash=$(git rev-parse --short HEAD)
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash"
+}
+
+build() {
+ cd "_build"
+
+ qmake ../qtnetworkauth
+ make
+}
+
+package() {
+ cd "_build"
+
+ make INSTALL_ROOT="$pkgdir" install
+
+ # Drop QMAKE_PRL_BUILD_DIR because reference the build dir
+ find "$pkgdir/usr/lib" -type f -name '*.prl' \
+ -exec sed -i -e '/^QMAKE_PRL_BUILD_DIR/d' {} \;
+
+ cd "$srcdir/qtnetworkauth"
+ install -Dm644 "LICENSE.GPL3-EXCEPT" "$pkgdir/usr/share/licenses/qt5-networkauth/LICENSE.GPL3-EXCEPT"
+}