summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f9857052a01c..9645bf6a8ae0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qt5-serialport-git
pkgdesc = Qt5 serial port module
- pkgver = 5.15.1.r1.gf611325
+ pkgver = 5.15.9.r0.g7fb308e
pkgrel = 1
url = https://www.qt.io/
arch = i686
@@ -11,10 +11,9 @@ pkgbase = qt5-serialport-git
license = custom
makedepends = git
depends = qt5-base
- provides = qt5-serialport
+ provides = qt5-serialport=5.15.9.r0.g7fb308e
conflicts = qt5-serialport
source = git+https://code.qt.io/qt/qtserialport.git#branch=5.15
sha256sums = SKIP
pkgname = qt5-serialport-git
-
diff --git a/PKGBUILD b/PKGBUILD
index d2b33b215cd0..a32ba00afc56 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=qt5-serialport-git
-pkgver=5.15.1.r1.gf611325
+pkgver=5.15.9.r0.g7fb308e
pkgrel=1
pkgdesc="Qt5 serial port module"
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ url="https://www.qt.io/"
license=('FDL' 'GPL' 'LGPL' 'custom')
depends=('qt5-base')
makedepends=('git')
-provides=('qt5-serialport')
+provides=("qt5-serialport=$pkgver")
conflicts=('qt5-serialport')
source=("git+https://code.qt.io/qt/qtserialport.git#branch=5.15")
sha256sums=('SKIP')
@@ -24,10 +24,10 @@ prepare() {
pkgver() {
cd "qtserialport"
- _tag=$(git tag -l --sort -v:refname | head -n1)
+ _tag=$(git tag -l --sort -creatordate | grep -E '^v5\.15[0-9\.]+' | head -n1)
_rev=$(git rev-list --count $_tag..HEAD)
_hash=$(git rev-parse --short HEAD)
- printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//;s/-/_/g'
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//;s/-lts-lgpl//'
}
build() {