summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--QTBUG-86018.patch42
3 files changed, 12 insertions, 38 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb483d146420..98cdfc28c9e8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = qt5-webengine-595
pkgdesc = Provides support for web applications using the Chromium browser project (v5.9.5)
pkgver = 5.9.5
- pkgrel = 3
+ pkgrel = 4
url = http://qt-project.org/
arch = i686
arch = x86_64
@@ -44,7 +44,7 @@ pkgbase = qt5-webengine-595
sha256sums = ddd8d8b64fb2f81bbc5acd3d77cc6aeb79df44db451c3fed94f0e05b73c7b078
sha256sums = 0be352f23946a41cddae941ecedfe1bceb62b23e2a1225dd5469e77e251ccf42
sha256sums = cef22eeef1dedd484dec4cf94bb0aed2881ea7b2ee6d563e6940f4362e26604f
- sha256sums = 7849a944b63fbdcab3e15bce6158fa74d213f4f61bce7e870f05060fa00e2638
+ sha256sums = 1eaef6c3ae167c75eec42713a6c7301f0781610d24019b5241b5f77fc207d2ed
pkgname = qt5-webengine-595
diff --git a/PKGBUILD b/PKGBUILD
index 95abe84e57fe..644f2f2a3389 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=qt5-webengine-595
_qtver=5.9.5
pkgver=${_qtver/-/}
-pkgrel=3
+pkgrel=4
arch=('i686' 'x86_64')
url='http://qt-project.org/'
license=('LGPL3' 'LGPL2.1' 'BSD')
@@ -30,7 +30,7 @@ sha256sums=('70d26db4e7944291c5f843b875916fb95ceec0f0a8fea3daea8004990199fc07'
'ddd8d8b64fb2f81bbc5acd3d77cc6aeb79df44db451c3fed94f0e05b73c7b078'
'0be352f23946a41cddae941ecedfe1bceb62b23e2a1225dd5469e77e251ccf42'
'cef22eeef1dedd484dec4cf94bb0aed2881ea7b2ee6d563e6940f4362e26604f'
- '382ab1774b458a366deac45e38173147cc42f5edbbfb6b93e905c59c5c4abb46')
+ '1eaef6c3ae167c75eec42713a6c7301f0781610d24019b5241b5f77fc207d2ed')
prepare() {
mkdir -p build
diff --git a/QTBUG-86018.patch b/QTBUG-86018.patch
index 9effe79ab7ca..7df470db62b7 100644
--- a/QTBUG-86018.patch
+++ b/QTBUG-86018.patch
@@ -1,37 +1,11 @@
-diff --git a/src/3rdparty/chromium/third_party/WebKit/Source/build/scripts/rule_bison.py b/src/3rdparty/chromium/third_party/WebKit/Source/build/scripts/rule_bison.py
-index f75e25fd23f..7e0767e951a 100755
--- a/src/3rdparty/chromium/third_party/WebKit/Source/build/scripts/rule_bison.py
+++ b/src/3rdparty/chromium/third_party/WebKit/Source/build/scripts/rule_bison.py
-@@ -45,6 +45,19 @@ from utilities import abs
-
- from blinkbuild.name_style_converter import NameStyleConverter
-
-+def modify_file(path, prefix_lines, suffix_lines, replace_list=[]):
-+ prefix_lines = map(lambda s: s + '\n', prefix_lines)
-+ suffix_lines = map(lambda s: s + '\n', suffix_lines)
-+ with open(path, 'r') as f:
-+ old_lines = f.readlines()
-+ for i in range(len(old_lines)):
-+ for src, dest in replace_list:
-+ old_lines[i] = old_lines[i].replace(src, dest)
-+ new_lines = prefix_lines + old_lines + suffix_lines
-+ with open(path, 'w') as f:
-+ f.writelines(new_lines)
-+
-+
- assert len(sys.argv) == 4 or len(sys.argv) == 5
-
- inputFile = abs(sys.argv[1])
-@@ -115,3 +128,9 @@ print >>outputHFile, '#define %s' % headerGuard
- print >>outputHFile, outputHContents
- print >>outputHFile, '#endif // %s' % headerGuard
+@@ -100,7 +100,7 @@
+ outputHFile = open(outputHTmp)
+ outputHContents = outputHFile.read()
outputHFile.close()
-+
-+common_replace_list = [(inputRoot + '.hh',
-+ inputRoot + '.h')]
-+modify_file(
-+ outputCpp, [], [],
-+ replace_list=common_replace_list)
---
-cgit v1.2.1
-
+-os.unlink(outputHTmp)
++# not working for bison-3.7: os.unlink(outputHTmp)
+
+ # Rewrite the generated header with #include guards.
+ outputH = os.path.join(outputDir, inputRoot + '.h')