summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD8
2 files changed, 6 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index faf563de5771..7ba1d82fd139 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qt5-websockets-git
pkgdesc = Qt5 WebSockets module
- pkgver = 5.15.1.r1.g55e0638
+ pkgver = 5.15.9.r0.g7d09b69
pkgrel = 1
url = https://www.qt.io/
arch = i686
@@ -11,10 +11,9 @@ pkgbase = qt5-websockets-git
makedepends = git
makedepends = qt5-declarative
depends = qt5-base
- provides = qt5-websockets
+ provides = qt5-websockets=5.15.9.r0.g7d09b69
conflicts = qt5-websockets
source = git+https://code.qt.io/qt/qtwebsockets.git#branch=5.15
sha256sums = SKIP
pkgname = qt5-websockets-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 08c6a8dac7f9..0cca4073fdc4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=qt5-websockets-git
-pkgver=5.15.1.r1.g55e0638
+pkgver=5.15.9.r0.g7d09b69
pkgrel=1
pkgdesc="Qt5 WebSockets module"
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ url="https://www.qt.io/"
license=('GPL' 'LGPL' 'custom')
depends=('qt5-base')
makedepends=('git' 'qt5-declarative')
-provides=('qt5-websockets')
+provides=("qt5-websockets=$pkgver")
conflicts=('qt5-websockets')
source=("git+https://code.qt.io/qt/qtwebsockets.git#branch=5.15")
sha256sums=('SKIP')
@@ -24,10 +24,10 @@ prepare() {
pkgver() {
cd "qtwebsockets"
- _tag=$(git tag -l --sort -v:refname | head -n1)
+ _tag=$(git tag -l --sort -creatordate | grep -E '^v5\.15[0-9\.]+' | head -n1)
_rev=$(git rev-list --count $_tag..HEAD)
_hash=$(git rev-parse --short HEAD)
- printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//;s/-/_/g'
+ printf "%s.r%s.g%s" "$_tag" "$_rev" "$_hash" | sed 's/^v//;s/-lts-lgpl//'
}
build() {