summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
-rw-r--r--platform-linux-g++-4.6.patch118
3 files changed, 138 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 04bf7174fdc8..2d9d756ddb86 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Mar 22 10:48:56 UTC 2016
+# Fri Jun 24 16:13:06 UTC 2016
pkgbase = qt51
pkgver = 5.1.1
- pkgrel = 3
+ pkgrel = 4
url = http://qt-project.org/
arch = i686
arch = x86_64
@@ -11,6 +11,7 @@ pkgbase = qt51
license = LGPL
license = FDL
license = custom
+ makedepends = gcc46
makedepends = libxcb
makedepends = xcb-proto
makedepends = xcb-util
@@ -47,6 +48,7 @@ pkgbase = qt51
source = linguist-qt51.desktop
source = qdbusviewer-qt51.desktop
source = use-python2.patch
+ source = platform-linux-g++-4.6.patch
source = bison3.patch
source = CVE-2013-4549.patch
source = libmng2.patch
@@ -58,6 +60,7 @@ pkgbase = qt51
md5sums = 4ce959cbe138df8589e81537ac40f37f
md5sums = 9019f5c97c91c9b29a50b55f3e33c40a
md5sums = 92831f79144d5cb8121915423ba47575
+ md5sums = 72451f13cf068f0c137e81b0630c5f44
md5sums = 6b162cd2bc104f0ae83ca039401be7bf
md5sums = e59ba552e12408dcc9486cdbb1f233e3
md5sums = 478647fa057d190a7d789cf78995167b
diff --git a/PKGBUILD b/PKGBUILD
index cd971841e95b..9477889a27d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,11 +24,11 @@ pkgname=('qt51-base'
'qt51-x11extras'
'qt51-xmlpatterns')
pkgver=5.1.1
-pkgrel=3
+pkgrel=4
arch=('i686' 'x86_64')
url='http://qt-project.org/'
license=('GPL3' 'LGPL' 'FDL' 'custom')
-makedepends=('libxcb' 'xcb-proto' 'xcb-util' 'xcb-util-image' 'xcb-util-wm' 'xcb-util-keysyms'
+makedepends=('gcc46' 'libxcb' 'xcb-proto' 'xcb-util' 'xcb-util-image' 'xcb-util-wm' 'xcb-util-keysyms'
'mesa' 'at-spi2-core' 'alsa-lib' 'gstreamer0.10-base-plugins' 'libmng'
'libjpeg-turbo' 'cups' 'libpulse' 'hicolor-icon-theme' 'desktop-file-utils'
'postgresql-libs' 'libmariadbclient' 'sqlite' 'unixodbc' 'libfbclient'
@@ -42,6 +42,7 @@ source=("http://download.qt-project.org/official_releases/qt/5.1/${pkgver}/singl
'linguist-qt51.desktop'
'qdbusviewer-qt51.desktop'
'use-python2.patch'
+ 'platform-linux-g++-4.6.patch'
'bison3.patch'
'CVE-2013-4549.patch'
'libmng2.patch'
@@ -53,6 +54,7 @@ md5sums=('697b7b8768ef8895e168366ab6b44760'
'4ce959cbe138df8589e81537ac40f37f'
'9019f5c97c91c9b29a50b55f3e33c40a'
'92831f79144d5cb8121915423ba47575'
+ '72451f13cf068f0c137e81b0630c5f44'
'6b162cd2bc104f0ae83ca039401be7bf'
'e59ba552e12408dcc9486cdbb1f233e3'
'478647fa057d190a7d789cf78995167b'
@@ -71,6 +73,9 @@ prepare() {
sed -i -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
-e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
$(find . -name '*.py')
+
+ # use gcc-4.6
+ patch -p0 -i "${srcdir}"/platform-linux-g++-4.6.patch
# Fix build with bison 3.x
cd qtwebkit
@@ -89,6 +94,13 @@ prepare() {
build() {
cd ${_pkgfqn}
+ CFLAGS=${CFLAGS//-fstack-protector-strong/-fstack-protector}
+ CXXFLAGS=${CXXFLAGS//-fstack-protector-strong/-fstack-protector}
+ echo "QMAKE_CFLAGS_RELEASE=$CFLAGS -fpermissive" >> qtbase/mkspecs/linux-g++-4.6/qmake.conf
+ echo "QMAKE_CXXFLAGS_RELEASE=$CXXFLAGS -fpermissive" >> qtbase/mkspecs/linux-g++-4.6/qmake.conf
+ echo "QMAKE_CC=gcc-4.6" >> qtbase/mkspecs/linux-g++-4.6/qmake.conf
+ echo "QMAKE_CXX=g++-4.6" >> qtbase/mkspecs/linux-g++-4.6/qmake.conf
+
export QTDIR="${srcdir}"/${_pkgfqn}
export LD_LIBRARY_PATH="${QTDIR}"/qtbase/lib:"${QTDIR}"/qttools/lib:"${LD_LIBRARY_PATH}"
export QT_PLUGIN_PATH="${QTDIR}"/qtbase/plugins
@@ -102,6 +114,7 @@ build() {
-no-rpath \
-optimized-qmake \
-dbus-linked \
+ -platform linux-g++-4.6 \
-reduce-relocations
make
diff --git a/platform-linux-g++-4.6.patch b/platform-linux-g++-4.6.patch
new file mode 100644
index 000000000000..bea2f3917cbf
--- /dev/null
+++ b/platform-linux-g++-4.6.patch
@@ -0,0 +1,118 @@
+--- /dev/null 2016-06-24 11:30:22.921375825 +0200
++++ qtbase/mkspecs/linux-g++-4.6/qmake.conf 2016-06-24 16:51:54.184917236 +0200
+@@ -0,0 +1,12 @@
++#
++# qmake configuration for linux-g++
++#
++
++MAKEFILE_GENERATOR = UNIX
++CONFIG += incremental gdb_dwarf_index
++QMAKE_INCREMENTAL_STYLE = sublib
++
++include(../common/linux.conf)
++include(../common/gcc-base-unix.conf)
++include(../common/g++-unix.conf)
++load(qt_config)
+--- /dev/null 2016-06-24 11:30:22.921375825 +0200
++++ qtbase/mkspecs/linux-g++-4.6/qplatformdefs.h 2016-06-24 16:51:54.184917236 +0200
+@@ -0,0 +1,100 @@
++/****************************************************************************
++**
++** Copyright (C) 2013 Digia Plc and/or its subsidiary(-ies).
++** Contact: http://www.qt-project.org/legal
++**
++** This file is part of the qmake spec of the Qt Toolkit.
++**
++** $QT_BEGIN_LICENSE:LGPL$
++** Commercial License Usage
++** Licensees holding valid commercial Qt licenses may use this file in
++** accordance with the commercial license agreement provided with the
++** Software or, alternatively, in accordance with the terms contained in
++** a written agreement between you and Digia. For licensing terms and
++** conditions see http://qt.digia.com/licensing. For further information
++** use the contact form at http://qt.digia.com/contact-us.
++**
++** GNU Lesser General Public License Usage
++** Alternatively, this file may be used under the terms of the GNU Lesser
++** General Public License version 2.1 as published by the Free Software
++** Foundation and appearing in the file LICENSE.LGPL included in the
++** packaging of this file. Please review the following information to
++** ensure the GNU Lesser General Public License version 2.1 requirements
++** will be met: http://www.gnu.org/licenses/old-licenses/lgpl-2.1.html.
++**
++** In addition, as a special exception, Digia gives you certain additional
++** rights. These rights are described in the Digia Qt LGPL Exception
++** version 1.1, included in the file LGPL_EXCEPTION.txt in this package.
++**
++** GNU General Public License Usage
++** Alternatively, this file may be used under the terms of the GNU
++** General Public License version 3.0 as published by the Free Software
++** Foundation and appearing in the file LICENSE.GPL included in the
++** packaging of this file. Please review the following information to
++** ensure the GNU General Public License version 3.0 requirements will be
++** met: http://www.gnu.org/copyleft/gpl.html.
++**
++**
++** $QT_END_LICENSE$
++**
++****************************************************************************/
++
++#ifndef QPLATFORMDEFS_H
++#define QPLATFORMDEFS_H
++
++// Get Qt defines/settings
++
++#include "qglobal.h"
++
++// Set any POSIX/XOPEN defines at the top of this file to turn on specific APIs
++
++// 1) need to reset default environment if _BSD_SOURCE is defined
++// 2) need to specify POSIX thread interfaces explicitly in glibc 2.0
++// 3) it seems older glibc need this to include the X/Open stuff
++#ifndef _GNU_SOURCE
++# define _GNU_SOURCE
++#endif
++
++#include <unistd.h>
++
++
++// We are hot - unistd.h should have turned on the specific APIs we requested
++
++#include <features.h>
++#include <pthread.h>
++#include <dirent.h>
++#include <fcntl.h>
++#include <grp.h>
++#include <pwd.h>
++#include <signal.h>
++
++#include <sys/types.h>
++#include <sys/ioctl.h>
++#include <sys/ipc.h>
++#include <sys/time.h>
++#include <sys/shm.h>
++#include <sys/socket.h>
++#include <sys/stat.h>
++#include <sys/wait.h>
++#include <netinet/in.h>
++#ifndef QT_NO_IPV6IFNAME
++#include <net/if.h>
++#endif
++
++#define QT_USE_XOPEN_LFS_EXTENSIONS
++#include "../common/posix/qplatformdefs.h"
++
++#undef QT_SOCKLEN_T
++
++#if defined(__GLIBC__) && (__GLIBC__ >= 2)
++#define QT_SOCKLEN_T socklen_t
++#else
++#define QT_SOCKLEN_T int
++#endif
++
++#if defined(_XOPEN_SOURCE) && (_XOPEN_SOURCE >= 500)
++#define QT_SNPRINTF ::snprintf
++#define QT_VSNPRINTF ::vsnprintf
++#endif
++
++#endif // QPLATFORMDEFS_H