summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--0002-disable-v8snapshot.patch69
-rw-r--r--0003-drop-tr1-usage.patch43
-rw-r--r--0004-fix-3rdparty-javascriptcore.patch48
-rw-r--r--0005-fix-bind-in-webkit2.patch31
-rw-r--r--0006-fix-javascriptcore.patch53
-rw-r--r--PKGBUILD33
-rw-r--r--platform-linux-g++-4.6.patch118
8 files changed, 274 insertions, 138 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d9d756ddb86..09f18663aa6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri Jun 24 16:13:06 UTC 2016
+# Fri Aug 19 08:09:17 UTC 2016
pkgbase = qt51
pkgver = 5.1.1
- pkgrel = 4
+ pkgrel = 5
url = http://qt-project.org/
arch = i686
arch = x86_64
@@ -11,7 +11,6 @@ pkgbase = qt51
license = LGPL
license = FDL
license = custom
- makedepends = gcc46
makedepends = libxcb
makedepends = xcb-proto
makedepends = xcb-util
@@ -48,11 +47,15 @@ pkgbase = qt51
source = linguist-qt51.desktop
source = qdbusviewer-qt51.desktop
source = use-python2.patch
- source = platform-linux-g++-4.6.patch
source = bison3.patch
source = CVE-2013-4549.patch
source = libmng2.patch
source = 0001-Fix-g-5-build-see-qtwebkit-Source-JavaScriptCore-run.patch
+ source = 0002-disable-v8snapshot.patch
+ source = 0003-drop-tr1-usage.patch
+ source = 0004-fix-3rdparty-javascriptcore.patch
+ source = 0005-fix-bind-in-webkit2.patch
+ source = 0006-fix-javascriptcore.patch
source = qt51.PATH
md5sums = 697b7b8768ef8895e168366ab6b44760
md5sums = d6fd35a4858c2519385d13c04985a947
@@ -60,11 +63,15 @@ pkgbase = qt51
md5sums = 4ce959cbe138df8589e81537ac40f37f
md5sums = 9019f5c97c91c9b29a50b55f3e33c40a
md5sums = 92831f79144d5cb8121915423ba47575
- md5sums = 72451f13cf068f0c137e81b0630c5f44
md5sums = 6b162cd2bc104f0ae83ca039401be7bf
md5sums = e59ba552e12408dcc9486cdbb1f233e3
md5sums = 478647fa057d190a7d789cf78995167b
md5sums = 27b294a3b24eae2c001f85961133eadb
+ md5sums = cfbc1ecacf9851d51d5a44493fc54cd4
+ md5sums = aef7d21241f547cae1579f0e874eaa04
+ md5sums = a1c74da7e50e864ca7027416793d683b
+ md5sums = 73ffdcd08c03a81176b989e6de39ae62
+ md5sums = b2fe290a446fa4d41becbf4720cfe318
md5sums = 28f4755e54ba1df5a89d60a73f6d1a9e
pkgname = qt51-base
diff --git a/0002-disable-v8snapshot.patch b/0002-disable-v8snapshot.patch
new file mode 100644
index 000000000000..bdf78448f0e2
--- /dev/null
+++ b/0002-disable-v8snapshot.patch
@@ -0,0 +1,69 @@
+From f855c6b7ea72e84ba455026b4b80ebf3a2cbff32 Mon Sep 17 00:00:00 2001
+From: "aur@manjaro" <aur@manjaro>
+Date: Thu, 18 Aug 2016 12:05:36 +0200
+Subject: [PATCH] disable v8snapshot
+
+See http://lists.busybox.net/pipermail/buildroot/2013-May/072357.html
+
+# Hi Arnout & Thomas,
+#
+# Thanks for tips. It got me digging in the (hopefully) right direction.
+#
+# The issue is basically that host tool "mkv8snapshot" which is part of
+# qtjsbackend is segfaulting -
+#
+# mkv8snapshot[29356]: segfault at 0 ip 0833e3b9 sp bf8ec040 error 4 in
+# mkv8snapshot
+#
+# I still haven't been able to determine why this happens. But the solution
+# that works for me is to disable its usage during the Qt build as per the
+# info in this mail trail from Qt-project
+# http://comments.gmane.org/gmane.comp.lib.qt.devel/6101
+#
+# So I added a patch as per below... and no more issues!
+#
+# diff -urN qt-everywhere-commercial-src-5.0.2_orig//qtbase/configure
+# qt-everywhere-commercial-src-5.0.2//qtbase/configure---
+# qt-everywhere-commercial-src-5.0.2_orig//qtbase/configure 2013-05-09
+# 18:28:22.615623889 +0530
+# +++ qt-everywhere-commercial-src-5.0.2//qtbase/configure 2013-05-16
+# 18:56:21.124371988 +0530
+# @@ -471,7 +471,7 @@
+# CFG_SKIP_MODULES=""
+# CFG_RELEASE_QMAKE=no
+# CFG_AUDIO_BACKEND=auto
+# -CFG_V8SNAPSHOT=auto
+# +CFG_V8SNAPSHOT=no
+# CFG_QML_DEBUG=yes
+# CFG_JAVASCRIPTCORE_JIT=auto
+# CFG_PKGCONFIG=auto
+# I can't exactly figure out why this happens esp becuse it If build qt5
+# manually "by hand" using the same process (but just outside buildroot, but
+# with the same cross-toolchain) i dont see this error as the configure
+# script detects that this tool is not required (canUseV8Snapshot gets set to
+# no).
+#
+# Any reasons why this is happening?
+#
+# regards,
+# Carlos
+---
+ qtbase/configure | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/qtbase/configure b/qtbase/configure
+index 140c7b4..3f8735b 100755
+--- a/qtbase/configure
++++ b/qtbase/configure
+@@ -891,7 +891,7 @@ CFG_SKIP_MODULES=""
+ CFG_COMPILE_EXAMPLES=yes
+ CFG_RELEASE_QMAKE=no
+ CFG_AUDIO_BACKEND=auto
+-CFG_V8SNAPSHOT=auto
++CFG_V8SNAPSHOT=no
+ CFG_QML_DEBUG=yes
+ CFG_JAVASCRIPTCORE_JIT=auto
+ CFG_PKGCONFIG=auto
+--
+2.9.2
+
diff --git a/0003-drop-tr1-usage.patch b/0003-drop-tr1-usage.patch
new file mode 100644
index 000000000000..7acfb750b51e
--- /dev/null
+++ b/0003-drop-tr1-usage.patch
@@ -0,0 +1,43 @@
+From d0590658d4e1fe0126fba9c251eb8ec365e79cce Mon Sep 17 00:00:00 2001
+From: "aur@manjaro" <aur@manjaro>
+Date: Thu, 18 Aug 2016 14:06:15 +0200
+Subject: [PATCH] drop tr1 usage
+
+---
+ qtscript/src/3rdparty/javascriptcore/JavaScriptCore/wtf/TypeTraits.h | 4 ++--
+ qtwebkit/Source/WTF/wtf/TypeTraits.h | 4 ++--
+ 2 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/wtf/TypeTraits.h b/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/wtf/TypeTraits.h
+index 7ba487f..ff998fd 100644
+--- a/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/wtf/TypeTraits.h
++++ b/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/wtf/TypeTraits.h
+@@ -170,8 +170,8 @@ namespace WTF {
+
+ // GCC's libstdc++ 20070724 and later supports C++ TR1 type_traits in the std namespace.
+ // VC10 (VS2010) and later support C++ TR1 type_traits in the std::tr1 namespace.
+- template<typename T> struct HasTrivialConstructor : public std::tr1::has_trivial_constructor<T> { };
+- template<typename T> struct HasTrivialDestructor : public std::tr1::has_trivial_destructor<T> { };
++ template<typename T> struct HasTrivialConstructor : public std::is_trivially_default_constructible<T> { };
++ template<typename T> struct HasTrivialDestructor : public std::is_trivially_destructible<T> { };
+
+ #else
+
+diff --git a/qtwebkit/Source/WTF/wtf/TypeTraits.h b/qtwebkit/Source/WTF/wtf/TypeTraits.h
+index b9e46bc..b4e4db0 100644
+--- a/qtwebkit/Source/WTF/wtf/TypeTraits.h
++++ b/qtwebkit/Source/WTF/wtf/TypeTraits.h
+@@ -241,8 +241,8 @@ namespace WTF {
+ #elif (defined(__GLIBCXX__) && (__GLIBCXX__ >= 20070724) && defined(__GXX_EXPERIMENTAL_CXX0X__)) || (defined(_MSC_VER) && (_MSC_VER >= 1600))
+ // GCC's libstdc++ 20070724 and later supports C++ TR1 type_traits in the std namespace.
+ // VC10 (VS2010) and later support C++ TR1 type_traits in the std::tr1 namespace.
+- template<typename T> struct HasTrivialConstructor : public std::tr1::has_trivial_constructor<T> { };
+- template<typename T> struct HasTrivialDestructor : public std::tr1::has_trivial_destructor<T> { };
++ template<typename T> struct HasTrivialConstructor : public std::is_trivially_default_constructible<T> { };
++ template<typename T> struct HasTrivialDestructor : public std::is_trivially_destructible<T> { };
+ #else
+ // For compilers that don't support detection of trivial constructors and destructors in classes,
+ // we use a template that returns true for any POD type that IsPod can detect (see IsPod caveats above),
+--
+2.9.2
+
diff --git a/0004-fix-3rdparty-javascriptcore.patch b/0004-fix-3rdparty-javascriptcore.patch
new file mode 100644
index 000000000000..666a837b1518
--- /dev/null
+++ b/0004-fix-3rdparty-javascriptcore.patch
@@ -0,0 +1,48 @@
+From d45a69d10b8e61b35820d92ee9d4ccf763f71b0f Mon Sep 17 00:00:00 2001
+From: "aur@manjaro" <aur@manjaro>
+Date: Thu, 18 Aug 2016 15:36:32 +0200
+Subject: [PATCH] fix 3rdparty javascriptcore
+
+---
+ .../javascriptcore/JavaScriptCore/runtime/Structure.h | 2 +-
+ .../3rdparty/javascriptcore/JavaScriptCore/wtf/HashTable.h | 11 -----------
+ 2 files changed, 1 insertion(+), 12 deletions(-)
+
+diff --git a/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/runtime/Structure.h b/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/runtime/Structure.h
+index 7571efc..77d4f50 100644
+--- a/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/runtime/Structure.h
++++ b/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/runtime/Structure.h
+@@ -317,7 +317,7 @@ namespace JSC {
+ TransitionTable* transitionTable = new TransitionTable;
+ setTransitionTable(transitionTable);
+ if (existingTransition)
+- add(StructureTransitionTableHash::Key(RefPtr<UString::Rep>(existingTransition->m_nameInPrevious.get()), existingTransition->m_attributesInPrevious), existingTransition, existingTransition->m_specificValueInPrevious);
++ add(StructureTransitionTableHash::Key(RefPtr<UString::Rep>(existingTransition->m_nameInPrevious.get()), (unsigned int)(existingTransition->m_attributesInPrevious)), existingTransition, existingTransition->m_specificValueInPrevious);
+ }
+ } // namespace JSC
+
+diff --git a/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/wtf/HashTable.h b/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/wtf/HashTable.h
+index 42a9233..e761edb 100644
+--- a/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/wtf/HashTable.h
++++ b/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/wtf/HashTable.h
+@@ -257,17 +257,6 @@ namespace WTF {
+
+ using std::swap;
+
+-#if !COMPILER(MSVC) && !OS(QNX) && !defined(_LIBCPP_VERSION)
+- // The Dinkumware C++ library (used by MSVC and QNX) and clang's libc++ have a swap for pairs defined.
+-
+- // swap pairs by component, in case of pair members that specialize swap
+- template<typename T, typename U> inline void swap(pair<T, U>& a, pair<T, U>& b)
+- {
+- swap(a.first, b.first);
+- swap(a.second, b.second);
+- }
+-#endif
+-
+ template<typename T, bool useSwap> struct Mover;
+ template<typename T> struct Mover<T, true> { static void move(T& from, T& to) { swap(from, to); } };
+ template<typename T> struct Mover<T, false> { static void move(T& from, T& to) { to = from; } };
+--
+2.9.2
+
diff --git a/0005-fix-bind-in-webkit2.patch b/0005-fix-bind-in-webkit2.patch
new file mode 100644
index 000000000000..4bd8327afbb5
--- /dev/null
+++ b/0005-fix-bind-in-webkit2.patch
@@ -0,0 +1,31 @@
+From 04ec167908b9ce7adbd1c765525e8b82011a3de2 Mon Sep 17 00:00:00 2001
+From: "aur@manjaro" <aur@manjaro>
+Date: Fri, 19 Aug 2016 09:13:37 +0200
+Subject: [PATCH] fix bind in webkit2
+
+---
+ qtwebkit/Source/WebKit2/UIProcess/WebProcessProxy.cpp | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/qtwebkit/Source/WebKit2/UIProcess/WebProcessProxy.cpp b/qtwebkit/Source/WebKit2/UIProcess/WebProcessProxy.cpp
+index 6ca003a..a765303 100644
+--- a/qtwebkit/Source/WebKit2/UIProcess/WebProcessProxy.cpp
++++ b/qtwebkit/Source/WebKit2/UIProcess/WebProcessProxy.cpp
+@@ -377,12 +377,12 @@ void WebProcessProxy::handleGetPlugins(uint64_t requestID, bool refresh)
+
+ // NOTE: We have to pass the PluginInfo vector to the secondary thread via a pointer as otherwise
+ // we'd end up with a deref() race on all the WTF::Strings it contains.
+- RunLoop::main()->dispatch(bind(&WebProcessProxy::sendDidGetPlugins, this, requestID, pluginInfos.release()));
++ RunLoop::main()->dispatch(WTF::bind(&WebProcessProxy::sendDidGetPlugins, this, requestID, pluginInfos.release()));
+ }
+
+ void WebProcessProxy::getPlugins(CoreIPC::Connection*, uint64_t requestID, bool refresh)
+ {
+- pluginWorkQueue().dispatch(bind(&WebProcessProxy::handleGetPlugins, this, requestID, refresh));
++ pluginWorkQueue().dispatch(WTF::bind(&WebProcessProxy::handleGetPlugins, this, requestID, refresh));
+ }
+
+ void WebProcessProxy::getPluginPath(const String& mimeType, const String& urlString, String& pluginPath, uint32_t& pluginLoadPolicy)
+--
+2.9.2
+
diff --git a/0006-fix-javascriptcore.patch b/0006-fix-javascriptcore.patch
new file mode 100644
index 000000000000..490e390c7696
--- /dev/null
+++ b/0006-fix-javascriptcore.patch
@@ -0,0 +1,53 @@
+From f1e8d694005f06a203157b18cbdbccbb674776e4 Mon Sep 17 00:00:00 2001
+From: "aur@manjaro" <aur@manjaro>
+Date: Fri, 19 Aug 2016 10:05:04 +0200
+Subject: [PATCH] fix javascriptcore
+
+---
+ .../src/3rdparty/javascriptcore/JavaScriptCore/runtime/Structure.cpp | 2 +-
+ .../src/3rdparty/javascriptcore/JavaScriptCore/wtf/unicode/UTF8.cpp | 2 +-
+ .../src/3rdparty/javascriptcore/JavaScriptCore/yarr/RegexCompiler.cpp | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/runtime/Structure.cpp b/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/runtime/Structure.cpp
+index bf49a15..7daebbb 100644
+--- a/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/runtime/Structure.cpp
++++ b/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/runtime/Structure.cpp
+@@ -157,7 +157,7 @@ Structure::~Structure()
+ {
+ if (m_previous) {
+ if (m_nameInPrevious)
+- m_previous->table.remove(StructureTransitionTableHash::Key(RefPtr<UString::Rep>(m_nameInPrevious.get()), m_attributesInPrevious), m_specificValueInPrevious);
++ m_previous->table.remove(StructureTransitionTableHash::Key(RefPtr<UString::Rep>(m_nameInPrevious.get()), (unsigned int)(m_attributesInPrevious)), m_specificValueInPrevious);
+ else
+ m_previous->table.removeAnonymousSlotTransition(m_anonymousSlotsInPrevious);
+
+diff --git a/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/wtf/unicode/UTF8.cpp b/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/wtf/unicode/UTF8.cpp
+index 21d5856..ba819fc 100644
+--- a/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/wtf/unicode/UTF8.cpp
++++ b/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/wtf/unicode/UTF8.cpp
+@@ -228,7 +228,7 @@ static bool isLegalUTF8(const unsigned char* source, int length)
+ // Magic values subtracted from a buffer value during UTF8 conversion.
+ // This table contains as many values as there might be trailing bytes
+ // in a UTF-8 sequence.
+-static const UChar32 offsetsFromUTF8[6] = { 0x00000000UL, 0x00003080UL, 0x000E2080UL,
++static const long offsetsFromUTF8[6] = { 0x00000000UL, 0x00003080UL, 0x000E2080UL,
+ 0x03C82080UL, 0xFA082080UL, 0x82082080UL };
+
+ ConversionResult convertUTF8ToUTF16(
+diff --git a/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/yarr/RegexCompiler.cpp b/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/yarr/RegexCompiler.cpp
+index 9cd3d12..917eac0 100644
+--- a/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/yarr/RegexCompiler.cpp
++++ b/qtscript/src/3rdparty/javascriptcore/JavaScriptCore/yarr/RegexCompiler.cpp
+@@ -719,7 +719,7 @@ const char* compileRegex(const UString& patternString, RegexPattern& pattern)
+
+ constructor.setupOffsets();
+
+- return false;
++ return nullptr;
+ };
+
+
+--
+2.9.2
+
diff --git a/PKGBUILD b/PKGBUILD
index 9477889a27d6..37cfedd0634f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,11 +24,11 @@ pkgname=('qt51-base'
'qt51-x11extras'
'qt51-xmlpatterns')
pkgver=5.1.1
-pkgrel=4
+pkgrel=5
arch=('i686' 'x86_64')
url='http://qt-project.org/'
license=('GPL3' 'LGPL' 'FDL' 'custom')
-makedepends=('gcc46' 'libxcb' 'xcb-proto' 'xcb-util' 'xcb-util-image' 'xcb-util-wm' 'xcb-util-keysyms'
+makedepends=('libxcb' 'xcb-proto' 'xcb-util' 'xcb-util-image' 'xcb-util-wm' 'xcb-util-keysyms'
'mesa' 'at-spi2-core' 'alsa-lib' 'gstreamer0.10-base-plugins' 'libmng'
'libjpeg-turbo' 'cups' 'libpulse' 'hicolor-icon-theme' 'desktop-file-utils'
'postgresql-libs' 'libmariadbclient' 'sqlite' 'unixodbc' 'libfbclient'
@@ -42,11 +42,15 @@ source=("http://download.qt-project.org/official_releases/qt/5.1/${pkgver}/singl
'linguist-qt51.desktop'
'qdbusviewer-qt51.desktop'
'use-python2.patch'
- 'platform-linux-g++-4.6.patch'
'bison3.patch'
'CVE-2013-4549.patch'
'libmng2.patch'
'0001-Fix-g-5-build-see-qtwebkit-Source-JavaScriptCore-run.patch'
+ '0002-disable-v8snapshot.patch'
+ '0003-drop-tr1-usage.patch'
+ '0004-fix-3rdparty-javascriptcore.patch'
+ '0005-fix-bind-in-webkit2.patch'
+ '0006-fix-javascriptcore.patch'
'qt51.PATH')
md5sums=('697b7b8768ef8895e168366ab6b44760'
'd6fd35a4858c2519385d13c04985a947'
@@ -54,11 +58,15 @@ md5sums=('697b7b8768ef8895e168366ab6b44760'
'4ce959cbe138df8589e81537ac40f37f'
'9019f5c97c91c9b29a50b55f3e33c40a'
'92831f79144d5cb8121915423ba47575'
- '72451f13cf068f0c137e81b0630c5f44'
'6b162cd2bc104f0ae83ca039401be7bf'
'e59ba552e12408dcc9486cdbb1f233e3'
'478647fa057d190a7d789cf78995167b'
'27b294a3b24eae2c001f85961133eadb'
+ 'cfbc1ecacf9851d51d5a44493fc54cd4'
+ 'aef7d21241f547cae1579f0e874eaa04'
+ 'a1c74da7e50e864ca7027416793d683b'
+ '73ffdcd08c03a81176b989e6de39ae62'
+ 'b2fe290a446fa4d41becbf4720cfe318'
'28f4755e54ba1df5a89d60a73f6d1a9e')
prepare() {
@@ -67,15 +75,13 @@ prepare() {
sed -i "s|-O2|${CXXFLAGS}|" qtbase/mkspecs/common/{g++,gcc}-base.conf
sed -i "/^QMAKE_LFLAGS_RPATH/s| -Wl,-rpath,||g" qtbase/mkspecs/common/gcc-base-unix.conf
sed -i "/^QMAKE_LFLAGS\s/s|+=|+= ${LDFLAGS}|g" qtbase/mkspecs/common/gcc-base.conf
+ sed -i 's/QMAKE_CFLAGS_RELEASE +=/QMAKE_CFLAGS_RELEASE += -fpermissive/g' qtbase/mkspecs/common/gcc-base.conf
# Use python2 for Python 2.x
patch -p1 -i "${srcdir}"/use-python2.patch
sed -i -e "s|#![ ]*/usr/bin/python$|#!/usr/bin/python2|" \
-e "s|#![ ]*/usr/bin/env python$|#!/usr/bin/env python2|" \
$(find . -name '*.py')
-
- # use gcc-4.6
- patch -p0 -i "${srcdir}"/platform-linux-g++-4.6.patch
# Fix build with bison 3.x
cd qtwebkit
@@ -89,18 +95,16 @@ prepare() {
cd ..
patch -p1 -i "${srcdir}"/0001-Fix-g-5-build-see-qtwebkit-Source-JavaScriptCore-run.patch
+ patch -p1 -i "${srcdir}"/0002-disable-v8snapshot.patch
+ patch -p1 -i "${srcdir}"/0003-drop-tr1-usage.patch
+ patch -p1 -i "${srcdir}"/0004-fix-3rdparty-javascriptcore.patch
+ patch -p1 -i "${srcdir}"/0005-fix-bind-in-webkit2.patch
+ patch -p1 -i "${srcdir}"/0006-fix-javascriptcore.patch
}
build() {
cd ${_pkgfqn}
- CFLAGS=${CFLAGS//-fstack-protector-strong/-fstack-protector}
- CXXFLAGS=${CXXFLAGS//-fstack-protector-strong/-fstack-protector}
- echo "QMAKE_CFLAGS_RELEASE=$CFLAGS -fpermissive" >> qtbase/mkspecs/linux-g++-4.6/qmake.conf
- echo "QMAKE_CXXFLAGS_RELEASE=$CXXFLAGS -fpermissive" >> qtbase/mkspecs/linux-g++-4.6/qmake.conf
- echo "QMAKE_CC=gcc-4.6" >> qtbase/mkspecs/linux-g++-4.6/qmake.conf
- echo "QMAKE_CXX=g++-4.6" >> qtbase/mkspecs/linux-g++-4.6/qmake.conf
-
export QTDIR="${srcdir}"/${_pkgfqn}
export LD_LIBRARY_PATH="${QTDIR}"/qtbase/lib:"${QTDIR}"/qttools/lib:"${LD_LIBRARY_PATH}"
export QT_PLUGIN_PATH="${QTDIR}"/qtbase/plugins
@@ -114,7 +118,6 @@ build() {
-no-rpath \
-optimized-qmake \
-dbus-linked \
- -platform linux-g++-4.6 \
-reduce-relocations
make
diff --git a/platform-linux-g++-4.6.patch b/platform-linux-g++-4.6.patch
deleted file mode 100644
index bea2f3917cbf..000000000000
--- a/platform-linux-g++-4.6.patch
+++ /dev/null
@@ -1,118 +0,0 @@
---- /dev/null 2016-06-24 11:30:22.921375825 +0200
-+++ qtbase/mkspecs/linux-g++-4.6/qmake.conf 2016-06-24 16:51:54.184917236 +0200
-@@ -0,0 +1,12 @@
-+#
-+# qmake configuration for linux-g++
-+#
-+
-+MAKEFILE_GENERATOR = UNIX
-+CONFIG += incremental gdb_dwarf_index
-+QMAKE_INCREMENTAL_STYLE = sublib
-+
-+include(../common/linux.conf)
-+include(../common/gcc-base-unix.conf)
-+include(../common/g++-unix.conf)
-+load(qt_config)
---- /dev/null 2016-06-24 11:30:22.921375825 +0200
-+++ qtbase/mkspecs/linux-g++-4.6/qplatformdefs.h 2016-06-24 16:51:54.184917236 +0200
-@@ -0,0 +1,100 @@
-+/****************************************************************************
-+**
-+** Copyright (C) 2013 Digia Plc and/or its subsidiary(-ies).
-+** Contact: http://www.qt-project.org/legal
-+**
-+** This file is part of the qmake spec of the Qt Toolkit.
-+**
-+** $QT_BEGIN_LICENSE:LGPL$
-+** Commercial License Usage
-+** Licensees holding valid commercial Qt licenses may use this file in
-+** accordance with the commercial license agreement provided with the
-+** Software or, alternatively, in accordance with the terms contained in
-+** a written agreement between you and Digia. For licensing terms and
-+** conditions see http://qt.digia.com/licensing. For further information
-+** use the contact form at http://qt.digia.com/contact-us.
-+**
-+** GNU Lesser General Public License Usage
-+** Alternatively, this file may be used under the terms of the GNU Lesser
-+** General Public License version 2.1 as published by the Free Software
-+** Foundation and appearing in the file LICENSE.LGPL included in the
-+** packaging of this file. Please review the following information to
-+** ensure the GNU Lesser General Public License version 2.1 requirements
-+** will be met: http://www.gnu.org/licenses/old-licenses/lgpl-2.1.html.
-+**
-+** In addition, as a special exception, Digia gives you certain additional
-+** rights. These rights are described in the Digia Qt LGPL Exception
-+** version 1.1, included in the file LGPL_EXCEPTION.txt in this package.
-+**
-+** GNU General Public License Usage
-+** Alternatively, this file may be used under the terms of the GNU
-+** General Public License version 3.0 as published by the Free Software
-+** Foundation and appearing in the file LICENSE.GPL included in the
-+** packaging of this file. Please review the following information to
-+** ensure the GNU General Public License version 3.0 requirements will be
-+** met: http://www.gnu.org/copyleft/gpl.html.
-+**
-+**
-+** $QT_END_LICENSE$
-+**
-+****************************************************************************/
-+
-+#ifndef QPLATFORMDEFS_H
-+#define QPLATFORMDEFS_H
-+
-+// Get Qt defines/settings
-+
-+#include "qglobal.h"
-+
-+// Set any POSIX/XOPEN defines at the top of this file to turn on specific APIs
-+
-+// 1) need to reset default environment if _BSD_SOURCE is defined
-+// 2) need to specify POSIX thread interfaces explicitly in glibc 2.0
-+// 3) it seems older glibc need this to include the X/Open stuff
-+#ifndef _GNU_SOURCE
-+# define _GNU_SOURCE
-+#endif
-+
-+#include <unistd.h>
-+
-+
-+// We are hot - unistd.h should have turned on the specific APIs we requested
-+
-+#include <features.h>
-+#include <pthread.h>
-+#include <dirent.h>
-+#include <fcntl.h>
-+#include <grp.h>
-+#include <pwd.h>
-+#include <signal.h>
-+
-+#include <sys/types.h>
-+#include <sys/ioctl.h>
-+#include <sys/ipc.h>
-+#include <sys/time.h>
-+#include <sys/shm.h>
-+#include <sys/socket.h>
-+#include <sys/stat.h>
-+#include <sys/wait.h>
-+#include <netinet/in.h>
-+#ifndef QT_NO_IPV6IFNAME
-+#include <net/if.h>
-+#endif
-+
-+#define QT_USE_XOPEN_LFS_EXTENSIONS
-+#include "../common/posix/qplatformdefs.h"
-+
-+#undef QT_SOCKLEN_T
-+
-+#if defined(__GLIBC__) && (__GLIBC__ >= 2)
-+#define QT_SOCKLEN_T socklen_t
-+#else
-+#define QT_SOCKLEN_T int
-+#endif
-+
-+#if defined(_XOPEN_SOURCE) && (_XOPEN_SOURCE >= 500)
-+#define QT_SNPRINTF ::snprintf
-+#define QT_VSNPRINTF ::vsnprintf
-+#endif
-+
-+#endif // QPLATFORMDEFS_H