summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--0001-Fix-g-5-build-see-qtwebkit-Source-JavaScriptCore-run.patch28
-rw-r--r--PKGBUILD18
3 files changed, 47 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index beeb48d60fcb..04bf7174fdc8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
-# Generated by makepkg 4.2.1
-# Sat Jun 20 11:55:55 UTC 2015
+# Generated by mksrcinfo v8
+# Tue Mar 22 10:48:56 UTC 2016
pkgbase = qt51
pkgver = 5.1.1
- pkgrel = 2
+ pkgrel = 3
url = http://qt-project.org/
arch = i686
arch = x86_64
@@ -50,6 +50,7 @@ pkgbase = qt51
source = bison3.patch
source = CVE-2013-4549.patch
source = libmng2.patch
+ source = 0001-Fix-g-5-build-see-qtwebkit-Source-JavaScriptCore-run.patch
source = qt51.PATH
md5sums = 697b7b8768ef8895e168366ab6b44760
md5sums = d6fd35a4858c2519385d13c04985a947
@@ -60,6 +61,7 @@ pkgbase = qt51
md5sums = 6b162cd2bc104f0ae83ca039401be7bf
md5sums = e59ba552e12408dcc9486cdbb1f233e3
md5sums = 478647fa057d190a7d789cf78995167b
+ md5sums = 27b294a3b24eae2c001f85961133eadb
md5sums = 28f4755e54ba1df5a89d60a73f6d1a9e
pkgname = qt51-base
diff --git a/0001-Fix-g-5-build-see-qtwebkit-Source-JavaScriptCore-run.patch b/0001-Fix-g-5-build-see-qtwebkit-Source-JavaScriptCore-run.patch
new file mode 100644
index 000000000000..4d004677c7fe
--- /dev/null
+++ b/0001-Fix-g-5-build-see-qtwebkit-Source-JavaScriptCore-run.patch
@@ -0,0 +1,28 @@
+From 548715948276124472a63343515ff9eb3f01ec28 Mon Sep 17 00:00:00 2001
+From: aur <aur>
+Date: Tue, 10 Nov 2015 17:59:28 +0100
+Subject: [PATCH] Fix g++ >= 5 build, see
+ qtwebkit/Source/JavaScriptCore/runtime/JSObject.cpp
+
+---
+ qtwebkit/Source/JavaScriptCore/runtime/JSObject.cpp | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/qtwebkit/Source/JavaScriptCore/runtime/JSObject.cpp b/qtwebkit/Source/JavaScriptCore/runtime/JSObject.cpp
+index e6f95bd..61baed8 100644
+--- a/qtwebkit/Source/JavaScriptCore/runtime/JSObject.cpp
++++ b/qtwebkit/Source/JavaScriptCore/runtime/JSObject.cpp
+@@ -1922,6 +1922,10 @@ void JSObject::putByIndexBeyondVectorLengthWithoutAttributes(ExecState* exec, un
+ }
+ }
+
++template void JSObject::putByIndexBeyondVectorLengthWithoutAttributes<Int32Shape>(ExecState* exec, unsigned i, JSValue value);
++template void JSObject::putByIndexBeyondVectorLengthWithoutAttributes<DoubleShape>(ExecState* exec, unsigned i, JSValue value);
++template void JSObject::putByIndexBeyondVectorLengthWithoutAttributes<ContiguousShape>(ExecState* exec, unsigned i, JSValue value);
++
+ void JSObject::putByIndexBeyondVectorLengthWithArrayStorage(ExecState* exec, unsigned i, JSValue value, bool shouldThrow, ArrayStorage* storage)
+ {
+ JSGlobalData& globalData = exec->globalData();
+--
+2.6.2
+
diff --git a/PKGBUILD b/PKGBUILD
index 311151159933..cd971841e95b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -24,7 +24,7 @@ pkgname=('qt51-base'
'qt51-x11extras'
'qt51-xmlpatterns')
pkgver=5.1.1
-pkgrel=2
+pkgrel=3
arch=('i686' 'x86_64')
url='http://qt-project.org/'
license=('GPL3' 'LGPL' 'FDL' 'custom')
@@ -37,9 +37,15 @@ makedepends=('libxcb' 'xcb-proto' 'xcb-util' 'xcb-util-image' 'xcb-util-wm' 'xcb
groups=('qt51')
_pkgfqn="qt-everywhere-opensource-src-${pkgver}"
source=("http://download.qt-project.org/official_releases/qt/5.1/${pkgver}/single/${_pkgfqn}.tar.xz"
- 'assistant-qt51.desktop' 'designer-qt51.desktop' 'linguist-qt51.desktop' 'qdbusviewer-qt51.desktop'
+ 'assistant-qt51.desktop'
+ 'designer-qt51.desktop'
+ 'linguist-qt51.desktop'
+ 'qdbusviewer-qt51.desktop'
'use-python2.patch'
- 'bison3.patch' 'CVE-2013-4549.patch' 'libmng2.patch'
+ 'bison3.patch'
+ 'CVE-2013-4549.patch'
+ 'libmng2.patch'
+ '0001-Fix-g-5-build-see-qtwebkit-Source-JavaScriptCore-run.patch'
'qt51.PATH')
md5sums=('697b7b8768ef8895e168366ab6b44760'
'd6fd35a4858c2519385d13c04985a947'
@@ -50,6 +56,7 @@ md5sums=('697b7b8768ef8895e168366ab6b44760'
'6b162cd2bc104f0ae83ca039401be7bf'
'e59ba552e12408dcc9486cdbb1f233e3'
'478647fa057d190a7d789cf78995167b'
+ '27b294a3b24eae2c001f85961133eadb'
'28f4755e54ba1df5a89d60a73f6d1a9e')
prepare() {
@@ -74,6 +81,9 @@ prepare() {
cd ../qtimageformats
patch -p1 -i "${srcdir}"/libmng2.patch
+
+ cd ..
+ patch -p1 -i "${srcdir}"/0001-Fix-g-5-build-see-qtwebkit-Source-JavaScriptCore-run.patch
}
build() {
@@ -87,7 +97,7 @@ build() {
-prefix /opt/$pkgbase \
-plugin-sql-{psql,mysql,sqlite,odbc,ibase} \
-system-sqlite \
- -openssl-linked \
+ --no-openssl \
-nomake examples \
-no-rpath \
-optimized-qmake \