summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD44
2 files changed, 43 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 34db5dd39bdd..ddf385970c91 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qt6-base-headless
pkgdesc = A cross-platform application and UI framework - headless build, no QtGui or QtWidgets
- pkgver = 6.3.1
+ pkgver = 6.7.0
pkgrel = 1
url = https://www.qt.io
arch = x86_64
@@ -10,16 +10,19 @@ pkgbase = qt6-base-headless
license = FDL
license = custom
makedepends = cmake
- makedepends = ninja
+ makedepends = git
makedepends = mariadb-libs
- makedepends = unixodbc
+ makedepends = ninja
makedepends = postgresql
- makedepends = xmlstarlet
makedepends = systemd
- depends = sqlite
- depends = double-conversion
+ makedepends = unixodbc
+ makedepends = xmlstarlet
depends = brotli
+ depends = double-conversion
depends = libb2
+ depends = sqlite
+ depends = zlib
+ depends = zstd
optdepends = postgresql-libs: PostgreSQL driver
optdepends = mariadb-libs: MariaDB driver
optdepends = md4c: C Markdown parser
@@ -27,13 +30,14 @@ pkgbase = qt6-base-headless
optdepends = shared-mime-info: Freedesktop.org Shared MIME Info
provides = qt6-base
conflicts = qt6-base
- options = debug
- source = https://download.qt.io/official_releases/qt/6.3/6.3.1/submodules/qtbase-everywhere-src-6.3.1.tar.xz
+ source = git+https://code.qt.io/qt/qtbase#tag=v6.7.0
source = qt6-base-cflags.patch
source = qt6-base-nostrip.patch
- sha256sums = 0a64421d9c2469c2c48490a032ab91d547017c9cc171f3f8070bc31888f24e03
+ source = fix-wrong-cpp-if.patch::https://code.qt.io/cgit/qt/qtbase.git/patch/?id=68102202
+ sha256sums = ee87abbfdf2d5bb204056bcb6c53e21c03e1abd779e3669faa56db7249c5e39e
sha256sums = 5411edbe215c24b30448fac69bd0ba7c882f545e8cf05027b2b6e2227abc5e78
sha256sums = 4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094
+ sha256sums = 81c4821fb1c258603474771a267d450aa8b5d1d298443bc04620d70719c7eab7
pkgname = qt6-base-headless
optdepends = postgresql-libs: PostgreSQL driver
diff --git a/PKGBUILD b/PKGBUILD
index e6e2aed004a1..072600a20534 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,15 +4,27 @@
# Contributor: Andrea Scarpino <andrea@archlinux.org>
pkgname=qt6-base-headless
-_qtver=6.3.1
+_qtver=6.7.0
pkgver=${_qtver/-/}
pkgrel=1
arch=(x86_64)
url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
pkgdesc='A cross-platform application and UI framework - headless build, no QtGui or QtWidgets'
-depends=(sqlite double-conversion brotli libb2)
-makedepends=(cmake ninja mariadb-libs unixodbc postgresql xmlstarlet systemd)
+depends=(brotli
+ double-conversion
+ libb2
+ sqlite
+ zlib
+ zstd)
+makedepends=(cmake
+ git
+ mariadb-libs
+ ninja
+ postgresql
+ systemd
+ unixodbc
+ xmlstarlet)
optdepends=('postgresql-libs: PostgreSQL driver'
'mariadb-libs: MariaDB driver'
'md4c: C Markdown parser'
@@ -21,18 +33,20 @@ optdepends=('postgresql-libs: PostgreSQL driver'
groups=(qt6)
conflicts=(qt6-base)
provides=(qt6-base)
-options=(debug)
-_pkgfn="qtbase-everywhere-src-$_qtver"
-source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz
+_pkgfn=qtbase
+source=(git+https://code.qt.io/qt/$_pkgfn#tag=v$pkgver
qt6-base-cflags.patch
- qt6-base-nostrip.patch)
-sha256sums=('0a64421d9c2469c2c48490a032ab91d547017c9cc171f3f8070bc31888f24e03'
+ qt6-base-nostrip.patch
+ fix-wrong-cpp-if.patch::https://code.qt.io/cgit/qt/qtbase.git/patch/?id=68102202)
+sha256sums=('ee87abbfdf2d5bb204056bcb6c53e21c03e1abd779e3669faa56db7249c5e39e'
'5411edbe215c24b30448fac69bd0ba7c882f545e8cf05027b2b6e2227abc5e78'
- '4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094')
+ '4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094'
+ '81c4821fb1c258603474771a267d450aa8b5d1d298443bc04620d70719c7eab7')
prepare() {
patch -d $_pkgfn -p1 < qt6-base-cflags.patch # Use system CFLAGS
patch -d $_pkgfn -p1 < qt6-base-nostrip.patch # Don't strip binaries with qmake
+ patch -d $_pkgfn -p1 < fix-wrong-cpp-if.patch # https://bugreports.qt.io/browse/QTBUG-123937
}
build() {
@@ -48,16 +62,18 @@ build() {
-DINSTALL_INCLUDEDIR=include/qt6 \
-DINSTALL_MKSPECSDIR=lib/qt6/mkspecs \
-DINSTALL_EXAMPLESDIR=share/doc/qt6/examples \
- -DQT_FEATURE_journald=ON \
- -DQT_FEATURE_openssl_linked=ON \
- -DQT_FEATURE_system_sqlite=ON \
+ -DFEATURE_journald=ON \
+ -DFEATURE_openssl_linked=ON \
+ -DFEATURE_system_sqlite=ON \
+ -DFEATURE_no_direct_extern_access=ON \
-DCMAKE_INTERPROCEDURAL_OPTIMIZATION=ON \
+ -DCMAKE_MESSAGE_LOG_LEVEL=STATUS \
\
-DQT_FEATURE_gui=OFF \
-DQT_FEATURE_widgets=OFF \
-DQT_FEATURE_freetype=OFF \
-DQT_FEATURE_harfbuzz=OFF \
- -DQT_FEATURE_zstd=OFF
+ -DQT_FEATURE_zstd=ON
cmake --build build
}
@@ -66,7 +82,7 @@ package() {
optdepends+=('qt6-translations: Translations')
DESTDIR="$pkgdir" cmake --install build
- install -Dm644 $_pkgfn/LICENSE* -t "$pkgdir"/usr/share/licenses/$pkgbase
+ install -Dm644 $_pkgfn/LICENSES/* -t "$pkgdir"/usr/share/licenses/$pkgbase
# Install symlinks for user-facing tools
cd "$pkgdir"