summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD20
3 files changed, 19 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5523262d4efb..b741b9785589 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qt6-base-headless
pkgdesc = A cross-platform application and UI framework - headless build, no QtGui or QtWidgets
- pkgver = 6.1.3
+ pkgver = 6.2.0
pkgrel = 1
url = https://www.qt.io
arch = x86_64
@@ -22,16 +22,19 @@ pkgbase = qt6-base-headless
depends = libb2
optdepends = postgresql-libs: PostgreSQL driver
optdepends = mariadb-libs: MariaDB driver
+ optdepends = md4c: C Markdown parser
optdepends = unixodbc: ODBC driver
optdepends = shared-mime-info: Freedesktop.org Shared MIME Info
provides = qt6-base
conflicts = qt6-base
options = !lto
- source = https://download.qt.io/official_releases/qt/6.1/6.1.3/submodules/qtbase-everywhere-src-6.1.3.tar.xz
+ source = https://download.qt.io/official_releases/qt/6.2/6.2.0/submodules/qtbase-everywhere-src-6.2.0.tar.xz
source = qt6-base-cflags.patch
source = qt6-base-nostrip.patch
- sha256sums = 1e9abb2ea4daa0fd11f46fc871d9e896b916e1b7130fed74c83d66221bb4fe78
+ source = qtbug-96392.patch::https://code.qt.io/cgit/qt/qtbase.git/patch/?id=5c7b3db32bf383afa00050370222f39e0f3083ca
+ sha256sums = fdfff0716d093bcb6bcd53746ce1d3c9701a6bf3326d47813866d43949b47769
sha256sums = cf707cd970650f8b60f8897692b36708ded9ba116723ec8fcd885576783fe85c
sha256sums = 4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094
+ sha256sums = 4c999415cf813591efa2e5bc5f692a4a7a822ad94837a01ef9c802f96c3ebd90
pkgname = qt6-base-headless
diff --git a/.gitignore b/.gitignore
index 165c4d4ecf2b..586a8d739a0d 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
*~
*.log
*.tar.xz
+qtbug-96392.patch
qtbase-everywhere-src-*.tar.xz
qt6-base-headless-*.pkg.tar.*
diff --git a/PKGBUILD b/PKGBUILD
index 070d7511385a..e93a13ca0ff9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,17 +4,18 @@
# Contributor: Andrea Scarpino <andrea@archlinux.org>
pkgname=qt6-base-headless
-_qtver=6.1.3
+_qtver=6.2.0
pkgver=${_qtver/-/}
pkgrel=1
arch=(x86_64)
url='https://www.qt.io'
license=(GPL3 LGPL3 FDL custom)
pkgdesc='A cross-platform application and UI framework - headless build, no QtGui or QtWidgets'
-depends=(sqlite double-conversion brotli libb2) # md4c - not supported yet
+depends=(sqlite double-conversion brotli libb2)
makedepends=(cmake ninja mariadb-libs unixodbc postgresql xmlstarlet systemd)
optdepends=('postgresql-libs: PostgreSQL driver'
'mariadb-libs: MariaDB driver'
+ 'md4c: C Markdown parser'
'unixodbc: ODBC driver'
'shared-mime-info: Freedesktop.org Shared MIME Info')
groups=(qt6)
@@ -24,18 +25,21 @@ options=(!lto)
_pkgfn="qtbase-everywhere-src-$_qtver"
source=(https://download.qt.io/official_releases/qt/${pkgver%.*}/$_qtver/submodules/$_pkgfn.tar.xz
qt6-base-cflags.patch
- qt6-base-nostrip.patch)
-sha256sums=('1e9abb2ea4daa0fd11f46fc871d9e896b916e1b7130fed74c83d66221bb4fe78'
+ qt6-base-nostrip.patch
+ qtbug-96392.patch::https://code.qt.io/cgit/qt/qtbase.git/patch/?id=5c7b3db32bf383afa00050370222f39e0f3083ca)
+sha256sums=('fdfff0716d093bcb6bcd53746ce1d3c9701a6bf3326d47813866d43949b47769'
'cf707cd970650f8b60f8897692b36708ded9ba116723ec8fcd885576783fe85c'
- '4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094')
+ '4b93f6a79039e676a56f9d6990a324a64a36f143916065973ded89adc621e094'
+ '4c999415cf813591efa2e5bc5f692a4a7a822ad94837a01ef9c802f96c3ebd90')
prepare() {
- patch -d $_pkgfn -p1 -i ../qt6-base-cflags.patch # Use system CFLAGS
- patch -d $_pkgfn -p1 -i ../qt6-base-nostrip.patch # Don't strip binaries with qmake
+ patch -d $_pkgfn -p1 < qt6-base-cflags.patch # Use system CFLAGS
+ patch -d $_pkgfn -p1 < qt6-base-nostrip.patch # Don't strip binaries with qmake
+ patch -d $_pkgfn -p1 < qtbug-96392.patch # https://bugreports.qt.io/browse/QTBUG-96392
}
build() {
- cmake -G Ninja -B build -S "$_pkgfn" \
+ cmake -B build -S "$_pkgfn" -G Ninja \
-DCMAKE_INSTALL_PREFIX=/usr \
-DINSTALL_BINDIR=lib/qt6/bin \
-DINSTALL_PUBLICBINDIR=usr/bin \