summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
-rwxr-xr-xorg.qt-project.qtcreator.desktop22
-rw-r--r--qtcreator-clang-plugins.patch43
4 files changed, 29 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e72b96600879..789a64d384ae 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -35,10 +35,9 @@ pkgbase = qtcreator-git
options = docs
source = git+https://code.qt.io/qt-creator/qt-creator.git
source = git+https://code.qt.io/qbs/qbs.git
- source = qtcreator-clang-plugins.patch
+ source = org.qt-project.qtcreator.desktop
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 26382c282c36aa6716af2deadae864ed21ffba0dd568f9b8f8f8048ce304f436
+ sha256sums = 90addb552923db0897f7096d166c2d1bf1c3390ae9c79687fc4ce7c4e57ee810
pkgname = qtcreator-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 275385eb355f..e346fe077e0b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -33,10 +33,10 @@ provides=(qtcreator qbs)
conflicts=(qtcreator qbs)
source=('git+https://code.qt.io/qt-creator/qt-creator.git'
'git+https://code.qt.io/qbs/qbs.git'
- 'qtcreator-clang-plugins.patch')
+ 'org.qt-project.qtcreator.desktop')
sha256sums=('SKIP'
'SKIP'
- '26382c282c36aa6716af2deadae864ed21ffba0dd568f9b8f8f8048ce304f436')
+ '90addb552923db0897f7096d166c2d1bf1c3390ae9c79687fc4ce7c4e57ee810')
pkgver() {
cd qt-creator
@@ -52,11 +52,6 @@ prepare() {
# fix hardcoded libexec path
sed -e 's|libexec\/qtcreator|lib\/qtcreator|g' -i qtcreator.pri
- # Load analyzer plugins on demand, since upstream clang doesn't link to all plugins
- # see http://code.qt.io/cgit/clang/clang.git/commit/?id=7f349701d3ea0c47be3a43e265699dddd3fd55cf
- # and https://bugs.archlinux.org/task/59492
- patch -p1 -i ../qtcreator-clang-plugins.patch
-
# Do *NOT* use system Qbs: qt creator master is *NOT* compatible with any released Qbs!
( cd src/shared && rm -rf qbs && ln -s ../../../qbs qbs )
}
@@ -79,4 +74,7 @@ package() {
install -Dm644 "${srcdir}/qt-creator/LICENSE.GPL3-EXCEPT" \
"${pkgdir}/usr/share/licenses/qtcreator/LICENSE.GPL3-EXCEPT"
+
+ mkdir -p "${pkgdir}/usr/share/applications/"
+ cp "${srcdir}/org.qt-project.qtcreator.desktop" "${pkgdir}/usr/share/applications/"
}
diff --git a/org.qt-project.qtcreator.desktop b/org.qt-project.qtcreator.desktop
new file mode 100755
index 000000000000..d058ba0dab6f
--- /dev/null
+++ b/org.qt-project.qtcreator.desktop
@@ -0,0 +1,22 @@
+[Desktop Entry]
+Categories=Development;IDE;Qt;
+Comment[ru_RU]=
+Comment=
+Exec=qtcreator %F
+GenericName[ru_RU]=C++ IDE for developing Qt applications
+GenericName=C++ IDE for developing Qt applications
+Icon=QtProject-qtcreator
+MimeType=text/x-c++src;text/x-c++hdr;application/x-designer;
+Name[ru_RU]=Qt Creator
+Name=Qt Creator
+Path=
+StartupNotify=true
+StartupWMClass=qtcreator
+Terminal=false
+TerminalOptions=
+Type=Application
+X-DBUS-ServiceName=
+X-DBUS-StartupType=
+X-KDE-StartupNotify=true
+X-KDE-SubstituteUID=false
+X-KDE-Username=
diff --git a/qtcreator-clang-plugins.patch b/qtcreator-clang-plugins.patch
deleted file mode 100644
index 791c32781b7f..000000000000
--- a/qtcreator-clang-plugins.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-diff '--color=auto' --unified --recursive --text qt-creator.orig/src/plugins/clangcodemodel/clangeditordocumentprocessor.cpp qt-creator.new/src/plugins/clangcodemodel/clangeditordocumentprocessor.cpp
---- qt-creator.orig/src/plugins/clangcodemodel/clangeditordocumentprocessor.cpp 2019-05-03 16:09:59.000000000 -0300
-+++ qt-creator.new/src/plugins/clangcodemodel/clangeditordocumentprocessor.cpp 2019-05-03 15:57:36.000000000 -0300
-@@ -511,6 +511,7 @@
- if (tidyMode == Mode::Disabled)
- return;
-
-+ m_options.append(CppTools::XclangArgs({"-load", "libclangTidyPlugin.so"}));
- m_options.append(CppTools::XclangArgs({"-add-plugin", "clang-tidy"}));
-
- if (tidyMode == Mode::File)
-@@ -526,8 +527,8 @@
- if (checks.isEmpty())
- return;
-
-- m_options.append(CppTools::XclangArgs({"-add-plugin",
-- "clazy",
-+ m_options.append(CppTools::XclangArgs({"-load", "ClazyPlugin.so",
-+ "-add-plugin", "clazy",
- "-plugin-arg-clazy",
- "enable-all-fixits",
- "-plugin-arg-clazy",
-diff '--color=auto' --unified --recursive --text qt-creator.orig/src/plugins/clangtools/clangtidyclazyrunner.cpp qt-creator.new/src/plugins/clangtools/clangtidyclazyrunner.cpp
---- qt-creator.orig/src/plugins/clangtools/clangtidyclazyrunner.cpp 2019-05-03 16:09:59.000000000 -0300
-+++ qt-creator.new/src/plugins/clangtools/clangtidyclazyrunner.cpp 2019-05-03 16:02:39.000000000 -0300
-@@ -76,6 +76,7 @@
-
- const ClangDiagnosticConfig::TidyMode tidyMode = m_diagnosticConfig.clangTidyMode();
- if (tidyMode != ClangDiagnosticConfig::TidyMode::Disabled) {
-+ arguments << XclangArgs({"-load", "libclangTidyPlugin.so"});
- arguments << XclangArgs({"-add-plugin", "clang-tidy"});
- if (tidyMode != ClangDiagnosticConfig::TidyMode::File) {
- const QString tidyChecks = m_diagnosticConfig.clangTidyChecks();
-@@ -85,7 +86,8 @@
-
- const QString clazyChecks = m_diagnosticConfig.clazyChecks();
- if (!clazyChecks.isEmpty()) {
-- arguments << XclangArgs({"-add-plugin",
-+ arguments << XclangArgs({"-load", "ClazyPlugin.so",
-+ "-add-plugin",
- "clazy",
- "-plugin-arg-clazy",
- "enable-all-fixits",