summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD14
2 files changed, 12 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 74be566a2e09..1540c9ee885f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Thu May 4 21:41:59 UTC 2017
pkgbase = qtcurve-git
pkgdesc = A configurable set of widget styles for KDE and Gtk.
- pkgver = 1.8.18.293.ga249871e
+ pkgver = 1.9.0.rc1.75.gbe78a85b
pkgrel = 1
url = https://github.com/QtCurve/qtcurve
arch = i686
@@ -10,8 +8,10 @@ pkgbase = qtcurve-git
groups = qtcurve
license = GPL
makedepends = cmake
- makedepends = automoc4
makedepends = git
+ makedepends = extra-cmake-modules
+ makedepends = kio
+ makedepends = kconfig
depends = qt5-base
depends = qt5-svg
depends = libxcb
@@ -19,6 +19,8 @@ pkgbase = qtcurve-git
depends = gtk2
depends = libx11
depends = gcc-libs
+ depends = qt4
+ depends = frameworkintegration
provides = qtcurve-utils=1.8.18
provides = qtcurve-gtk2=1.8.18
provides = qtcurve-kde4=1.8.18
@@ -36,8 +38,7 @@ pkgbase = qtcurve-git
conflicts = qtcurve-utils
options = !debug
options = strip
- source = git://anongit.kde.org/qtcurve.git
+ source = git+https://invent.kde.org/system/qtcurve.git
sha512sums = SKIP
pkgname = qtcurve-git
-
diff --git a/PKGBUILD b/PKGBUILD
index f30ff3baca86..d6ef8fcb9edb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=qtcurve-git
_realver=1.8.18
-pkgver=1.8.18.293.ga249871e
+pkgver=1.9.0.rc1.75.gbe78a85b
pkgrel=1
pkgdesc='A configurable set of widget styles for KDE and Gtk.'
arch=('i686' 'x86_64')
@@ -10,8 +10,8 @@ url="https://github.com/QtCurve/qtcurve"
license=('GPL')
groups=('qtcurve')
depends=('qt5-base' 'qt5-svg' 'libxcb' 'qt5-x11extras'
- 'gtk2' 'libx11' 'gcc-libs')
-makedepends=('cmake' 'automoc4' 'git')
+ 'gtk2' 'libx11' 'gcc-libs' 'qt4' 'frameworkintegration')
+makedepends=('cmake' 'git' 'extra-cmake-modules' 'kio' 'kconfig')
provides=(
"qtcurve-utils=${_realver}"
"qtcurve-gtk2=${_realver}"
@@ -26,7 +26,7 @@ provides=(
conflicts=("qtcurve-kde4" "qtcurve-qt4"
"qtcurve-qt5" "qtcurve-gtk2" "qtcurve-utils")
options=('!debug' 'strip')
-source=(git://anongit.kde.org/qtcurve.git)
+source=("git+https://invent.kde.org/system/qtcurve.git")
_gitname=qtcurve
pkgver() {
@@ -43,11 +43,7 @@ build() {
cmake .. \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
- -DQT_QMAKE_EXECUTABLE=qmake-qt5 \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DQTC_KDE4_PREFIX=/usr \
- -DQTC_QT4_ENABLE_KDE:BOOL="0" \
- -DQTC_QT4_STYLE_SUPPORT:BOOL="0"
+ -DCMAKE_INSTALL_PREFIX=/usr
make
}