summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO6
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD8
3 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a52bb199f270..f23fb87ad840 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qtextpad
pkgdesc = Lightweight cross-platform text editor using KF5's syntax highlighting repository.
- pkgver = 1.0
+ pkgver = 1.1
pkgrel = 1
url = https://github.com/zrax/qtextpad
arch = i686
@@ -9,8 +9,8 @@ pkgbase = qtextpad
makedepends = cmake
depends = syntax-highlighting
depends = file
- source = git+https://github.com/zrax/qtextpad#tag=1.0
- sha256sums = SKIP
+ source = qtextpad-1.1.tar.gz::https://github.com/zrax/qtextpad/archive/1.1.tar.gz
+ sha256sums = f5c8e9235c53753e4b8c2e0f24ea6028ef3098c0f4ef9786c9d4ab3dd3236b29
pkgname = qtextpad
diff --git a/.gitignore b/.gitignore
index d4ae6f1141b7..3da66d15d4c8 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1,6 @@
/src/
/pkg/
/qtextpad/
+qtextpad-*.tar.gz
*.pkg.tar.xz
*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 35e26d7b19ea..d37f57d049b3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,15 +2,15 @@
pkgname=qtextpad
pkgdesc="Lightweight cross-platform text editor using KF5's syntax highlighting repository."
-pkgver=1.0
+pkgver=1.1
pkgrel=1
arch=('i686' 'x86_64')
url='https://github.com/zrax/qtextpad'
license=('GPL3')
depends=('syntax-highlighting' 'file')
makedepends=('cmake')
-source=("git+https://github.com/zrax/${pkgname}#tag=${pkgver}")
-sha256sums=('SKIP')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('f5c8e9235c53753e4b8c2e0f24ea6028ef3098c0f4ef9786c9d4ab3dd3236b29')
build() {
mkdir -p "${srcdir}/build"
@@ -18,7 +18,7 @@ build() {
cmake -DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
- "${srcdir}/${pkgname}"
+ "${srcdir}/${pkgname}-${pkgver}"
make
}