summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PKGBUILD11
-rw-r--r--qt-5.15+gentoo.patch22
2 files changed, 30 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 78f13711609d..7c96fafaf9fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,7 +11,7 @@
_pkgname=qtfm
pkgname=$_pkgname-git
-pkgver=2019.08.23
+pkgver=2019.10.14
pkgrel=1
pkgdesc="A lightweight file manager (git version)"
arch=('i686' 'x86_64')
@@ -20,14 +20,19 @@ license=('GPL')
depends=('qt5-base' 'desktop-file-utils' 'ffmpeg' 'hicolor-icon-theme' 'imagemagick')
provides=('qtfm')
conflicts=('qtfm')
-source=('qtfm::git+https://github.com/rodlie/qtfm.git#branch=master')
-md5sums=('SKIP')
+source=('qtfm::git+https://github.com/rodlie/qtfm.git#branch=master' 'qt-5.15+gentoo.patch')
+sha256sums=('SKIP' '34271a58f32eeed01ab2db408505e8a1cef20f4a60a372ba78c5607b404eb010')
pkgver() {
cd "$_pkgname"
git log -1 --format=%ci | sed 's/[ :-]/./g' | cut -d. -f1-3
}
+prepare() {
+ cd "${pkgname%-git}"
+ patch -Np1 < "$srcdir"/qt-5.15+gentoo.patch
+}
+
build() {
cd $_pkgname
[[ -d build ]] || mkdir build
diff --git a/qt-5.15+gentoo.patch b/qt-5.15+gentoo.patch
new file mode 100644
index 000000000000..5c286c792d75
--- /dev/null
+++ b/qt-5.15+gentoo.patch
@@ -0,0 +1,22 @@
+diff -Naur qtfm-6.2.0.orig/libfm/iconlist.cpp qtfm-6.2.0.new/libfm/iconlist.cpp
+--- qtfm-6.2.0.orig/libfm/iconlist.cpp 2019-06-04 07:47:00.000000000 +0200
++++ qtfm-6.2.0.new/libfm/iconlist.cpp 2020-08-02 17:47:04.899432194 +0200
+@@ -1,5 +1,7 @@
+ #include "iconlist.h"
+
++#include <QPainterPath>
++
+ QSize IconListDelegate::sizeHint(const QStyleOptionViewItem &option,
+ const QModelIndex &index) const
+ {
+diff -Naur qtfm-6.2.0.orig/libfm/iconview.cpp qtfm-6.2.0.new/libfm/iconview.cpp
+--- qtfm-6.2.0.orig/libfm/iconview.cpp 2019-06-04 07:47:00.000000000 +0200
++++ qtfm-6.2.0.new/libfm/iconview.cpp 2020-08-02 17:46:53.629482772 +0200
+@@ -1,5 +1,7 @@
+ #include "iconview.h"
+
++#include <QPainterPath>
++
+ bool IconViewDelegate::eventFilter(QObject *object,
+ QEvent *event)
+ {