summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 5 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb668d2ca6cf..f59f6f0f974a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = qtile-git
- pkgdesc = A full-featured, pure-Python tiling window manager. (git version)
+ pkgdesc = A full-featured, pure-Python tiling window manager - X11. (git version)
pkgver = 0.20.0.r33.gc1f50739
pkgrel = 2
url = http://www.qtile.org
@@ -17,20 +17,14 @@ pkgbase = qtile-git
checkdepends = python-dbus-next
checkdepends = python-gobject
checkdepends = python-pytest
- checkdepends = python-pywlroots>=0.15.12
- checkdepends = python-pywlroots<0.16.0
checkdepends = python-xdg
checkdepends = python-xvfbwrapper
- checkdepends = wlroots
checkdepends = xorg-server-xephyr
checkdepends = xorg-xrandr
- checkdepends = xorg-xwayland
makedepends = git
makedepends = python-setuptools
makedepends = python-setuptools-scm
makedepends = libpulse
- makedepends = python-pywlroots>=0.15.12
- makedepends = python-pywlroots<0.16.0
depends = gdk-pixbuf2
depends = glibc
depends = pango
diff --git a/PKGBUILD b/PKGBUILD
index eb9339848f84..9a87c839f845 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,16 @@
# Maintainer: mcol <mcol@posteo.net>
# Contributor: roger <roger@rogerpc.com.ar>
+# This PKGBUILD packages Qtile with X11 dependencies.
+
pkgname=qtile-git
pkgver=0.20.0.r33.gc1f50739
pkgrel=2
-pkgdesc="A full-featured, pure-Python tiling window manager. (git version)"
+pkgdesc="A full-featured, pure-Python tiling window manager - X11. (git version)"
arch=('x86_64')
url="http://www.qtile.org"
license=('MIT')
-_pywlroots_requirement="0.15.12"
-
-# Technically the X-related dependencies are *not* required, if the user only
-# wants to use the Wayland backend. However this would cause disruption, so
-# let's hold off on changing that for now.
depends=(
'gdk-pixbuf2'
'glibc'
@@ -28,7 +25,6 @@ makedepends=(
'python-setuptools'
'python-setuptools-scm'
'libpulse'
- "python-pywlroots>=$_pywlroots_requirement" 'python-pywlroots<0.16.0'
)
checkdepends=(
'dbus'
@@ -42,13 +38,10 @@ checkdepends=(
'python-dbus-next'
'python-gobject'
'python-pytest'
- "python-pywlroots>=$_pywlroots_requirement" 'python-pywlroots<0.16.0'
'python-xdg'
'python-xvfbwrapper'
- 'wlroots'
'xorg-server-xephyr'
'xorg-xrandr'
- 'xorg-xwayland'
)
optdepends=(
'alsa-utils: volume widget'
@@ -93,8 +86,7 @@ check() {
# export MYPYPATH="$PWD:$PWD/stubs"
# mypy-based tests are ignored until I figure out how to fix them
# Plus they won't change from merge to package
- #pytest -vv --backend x11 --backend wayland \
- # --ignore test/test_check.py --ignore test/test_migrate.py test
+ #pytest -vv --backend x11 --ignore test/test_check.py --ignore test/test_migrate.py test
}
package() {