summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO54
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD108
-rw-r--r--qtile-git.install4
4 files changed, 132 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e072c11daf9..dafbdbfcb375 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,58 @@
pkgbase = qtile-git
pkgdesc = A full-featured, pure-Python tiling window manager. (git version)
- pkgver = 3444.458c4875
- pkgrel = 2
+ pkgver = v0.18.0.r111.g6009be07
+ pkgrel = 1
url = http://www.qtile.org
install = qtile-git.install
- arch = any
+ arch = x86_64
license = MIT
- makedepends = python-setuptools
+ checkdepends = dbus
+ checkdepends = graphviz
+ checkdepends = gtk3
+ checkdepends = imagemagick
+ checkdepends = libnotify
+ checkdepends = librsvg
+ checkdepends = mypy
+ checkdepends = python-bowler
+ checkdepends = python-dbus-next
+ checkdepends = python-gobject
+ checkdepends = python-pytest
+ checkdepends = python-pywlroots
+ checkdepends = python-xdg
+ checkdepends = python-xvfbwrapper
+ checkdepends = wlroots
+ checkdepends = xorg-server-xephyr
+ checkdepends = xorg-xrandr
makedepends = git
- depends = python
+ makedepends = python-setuptools
+ makedepends = python-setuptools-scm
+ makedepends = libpulse
+ depends = gdk-pixbuf2
+ depends = glibc
depends = pango
- depends = python-xcffib
depends = python-cairocffi
- optdepends = python-setproctitle: change the process name to qtile
+ depends = python-cffi
+ depends = python-xcffib
+ optdepends = alsa-utils: volume widget
+ optdepends = canto-daemon: canto widget
+ optdepends = cmus: cmus widget
+ optdepends = jupyter_console: interaction with qtile via Jupyter
+ optdepends = khal: khal_calendar widget
+ optdepends = libpulse: for pulse_volume and pulseaudio_ffi widget
+ optdepends = librsvg: for SVG support in some widgets widgets or wallpapers
+ optdepends = lm_sensors: sensors widget
+ optdepends = moc: moc widget
+ optdepends = python-dbus-next: for utils, notifications and several widgets
+ optdepends = python-iwlib: wlan widget
+ optdepends = python-keyring: imapwidget widget
+ optdepends = python-mpd2: mpd2widget widget
+ optdepends = python-psutil: graph, net and memory widget
+ optdepends = python-pywlroots: Wayland backend
+ optdepends = python-setproctitle: change process name to qtile
+ optdepends = python-xdg: launchbar widget
provides = qtile
conflicts = qtile
- source = git://github.com/qtile/qtile.git
+ source = git+https://github.com/qtile/qtile
md5sums = SKIP
pkgname = qtile-git
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..62cb201228dd
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+*.log
+qtile
diff --git a/PKGBUILD b/PKGBUILD
index 58165bfca44b..b3f3678a957a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,41 +1,99 @@
-# Maintainer: roger <roger@rogerpc.com.ar>
+# Maintainer: mcol <mcol@posteo.net>
+# Contributor: roger <roger@rogerpc.com.ar>
pkgname=qtile-git
-pkgver=3444.458c4875
-pkgrel=2
+pkgver=v0.18.0.r111.g6009be07
+pkgrel=1
pkgdesc="A full-featured, pure-Python tiling window manager. (git version)"
-arch=('any')
+arch=('x86_64')
url="http://www.qtile.org"
license=('MIT')
-depends=('python' 'pango' 'python-xcffib' 'python-cairocffi')
-makedepends=('python-setuptools' 'git')
-optdepends=('python-setproctitle: change the process name to qtile')
+
+# Technically the X-related dependencies are *not* required, if the user only
+# wants to use the Wayland backend. However this would cause disruption, so
+# let's hold off on changing that for now.
+depends=(
+ 'gdk-pixbuf2'
+ 'glibc'
+ 'pango'
+ 'python-cairocffi'
+ 'python-cffi'
+ 'python-xcffib'
+)
+
+makedepends=('git' 'python-setuptools' 'python-setuptools-scm' 'libpulse')
+checkdepends=(
+ 'dbus'
+ 'graphviz'
+ 'gtk3'
+ 'imagemagick'
+ 'libnotify'
+ 'librsvg'
+ 'mypy'
+ 'python-bowler'
+ 'python-dbus-next'
+ 'python-gobject'
+ 'python-pytest'
+ 'python-pywlroots'
+ 'python-xdg'
+ 'python-xvfbwrapper'
+ 'wlroots'
+ 'xorg-server-xephyr'
+ 'xorg-xrandr'
+)
+optdepends=(
+ 'alsa-utils: volume widget'
+ 'canto-daemon: canto widget'
+ 'cmus: cmus widget'
+ 'jupyter_console: interaction with qtile via Jupyter'
+ 'khal: khal_calendar widget'
+ 'libpulse: for pulse_volume and pulseaudio_ffi widget'
+ 'librsvg: for SVG support in some widgets widgets or wallpapers'
+ 'lm_sensors: sensors widget'
+ 'moc: moc widget'
+ 'python-dbus-next: for utils, notifications and several widgets'
+ 'python-iwlib: wlan widget'
+ 'python-keyring: imapwidget widget'
+ 'python-mpd2: mpd2widget widget'
+ 'python-psutil: graph, net and memory widget'
+ 'python-pywlroots: Wayland backend'
+ 'python-setproctitle: change process name to qtile'
+ 'python-xdg: launchbar widget'
+)
provides=('qtile')
conflicts=('qtile')
install=${pkgname}.install
-source=('git://github.com/qtile/qtile.git')
+source=('git+https://github.com/qtile/qtile')
md5sums=('SKIP')
-_gitname="qtile"
-
pkgver() {
- cd $_gitname
- echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ cd qtile
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
-package() {
- cd $_gitname
- # license
- msg "Copying license..."
- install -D -m 644 LICENSE $pkgdir/usr/share/licenses/$pkgname/LICENSE
-
- msg "Copying default config..."
- install -D -m 644 $srcdir/$_gitname/libqtile/resources/default_config.py $pkgdir/usr/share/doc/$pkgname/default_config.py
+build() {
+ cd qtile
+ python setup.py build
+ ./scripts/ffibuild
+}
- msg "Copying desktop file..."
- install -D -m 644 $srcdir/$_gitname/resources/qtile.desktop $pkgdir/usr/share/xsessions/qtile.desktop
+check() {
+ cd qtile
+ export LC_TYPE=en_US.UTF-8
+ # export MYPYPATH="$PWD:$PWD/stubs"
+ # mypy-based tests are ignored until I figure out how to fix them
+ # Plus they won't change from merge to package
+ pytest -vv --backend x11 --backend wayland \
+ --ignore test/test_check.py --ignore test/test_migrate.py test
+}
- # install
- msg "Running setup.py"
- python setup.py install --root=${pkgdir} --prefix=/usr
+package() {
+ cd qtile
+ python setup.py install --skip-build --optimize=1 --root="$pkgdir"
+ install -vDm 644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+ install -vDm 644 "$srcdir"/qtile/libqtile/resources/default_config.py \
+ "$pkgdir"/usr/share/doc/$pkgname/default_config.py
+ install -vDm 644 "$srcdir"/qtile/resources/qtile.desktop \
+ "$pkgdir"/usr/share/xsessions/qtile.desktop
+ install -vDm 644 CHANGELOG README.rst -t "${pkgdir}/usr/share/doc/$pkgname/"
}
diff --git a/qtile-git.install b/qtile-git.install
index 80fcc9179676..4374d5b847ef 100644
--- a/qtile-git.install
+++ b/qtile-git.install
@@ -4,8 +4,8 @@ post_install() {
}
post_upgrade() {
+ echo ">>> Qtile Changelog at"
+ echo ">>> /usr/share/doc/qtile-git/CHANGELOG"
echo ">>> Qtile Example Config at"
echo ">>> /usr/share/doc/qtile-git/default_config.py"
}
-
-# vim:set ts=2 sw=2 et: