summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--MatrixValuesDialog.patch11
-rw-r--r--PKGBUILD12
-rw-r--r--SetColValuesDialog.patch17
-rw-r--r--TableDialog.patch11
4 files changed, 50 insertions, 1 deletions
diff --git a/MatrixValuesDialog.patch b/MatrixValuesDialog.patch
new file mode 100644
index 000000000000..49beff792514
--- /dev/null
+++ b/MatrixValuesDialog.patch
@@ -0,0 +1,11 @@
+--- qtiplot-0.9.8.9/qtiplot/src/matrix/MatrixValuesDialog.cpp 2010-09-27 09:12:45.000000000 +0200
++++ qtiplot-0.9.8.9/qtiplot/src/matrix/MatrixValuesDialog.cpp 2019-12-30 12:56:06.634701739 +0100
+@@ -70,7 +70,7 @@
+ endCol->setRange(1, INT_MAX);
+ gl1->addWidget(endCol, 1, 3);
+
+- functions = new QComboBox(false);
++ functions = new QComboBox();
+ functions->addItems(scriptEnv->mathFunctions());
+ btnAddFunction = new QPushButton(tr( "Add &Function" ));
+ btnAddCell = new QPushButton(tr( "Add Ce&ll" ));
diff --git a/PKGBUILD b/PKGBUILD
index 8a1664af40a5..2614e4cf6d19 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -38,6 +38,9 @@ source=("http://downloads.sourceforge.net/project/qtiplot.berlios/qtiplot-${pkgv
"FitDialog.patch"
"LayerDialog.patch"
"PlotDialog.patch"
+"MatrixValuesDialog.patch"
+"TableDialog.patch"
+"SetColValuesDialog.patch"
)
noextract=("opj.tar.bz2"
@@ -63,7 +66,11 @@ sha256sums=('a523ea259516d7581abaf2fe376507d152db32f71d88176cff18f5bc391b9ef0'
'e5476599521289928e50462f6c9080185581f0c15b2dc274c96ca2c1fd8fa72a'
'da119d0d4abdf8954f7fc52efc9fc738897e4bdcc9b767444e549fb00a62578a'
'2427a152acdbe312211b7d57e73d47e9cd7f698440952784de6db4c0429cea22'
- "5eda5e19bf54fe00e15082987fd6a3e6833a393773fb35e6bd89d453f3585a3f")
+ "5eda5e19bf54fe00e15082987fd6a3e6833a393773fb35e6bd89d453f3585a3f"
+ "ce01c40744dbccdb1296c4c9d83f0c75a83fae22a1a1ef58d8ce385ff4b970f6"
+ "4b24e70d6abc155e8b6b74fc68bdd2c535a2716bb5eae5b9ab59d24f6b599dd6"
+ "ccd3ce2fb5230cdccd34706be7b20124b860ff4daedc334f90ed94f99e2c3217")
+
prepare() {
cd "$srcdir"
@@ -84,6 +91,9 @@ patch -p0 < ConfigDialog.patch
patch -p0 < ColorMapEditor.patch
patch -p0 < LayerDialog.patch
patch -p0 < PlotDialog.patch
+patch -p0 < MatrixValuesDialog.patch
+patch -p0 < SetColValuesDialog.patch
+patch -p0 < TableDialog.patch
cp build.conf qtiplot-${pkgver}/
}
diff --git a/SetColValuesDialog.patch b/SetColValuesDialog.patch
new file mode 100644
index 000000000000..3dc9c87e6aef
--- /dev/null
+++ b/SetColValuesDialog.patch
@@ -0,0 +1,17 @@
+--- qtiplot-0.9.8.9/qtiplot/src/table/SetColValuesDialog.cpp 2010-09-27 09:12:49.000000000 +0200
++++ qtiplot-0.9.8.9/qtiplot/src/table/SetColValuesDialog.cpp 2019-12-30 13:15:02.013520676 +0100
+@@ -72,12 +72,12 @@
+ hbox1->addWidget(end);
+
+ QGridLayout *gl1 = new QGridLayout();
+- functions = new QComboBox(false);
++ functions = new QComboBox();
+ functions->addItems(muParserScripting::functionsList(true));
+ gl1->addWidget(functions, 0, 0);
+ btnAddFunction = new QPushButton(tr( "Add function" ));
+ gl1->addWidget(btnAddFunction, 0, 1);
+- boxColumn = new QComboBox(false);
++ boxColumn = new QComboBox();
+ gl1->addWidget(boxColumn, 1, 0);
+ btnAddCol = new QPushButton(tr( "Add column" ));
+ gl1->addWidget(btnAddCol, 1, 1);
diff --git a/TableDialog.patch b/TableDialog.patch
new file mode 100644
index 000000000000..274b98300aaa
--- /dev/null
+++ b/TableDialog.patch
@@ -0,0 +1,11 @@
+--- qtiplot-0.9.8.9/qtiplot/src/table/TableDialog.cpp 2011-08-31 20:11:20.000000000 +0200
++++ qtiplot-0.9.8.9/qtiplot/src/table/TableDialog.cpp 2019-12-30 13:15:20.843116600 +0100
+@@ -127,7 +127,7 @@
+ labelFormat = new QLabel(tr( "Format:" ));
+ gl1->addWidget(labelFormat, 2, 0);
+
+- formatBox = new QComboBox(false);
++ formatBox = new QComboBox();
+ gl1->addWidget(formatBox, 2, 1);
+
+ labelNumeric = new QLabel(tr( "Precision:" ));