summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD4
2 files changed, 5 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bdf75b810fd9..96cbff9b66f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Tue May 3 08:41:31 UTC 2016
+# Tue Jul 19 10:48:41 UTC 2016
pkgbase = qtshutdownmenu-git
pkgdesc = Graphical shutdown util with PyQt5 and lock script for i3
pkgver = r4.314f35e
@@ -7,6 +7,7 @@ pkgbase = qtshutdownmenu-git
url = https://github.com/z3ntu/qtshutdownmenu
arch = any
license = MIT
+ makedepends = git
depends = python
depends = python-pyqt5
depends = ttf-liberation
diff --git a/PKGBUILD b/PKGBUILD
index 47315f572c99..c7d7d3b9e86d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,6 +7,7 @@ pkgdesc="Graphical shutdown util with PyQt5 and lock script for i3"
arch=('any')
url="https://github.com/z3ntu/qtshutdownmenu"
license=('MIT')
+makedepends=('git')
depends=('python' 'python-pyqt5' 'ttf-liberation' 'imagemagick' 'scrot' 'i3lock')
options=(!emptydirs)
source=(git+https://github.com/z3ntu/qtshutdownmenu)
@@ -21,10 +22,11 @@ package() {
cd "$srcdir/qtshutdownmenu"
mkdir -p "$pkgdir/usr/bin"
mkdir -p "$pkgdir/usr/share/icons"
- mkdir -p "$pkdir/usr/share/applications"
+ mkdir -p "$pkgdir/usr/share/applications"
install -Dm755 "shutdownmenu.py" "$pkgdir/usr/bin/qtshutdownmenu"
install -Dm755 "lock.sh" "$pkgdir/usr/bin/lock"
install -Dm755 "icon.png" "$pkgdir/usr/share/icons/lock.png"
install -Dm755 "qtshutdownmenu.desktop" "$pkgdir/usr/share/applications/qtshutdownmenu.desktop"
}
+# vim:set ts=2 sw=2 et: