summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD11
-rw-r--r--keys-guard.patch20
-rw-r--r--link-gl.patch18
-rw-r--r--quake2xp-svn.install3
5 files changed, 21 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 741149f0395c..79c8a981ed31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Tue Aug 1 20:48:47 UTC 2017
+# Thu May 10 20:13:30 UTC 2018
pkgbase = quake2xp-svn
pkgdesc = Quake 2 based engine with glsl per pixel lighting effects and more
- pkgver = r949
+ pkgver = r1043
pkgrel = 1
url = http://quake2xp.sourceforge.net/
install = quake2xp.install
@@ -29,16 +29,14 @@ pkgbase = quake2xp-svn
source = yandex://q2xpTex0.pkx
source = ftp://ftp.idsoftware.com/idstuff/quake2/q2-3.20-x86-full.exe
source = keys-guard.patch
- source = link-gl.patch
sha256sums = SKIP
- sha256sums = 4ddcf5d32ff858105e9b870a608c7095c7b8b877ff08073418473a80fe9301b1
+ sha256sums = a22b9324b1b8acada8f3abdd2a7787560a468b564d5cb1743e389da86b54363b
sha256sums = a96204dfab7e6632042267a8360b1f2cb33c7b4a804478a2b6527d2167d34a71
sha256sums = d2e0e15beaade312b929eb24b82b8561be9cb5ab66e921e0553ca78533f11a4a
sha256sums = 855ca6f37449deb82fc77d573c39d29e452c5a33dba23576402623653e58b893
sha256sums = 7f4116742cb3abcf05e374793e4b13a630f7b0eda818b8d509dc7e5691955d34
sha256sums = ee1b430258d5fc5a897ef47c6246f5da11de885f4c29fbeca005ff27924700be
- sha256sums = 22b97c937384b4ef33e87148d547affab3c472ebf83dcddb8933a9c7bef826d0
- sha256sums = 5cc8ac34c4b495c2a1ca39324c134898e83b374c649210b1332a829eaafdd75c
+ sha256sums = 4a5cd39f61d54cce9daa11272e2f79662c87b39d87fc4ac4a8b1ee3710d181fc
pkgname = quake2xp-svn
diff --git a/PKGBUILD b/PKGBUILD
index 4a8b856fc22c..0e9c4d24feed 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=quake2xp-svn
_svnname=quake2xp
-pkgver=r949
+pkgver=r1043
pkgrel=1
pkgdesc='Quake 2 based engine with glsl per pixel lighting effects and more'
arch=('i686' 'x86_64')
@@ -18,18 +18,16 @@ source=("$_svnname::svn://svn.code.sf.net/p/quake2xp/code/trunk"
'yandex://q2xpMusic.pkx'
'yandex://q2xpTex0.pkx'
'ftp://ftp.idsoftware.com/idstuff/quake2/q2-3.20-x86-full.exe'
- 'keys-guard.patch'
- 'link-gl.patch')
+ 'keys-guard.patch')
DLAGENTS+=("yandex::/usr/bin/echo %u - You need to download the files from https://yadi.sk/d/RP5yRSM-sx5ck/baseq2.")
sha256sums=('SKIP'
- '4ddcf5d32ff858105e9b870a608c7095c7b8b877ff08073418473a80fe9301b1'
+ 'a22b9324b1b8acada8f3abdd2a7787560a468b564d5cb1743e389da86b54363b'
'a96204dfab7e6632042267a8360b1f2cb33c7b4a804478a2b6527d2167d34a71'
'd2e0e15beaade312b929eb24b82b8561be9cb5ab66e921e0553ca78533f11a4a'
'855ca6f37449deb82fc77d573c39d29e452c5a33dba23576402623653e58b893'
'7f4116742cb3abcf05e374793e4b13a630f7b0eda818b8d509dc7e5691955d34'
'ee1b430258d5fc5a897ef47c6246f5da11de885f4c29fbeca005ff27924700be'
- '22b97c937384b4ef33e87148d547affab3c472ebf83dcddb8933a9c7bef826d0'
- '5cc8ac34c4b495c2a1ca39324c134898e83b374c649210b1332a829eaafdd75c')
+ '4a5cd39f61d54cce9daa11272e2f79662c87b39d87fc4ac4a8b1ee3710d181fc')
noextract=(q2xp0.pkx q2xpMaps.pkx q2xpMdl.pkx q2xpMusic.pkx q2xpTex0.pkx)
pkgver() {
@@ -43,7 +41,6 @@ prepare() {
unzip q2-3.20-x86-full.exe baseq2/\*
cd "$_svnname"
patch --binary -p1 -i ../keys-guard.patch || true
- patch --binary -p1 -i ../link-gl.patch || true
}
build() {
diff --git a/keys-guard.patch b/keys-guard.patch
index 22498b38cb1c..0e91961c67f9 100644
--- a/keys-guard.patch
+++ b/keys-guard.patch
@@ -1,16 +1,16 @@
---- a/client/keys.h
-+++ b/client/keys.h
-@@ -21,6 +21,9 @@
+--- a/client/keys.h
++++ b/client/keys.h
+@@ -18,6 +18,9 @@
+
+ */
+
++#ifndef _KEYS_H
++#define _KEYS_H
++
//
// these are the key numbers that should be passed to Key_Event
//
-+#ifndef _KEYS_H_
-+#define _KEYS_H_
-+
- typedef enum {
- K_TAB = 9,
- K_ENTER = 13,
-@@ -113,3 +116,5 @@
+@@ -121,3 +124,5 @@
void Key_SetBinding (int keynum, char *binding);
void Key_ClearStates (void);
int Key_GetKey (void);
diff --git a/link-gl.patch b/link-gl.patch
deleted file mode 100644
index a2c9d2f057a9..000000000000
--- a/link-gl.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- a/wscript
-+++ b/wscript
-@@ -48,7 +48,7 @@
-
- def configure(conf):
- conf.load('compiler_c')
-- for lib in ['sdl', 'ogg', 'vorbis', 'vorbisfile', 'IL', 'ILU', 'ILUT', 'openal', 'x11']:
-+ for lib in ['sdl', 'ogg', 'vorbis', 'vorbisfile', 'IL', 'ILU', 'ILUT', 'openal', 'x11', 'glu']:
- conf.check_cfg(package=lib, args=['--cflags', '--libs'])
-
- def build(bld):
-@@ -100,5 +100,5 @@
- source = sources['client'],
- target = 'quake2xp',
- lib = ['z', 'm', 'dl'],
-- use = ['IL', 'ILU', 'ILUT', 'OPENAL', 'X11', 'SDL', 'OGG', 'VORBIS', 'VORBISFILE']
-+ use = ['IL', 'ILU', 'ILUT', 'OPENAL', 'X11', 'SDL', 'OGG', 'VORBIS', 'VORBISFILE', 'GLU']
- )
diff --git a/quake2xp-svn.install b/quake2xp-svn.install
new file mode 100644
index 000000000000..970f53aaaf21
--- /dev/null
+++ b/quake2xp-svn.install
@@ -0,0 +1,3 @@
+post_upgrade() {
+ echo 'Ensure you download the GLSL shaders (e.g. `mkdir ~/.quake2xp/baseq2/ && cd ~/.quake2xp/baseq2/ && svn checkout svn://svn.code.sf.net/p/quake2xp/code/glsl glsl`)'.
+}