summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
-rw-r--r--quantum_moves.run3
3 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3fc497162478
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = quantum-moves
+ pkgdesc = Contribute to physics research by finding clever ways of manipulating and moving atoms
+ pkgver = 20160521
+ pkgrel = 1
+ url = https://www.scienceathome.org/games/quantum-moves/
+ arch = i686
+ arch = x86_64
+ license = custom:freeware
+ options = !strip
+ options = !buildflags
+ source = https://builds.scienceathome.org/quantum-moves/QuantumMoves.7z
+ source = quantum_moves.run
+ sha256sums = 6d974c220d870a895df55f0303561481b2f463179f93c43e56ba57d5a4697f46
+ sha256sums = c0ee4ae884c6036cd74161e8c6c33633868d7f3d509fe22390fd9e84ba84c745
+
+pkgname = quantum-moves
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b360b6117468
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: CValente <cvalente (a) email com>
+
+pkgname=quantum-moves
+pkgver=20160521 #not versioned upstream (WTF)
+pkgrel=1
+pkgdesc="Contribute to physics research by finding clever ways of manipulating and moving atoms"
+arch=(i686 x86_64)
+url="https://www.scienceathome.org/games/quantum-moves/"
+license=('custom:freeware')
+depends=()
+makedepends=()
+options=('!strip' '!buildflags')
+source=(
+ 'https://builds.scienceathome.org/quantum-moves/QuantumMoves.7z'
+ 'quantum_moves.run')
+sha256sums=(
+ '6d974c220d870a895df55f0303561481b2f463179f93c43e56ba57d5a4697f46'
+ 'c0ee4ae884c6036cd74161e8c6c33633868d7f3d509fe22390fd9e84ba84c745'
+)
+
+package() {
+ install -dm755 "$pkgdir/opt/"
+ cp -r "$srcdir" "$pkgdir/opt/quantum_moves"
+ chmod +x "$pkgdir/opt/quantum_moves/Quantum Moves.x86"
+ install -Dm555 "$srcdir/quantum_moves.run" "$pkgdir/usr/bin/quantum_moves"
+
+}
+
diff --git a/quantum_moves.run b/quantum_moves.run
new file mode 100644
index 000000000000..1a3a6f054cfa
--- /dev/null
+++ b/quantum_moves.run
@@ -0,0 +1,3 @@
+#!/bin/sh
+
+'/opt/quantum_moves/Quantum Moves.x86'