summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD33
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..638a450d1ad8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = questofdungeons-hib
+ pkgdesc = A turn based dungeon crawler game, a roguelike.
+ pkgver = 1.1.0
+ pkgrel = 2
+ url = http://www.questofdungeons.com/
+ arch = i686
+ arch = x86_64
+ license = custom: commercial
+ depends = freetype2
+ depends = libvorbis
+ depends = libgl
+ depends = openal
+ depends = sdl2
+ conflicts = questofdungeons
+ source = hib://QuestofDungeons_linux_1.1.0.zip
+ md5sums = e36fe29b119b3bb60ed9091408de4c3e
+
+pkgname = questofdungeons-hib
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..386e599b81f6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: gulaghad <can6dev <AT> gmail <DOT> com>
+pkgname=questofdungeons-hib
+pkgver=1.1.0
+pkgrel=2
+pkgdesc="A turn based dungeon crawler game, a roguelike."
+arch=('i686' 'x86_64')
+url="http://www.questofdungeons.com/"
+license=('custom: commercial')
+depends=('freetype2' 'libvorbis' 'libgl' 'openal' 'sdl2')
+conflicts=('questofdungeons')
+source=('hib://QuestofDungeons_linux_'${pkgver}'.zip')
+md5sums=('e36fe29b119b3bb60ed9091408de4c3e')
+
+package() {
+ cd "$srcdir/QuestofDungeons"
+
+ install -d "$pkgdir/opt/QuestofDungeons"
+ mv "GameResources" "$pkgdir/opt/QuestofDungeons"
+ install -m755 "QuestofDungeons" "$pkgdir/opt/QuestofDungeons"
+
+ if [ $CARCH == i686 ]; then
+ install -d "$pkgdir/opt/QuestofDungeons/x86/libs"
+ mv "x86/libs/libGLEW.so.1.10" "$pkgdir/opt/QuestofDungeons/x86/libs"
+ mv "x86/QuestofDungeons" "$pkgdir/opt/QuestofDungeons/x86"
+ elif [ $CARCH == x86_64 ]; then
+ install -d "$pkgdir/opt/QuestofDungeons/amd64/libs"
+ mv "amd64/libs/libGLEW.so.1.10" "$pkgdir/opt/QuestofDungeons/amd64/libs"
+ mv "amd64/QuestofDungeons" "$pkgdir/opt/QuestofDungeons/amd64"
+ fi
+
+ install -d "$pkgdir/usr/bin"
+ ln -s "/opt/QuestofDungeons/QuestofDungeons" "$pkgdir/usr/bin/questofdungeons"
+}