summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD12
2 files changed, 14 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c2e4987abef9..a70e4b0a193c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = quickemu
pkgdesc = Quickly create and run optimised Windows, macOS and Linux desktop virtual machines.
- pkgver = 3.15
+ pkgver = 4.9.2
pkgrel = 1
url = https://github.com/quickemu-project/quickemu
arch = any
@@ -21,10 +21,13 @@ pkgbase = quickemu
depends = xorg-xrandr
depends = zsync
depends = edk2-ovmf
+ depends = xdg-user-dirs
+ depends = socat
optdepends = quickgui: graphical user interface
+ optdepends = aria2: faster downloads
provides = quickemu
conflicts = quickemu
- source = quickemu-3.15.tar.gz::https://github.com/quickemu-project/quickemu/archive/refs/tags/3.15.tar.gz
- sha256sums = bba9f0432a5fdb65e52356438ccf62367da5704821a95545eeb472d8a3cb9412
+ source = quickemu-4.9.2.tar.gz::https://github.com/quickemu-project/quickemu/archive/refs/tags/4.9.2.tar.gz
+ sha256sums = fa5e2e5112deb836c0ab6035ab0aaabd1465b13e945d4a49dc975b94f1b01233
pkgname = quickemu
diff --git a/PKGBUILD b/PKGBUILD
index 344f4f7ab3c8..914f6eb318c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Steffen Hansen <steffengrundsoe@gmail.com>
pkgname=quickemu
-pkgver=3.15
+pkgver=4.9.2
pkgrel=1
pkgdesc="Quickly create and run optimised Windows, macOS and Linux desktop virtual machines."
arch=(any)
url="https://github.com/quickemu-project/quickemu"
license=('MIT')
-depends=('qemu' 'coreutils' 'grep' 'jq' 'procps' 'python3' 'cdrtools' 'usbutils' 'util-linux' 'sed' 'spice-gtk' 'swtpm' 'wget' 'xorg-xrandr' 'zsync' 'edk2-ovmf')
-optdepends=('quickgui: graphical user interface')
+depends=('qemu' 'coreutils' 'grep' 'jq' 'procps' 'python3' 'cdrtools' 'usbutils' 'util-linux' 'sed' 'spice-gtk' 'swtpm' 'wget' 'xorg-xrandr' 'zsync' 'edk2-ovmf' 'xdg-user-dirs' 'socat')
+optdepends=('quickgui: graphical user interface' 'aria2: faster downloads')
provides=("$pkgname")
conflicts=("$pkgname")
source=("$pkgname-$pkgver.tar.gz"::"https://github.com/quickemu-project/quickemu/archive/refs/tags/$pkgver.tar.gz")
-sha256sums=('bba9f0432a5fdb65e52356438ccf62367da5704821a95545eeb472d8a3cb9412')
+sha256sums=('fa5e2e5112deb836c0ab6035ab0aaabd1465b13e945d4a49dc975b94f1b01233')
package() {
cd "$pkgname-$pkgver"
@@ -20,4 +20,8 @@ package() {
install -Dm755 quickemu "$pkgdir/usr/bin/quickemu"
install -Dm755 macrecovery "$pkgdir/usr/bin/macrecovery"
install -Dm755 quickget "$pkgdir/usr/bin/quickget"
+
+ install -Dm644 docs/quickget.1 $pkgdir/usr/share/man/man1/quickget.1
+ install -Dm644 docs/quickemu.1 $pkgdir/usr/share/man/man1/quickemu.1
+ install -Dm644 docs/quickemu_conf.1 $pkgdir/usr/share/man/man1/quickemu_conf.1
}