summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD22
3 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7c429c0c08dc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = quickemu
+ pkgdesc = Quickly create and run optimised Windows, macOS and Linux desktop virtual machines.
+ pkgver = 2.2.3
+ pkgrel = 1
+ url = https://github.com/wimpysworld/quickemu
+ arch = any
+ license = MIT
+ depends = qemu
+ provides = quickemu
+ conflicts = quickemu
+ source = quickemu-2.2.3.tar.gz::https://github.com/wimpysworld/quickemu/archive/refs/tags/2.2.3.tar.gz
+ md5sums = 38cbaa95a18a6c98b9444a49263c64d4
+
+pkgname = quickemu
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..eb3c079ed051
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Steffen Hansen <steffengrundsoe@gmail.com>
+pkgname=quickemu
+pkgver=2.2.3
+pkgrel=1
+pkgdesc="Quickly create and run optimised Windows, macOS and Linux desktop virtual machines."
+arch=(any)
+url="https://github.com/wimpysworld/quickemu"
+license=('MIT')
+depends=('qemu')
+provides=("$pkgname")
+conflicts=("$pkgname")
+source=("$pkgname-$pkgver.tar.gz"::'https://github.com/wimpysworld/quickemu/archive/refs/tags/2.2.3.tar.gz')
+md5sums=("38cbaa95a18a6c98b9444a49263c64d4")
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm755 quickemu "$pkgdir/usr/bin/quickemu"
+ install -Dm755 macrecovery "$pkgdir/usr/bin/macrecovery"
+ install -Dm755 quickget "$pkgdir/usr/bin/quickget"
+}