summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO17
-rw-r--r--.hgignore4
-rw-r--r--PKGBUILD24
-rw-r--r--quicklook.cron1
4 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f73c8b154962
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = quicklook
+ pkgdesc = Collects system statistics and outputs pretty graphics and (X)HTML pages.
+ pkgver = 1.2
+ pkgrel = 2
+ url = http://code.google.com/p/quicklook/
+ arch = any
+ license = GPL
+ depends = python2>=2.3
+ depends = python2-cheetah
+ depends = rrdtool
+ source = quicklook-1.2.tar.gz::https://bitbucket.org/jmb/quicklook/get/v1.2.tar.gz
+ source = quicklook.cron
+ md5sums = bed76c1d9eeb30008eb2c0c6b39694d0
+ md5sums = 92e2f9514865de7ad8fadb7ab9da5164
+
+pkgname = quicklook
+
diff --git a/.hgignore b/.hgignore
new file mode 100644
index 000000000000..fc3b00732b1b
--- /dev/null
+++ b/.hgignore
@@ -0,0 +1,4 @@
+^[^/]*\.pkg\.tar\.xz$
+
+^pkg/
+^src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e1dcd0e6278e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# $Id: PKGBUILD 63943 2010-01-19 05:06:17Z eric $
+# Contributor: J. Berger <jeberger@free.fr>
+
+pkgname=quicklook
+pkgver=1.2
+_commit=0176bff4d357
+pkgrel=2
+pkgdesc="Collects system statistics and outputs pretty graphics and (X)HTML pages."
+arch=('any')
+url="http://code.google.com/p/quicklook/"
+license=('GPL')
+depends=('python2>=2.3' 'python2-cheetah' 'rrdtool')
+source=(${pkgname}-${pkgver}.tar.gz::https://bitbucket.org/jmb/quicklook/get/v${pkgver}.tar.gz
+ quicklook.cron)
+md5sums=('bed76c1d9eeb30008eb2c0c6b39694d0'
+ '92e2f9514865de7ad8fadb7ab9da5164')
+
+package() {
+ cd "${srcdir}/jmb-${pkgname}-${_commit}"
+
+ make DESTDIR="${pkgdir}/opt/quicklook" install || return 1
+ install -d "${pkgdir}/etc/cron.d" || return 1
+ install -o root -m 644 "${srcdir}/quicklook.cron" "${pkgdir}/etc/cron.d/quicklook"
+}
diff --git a/quicklook.cron b/quicklook.cron
new file mode 100644
index 000000000000..46b3ce627afe
--- /dev/null
+++ b/quicklook.cron
@@ -0,0 +1 @@
+*/5 * * * * root nice /opt/quicklook/stats.py --data=/var/opt/quicklook/ --output=/srv/http/quicklook/ > /dev/null