summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD29
2 files changed, 15 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 98f7ccfb8824..625c88ebfa62 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = quint
pkgdesc = Quint is an executable specification language with design and tooling focused on usability. It is based on the Temporal Logic of Actions
- pkgver = 0.9.1
+ pkgver = 0.10.0
pkgrel = 1
url = https://github.com/informalsystems/quint
arch = any
@@ -9,7 +9,9 @@ pkgbase = quint
depends = nodejs
provides = quint
conflicts = quint
- source = https://github.com/informalsystems/quint/archive/refs/tags/v0.9.1.tar.gz
- sha256sums = 1cf226160452dcacbc2dd8e0cff92ce8eb13a7d4f1eabfc33332a4c508bf6951
+ source = https://registry.npmjs.org/@informalsystems/quint/-/quint-0.10.0.tgz
+ source = https://github.com/informalsystems/quint/raw/v0.10.0/LICENSE
+ sha256sums = b9aed81a2c5d81c5a92fc05e1536dfd917fd162f82630a9c70c989c0f6c545e1
+ sha256sums = f6fe921a1fc4130262213e9a211327796782d6bbd234d14eba80b1285005b6e9
pkgname = quint
diff --git a/PKGBUILD b/PKGBUILD
index fc2d1b2b45e9..48f36bcc0cbb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,24 @@
# Maintainer: Ranadeep B < mail at rnbguy dot at >
pkgname=quint
-orgname=informalsystems
-pkgver=0.9.1
+_orgname=informalsystems
+_pkgname="@${_orgname}/${pkgname}"
+pkgver=0.10.0
pkgrel=1
pkgdesc="Quint is an executable specification language with design and tooling focused on usability. It is based on the Temporal Logic of Actions"
arch=('any')
-url="https://github.com/${orgname}/${pkgname}"
+url="https://github.com/${_orgname}/${pkgname}"
license=('Apache')
provides=(${pkgname})
conflicts=(${pkgname})
depends=('nodejs')
makedepends=('npm')
-source=("https://github.com/${orgname}/${pkgname}/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('1cf226160452dcacbc2dd8e0cff92ce8eb13a7d4f1eabfc33332a4c508bf6951')
-
-prepare() {
- cd "${srcdir}/${pkgname}-${pkgver}/${pkgname}"
- npm install
-}
-
-build() {
- cd "${srcdir}/${pkgname}-${pkgver}/${pkgname}"
- npm run compile
-}
+source=("https://registry.npmjs.org/${_pkgname}/-/${pkgname}-${pkgver}.tgz"
+ "https://github.com/${_orgname}/${pkgname}/raw/v${pkgver}/LICENSE")
+sha256sums=('b9aed81a2c5d81c5a92fc05e1536dfd917fd162f82630a9c70c989c0f6c545e1'
+ 'f6fe921a1fc4130262213e9a211327796782d6bbd234d14eba80b1285005b6e9')
package() {
- cd "${srcdir}/${pkgname}-${pkgver}/${pkgname}"
- npm pack
- npm install -g --prefix "${pkgdir}/usr" --no-save "${orgname}-${pkgname}-${pkgver}.tgz"
- install -Dm644 "${srcdir}/${pkgname}-${pkgver}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ npm install -g --cache "${srcdir}/npm-cache" --prefix "${pkgdir}/usr" "${pkgname}-${pkgver}.tgz"
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}