summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
2 files changed, 3 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1fbd6d5f28c4..7a582c410f56 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = qv2ray
pkgdesc = Cross-platform V2ray Client written in Qt (Stable Release)
- pkgver = 2.5.0
+ pkgver = 2.6.0
pkgrel = 1
url = https://github.com/Qv2ray/Qv2ray
arch = x86_64
@@ -22,12 +22,6 @@ pkgbase = qv2ray
provides = qv2ray
conflicts = qv2ray
source = Qv2ray::git+https://github.com/Qv2ray/Qv2ray
- source = QNodeEditor::git+https://github.com/Qv2ray/QNodeEditor
- source = SingleApplication::git+https://github.com/itay-grudev/SingleApplication
- source = x2struct::git+https://github.com/xyz347/x2struct
- sha512sums = SKIP
- sha512sums = SKIP
- sha512sums = SKIP
sha512sums = SKIP
pkgname = qv2ray
diff --git a/PKGBUILD b/PKGBUILD
index 41820ff47438..868e3eba4fea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: ArielAxionL <i at axionl dot me>
# Contributor: Leroy.H.Y <me at lhy0403 dot top>
pkgname=qv2ray
-pkgver=2.5.0
+pkgver=2.6.0
pkgrel=1
pkgdesc="Cross-platform V2ray Client written in Qt (Stable Release)"
arch=('x86_64')
@@ -17,15 +17,9 @@ conflicts=('qv2ray')
source=(
'Qv2ray::git+https://github.com/Qv2ray/Qv2ray'
- 'QNodeEditor::git+https://github.com/Qv2ray/QNodeEditor'
- 'SingleApplication::git+https://github.com/itay-grudev/SingleApplication'
- 'x2struct::git+https://github.com/xyz347/x2struct'
)
-sha512sums=('SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP')
+sha512sums=('SKIP')
pkgver() {
printf "%s" $(cat ${srcdir}/Qv2ray/makespec/VERSION)
@@ -34,12 +28,6 @@ pkgver() {
prepare() {
cd "${srcdir}/Qv2ray"
git submodule init
- submodules=('QNodeEditor' 'SingleApplication' 'x2struct' 'cpp-httplib')
- for module in ${submodules[@]}; do
- git config submodule."3rdparty/$module".url "${srcdir}/$module"
- done
-
- git config submodule."libs/libqvb".active false
git config submodule."3rdparty/zxing-cpp".active false
git submodule update
}