summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD43
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..479436cd9bba
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = qview-git
+ pkgdesc = qView is a Qt image viewer designed with minimalism and usability in mind.
+ pkgver = r434.4d15b97
+ pkgrel = 1
+ url = https://interversehq.com/qview/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = qt5-base
+ depends = qt5-base>=5.9
+ depends = hicolor-icon-theme
+ optdepends = xdg-utils: Used to open containing folder of file
+ optdepends = qt5-imageformats: Extra image format support
+ optdepends = qt5-svg: SVG support
+ provides = qview
+ conflicts = qview
+ source = git+https://github.com/jurplel/qView
+ sha256sums = SKIP
+
+pkgname = qview-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..131b0b7985e8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Andy Kluger <https://t.me/andykluger>
+# Contributor: jurplel <jeep70cp[at]gmail[dotcom]>
+_pkgname=qview
+pkgname=qview-git
+pkgver=r434.4d15b97
+pkgrel=1
+epoch=
+pkgdesc="qView is a Qt image viewer designed with minimalism and usability in mind."
+arch=('i686' 'x86_64')
+url="https://interversehq.com/qview/"
+license=('GPL3')
+groups=()
+depends=('qt5-base>=5.9' 'hicolor-icon-theme')
+optdepends=('xdg-utils: Used to open containing folder of file' 'qt5-imageformats: Extra image format support' 'qt5-svg: SVG support')
+makedepends=('git' 'qt5-base')
+checkdepends=()
+provides=('qview')
+conflicts=('qview')
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("git+https://github.com/jurplel/qView")
+noextract=()
+sha256sums=('SKIP')
+validpgpkeys=()
+
+pkgver() {
+ cd qView
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd qView
+ qmake
+ make
+}
+
+package() {
+ cd qView
+ make INSTALL_ROOT="$pkgdir/" install
+}