summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
-rw-r--r--qwtconfig-archlinux.pri118
3 files changed, 171 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d3da62d64f04
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Sat Apr 8 07:47:57 UTC 2017
+pkgbase = qwt-qt4
+ pkgdesc = Qt Widgets for Technical Applications (libqwt-qt4.so only)
+ pkgver = 6.1.3
+ pkgrel = 1
+ url = http://qwt.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = custom:qwt-qt4
+ depends = qt4
+ source = http://downloads.sourceforge.net/qwt-qt4/qwt-qt4-6.1.3.tar.bz2
+ source = qwtconfig-archlinux.pri
+ sha1sums = 90ec21bc42f7fae270482e1a0df3bc79cb10e5c7
+ sha1sums = 955f3702c5e8a847c545adf46745aade53626555
+
+pkgname = qwt-qt4
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..717b2fa8dd4f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+pkgname=qwt-qt4
+pkgver=6.1.3
+pkgrel=1
+pkgdesc="Qt Widgets for Technical Applications (libqwt-qt4.so only)"
+arch=('i686' 'x86_64')
+url="http://qwt.sourceforge.net/"
+depends=('qt4')
+license=("custom:$pkgname")
+source=("http://downloads.sourceforge.net/${pkgname}/$pkgname-$pkgver.tar.bz2" \
+ "qwtconfig-archlinux.pri")
+sha1sums=('90ec21bc42f7fae270482e1a0df3bc79cb10e5c7'
+ '955f3702c5e8a847c545adf46745aade53626555')
+
+prepare() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ # copy our config file to the right place
+ cp ${srcdir}/qwtconfig-archlinux.pri qwtconfig.pri
+}
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ # build qwt:
+ qmake-qt4 qwt.pro
+ make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ install -d "${pkgdir}"/usr/lib/
+ install -m 755 lib/libqwt.so.${pkgver} "${pkgdir}"/usr/lib/libqwt-qt4.so.${pkgver}
+ ln -f -s libqwt-qt4.so.${pkgver} "${pkgdir}"/usr/lib/libqwt-qt4.so
+ ln -f -s libqwt-qt4.so.${pkgver} "${pkgdir}"/usr/lib/libqwt-qt4.so.6
+}
diff --git a/qwtconfig-archlinux.pri b/qwtconfig-archlinux.pri
new file mode 100644
index 000000000000..5180901c2f80
--- /dev/null
+++ b/qwtconfig-archlinux.pri
@@ -0,0 +1,118 @@
+################################################################
+# Qwt Widget Library
+# Copyright (C) 1997 Josef Wilgen
+# Copyright (C) 2002 Uwe Rathmann
+#
+# This library is free software; you can redistribute it and/or
+# modify it under the terms of the Qwt License, Version 1.0
+################################################################
+
+QWT_VER_MAJ = 6
+QWT_VER_MIN = 1
+QWT_VER_PAT = 3
+QWT_VERSION = $${QWT_VER_MAJ}.$${QWT_VER_MIN}.$${QWT_VER_PAT}
+
+######################################################################
+# Install paths
+######################################################################
+
+QWT_INSTALL_PREFIX = $$[QT_INSTALL_PREFIX]
+
+unix {
+ QWT_INSTALL_PREFIX = /usr
+}
+
+win32 {
+ QWT_INSTALL_PREFIX = C:/Qwt
+}
+
+QWT_INSTALL_DOCS = $${QWT_INSTALL_PREFIX}/share/doc/qwt
+QWT_INSTALL_HEADERS = $${QWT_INSTALL_PREFIX}/include/qwt
+QWT_INSTALL_LIBS = $${QWT_INSTALL_PREFIX}/lib
+
+######################################################################
+# Designer plugin
+######################################################################
+
+#QWT_INSTALL_PLUGINS = $${QWT_INSTALL_PREFIX}/plugins/designer
+# QWT_INSTALL_PLUGINS = $${QT_INSTALL_PREFIX}/plugins/designer
+
+######################################################################
+# Features
+# When building a Qwt application with qmake you might want to load
+# the compiler/linker flags, that are required to build a Qwt application
+# from qwt.prf. Therefore all you need to do is to add "CONFIG += qwt"
+# to your project file and take care, that qwt.prf can be found by qmake.
+# ( see http://doc.trolltech.com/4.7/qmake-advanced-usage.html#adding-new-configuration-features )
+# I recommend not to install the Qwt features together with the
+# Qt features, because you will have to reinstall the Qwt features,
+# with every Qt upgrade.
+######################################################################
+
+#QWT_INSTALL_FEATURES = $${QWT_INSTALL_PREFIX}/features
+# QWT_INSTALL_FEATURES = $${QT_INSTALL_PREFIX}/features
+
+######################################################################
+# Build the static/shared libraries.
+# If QwtDll is enabled, a shared library is built, otherwise
+# it will be a static library.
+######################################################################
+
+QWT_CONFIG += QwtDll
+
+######################################################################
+# QwtPlot enables all classes, that are needed to use the QwtPlot
+# widget.
+######################################################################
+
+QWT_CONFIG += QwtPlot
+
+######################################################################
+# QwtWidgets enables all classes, that are needed to use the all other
+# widgets (sliders, dials, ...), beside QwtPlot.
+######################################################################
+
+QWT_CONFIG += QwtWidgets
+
+######################################################################
+# If you want to display svg images on the plot canvas, or
+# export a plot to a SVG document
+######################################################################
+
+QWT_CONFIG += QwtSvg
+
+######################################################################
+# You can use the MathML renderer of the Qt solutions package to
+# enable MathML support in Qwt. Because of license implications
+# the ( modified ) code of the MML Widget solution is included and
+# linked together with the QwtMathMLTextEngine into an own library.
+# To use it you will have to add "CONFIG += qwtmathml"
+# to your qmake project file.
+######################################################################
+
+#QWT_CONFIG += QwtMathML
+
+######################################################################
+# If you want to build the Qwt designer plugin,
+# enable the line below.
+# Otherwise you have to build it from the designer directory.
+######################################################################
+
+QWT_CONFIG += QwtDesigner
+
+######################################################################
+# If you want to auto build the examples, enable the line below
+# Otherwise you have to build them from the examples directory.
+######################################################################
+
+#QWT_CONFIG += QwtExamples
+
+######################################################################
+# When Qt has been built as framework qmake ( qtAddLibrary ) wants
+# to link frameworks instead of regular libs
+######################################################################
+
+macx:CONFIG(qt_framework, qt_framework|qt_no_framework) {
+
+ QWT_CONFIG += QwtFramework
+}