summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD50
2 files changed, 28 insertions, 36 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 448bf0d5e0a9..bf79eb46546b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,30 +12,34 @@ pkgbase = gzdoom-git
license = LGPL
makedepends = cmake
makedepends = desktop-file-utils
+ makedepends = fluidsynth
makedepends = git
makedepends = imagemagick
+ makedepends = openal
makedepends = xdg-utils
- depends = fluidsynth
- depends = fmodex=4.44.62
depends = gtk2
depends = libgl
depends = libgme
depends = libsndfile
depends = mpg123
- depends = openal
depends = sdl2
optdepends = blasphemer-wad: Blasphemer (free Heretic) game data
optdepends = chexquest3-wad: Chex Quest 3 game data
optdepends = doom1-wad: Doom shareware game data
- optdepends = freedoom: FreeDoom game data
+ optdepends = fluidsynth: FluidSynth MIDI device
+ optdepends = freedm: FreeDM game data
+ optdepends = freedoom1: Freedoom: Phase 1 game data
+ optdepends = freedoom2: Freedoom: Phase 2 game data
optdepends = gxmessage: crash dialog (GNOME)
optdepends = hacx-wad: HacX game data
optdepends = harmony-wad: Harmony game data
optdepends = heretic1-wad: Heretic shareware game data
optdepends = hexen1-wad: Hexen demo game data
- optdepends = kdebase-kdialog: crash dialog (KDE)
+ optdepends = kdialog: crash dialog (KDE)
+ optdepends = openal: OpenAL sound backend
optdepends = strife0-wad: Strife shareware game data
optdepends = square1-wad: The Adventures of Square, Episode 1 game data
+ optdepends = timidity++: Timidity MIDI device
optdepends = urbanbrawl-wad: Urban Brawl: Action Doom 2 game data
optdepends = xorg-xmessage: crash dialog (other)
provides = gzdoom
diff --git a/PKGBUILD b/PKGBUILD
index efa0ce14dc63..1ffa3eccd816 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,9 @@
# Maintainer: Jan Cholasta <grubber at grubber cz>
-# Build with fmodex:
-_fmodex=fmodex
# Build without fmodex:
-#_fmodex=
-
-# Build with OpenAL:
-_openal=openal
-# Build without OpenAL:
-#_openal=
+_fmodex=
+# Build with fmodex:
+#_fmodex=fmodex
_name=gzdoom
pkgname=${_name}-git
@@ -18,52 +13,56 @@ pkgdesc='Advanced Doom source port with OpenGL support (git version)'
arch=('i686' 'x86_64')
url='http://www.zdoom.org/'
license=('BSD' 'custom:BUILD' 'custom:doom' 'custom:dumb' 'LGPL')
-depends=('fluidsynth'
- ${_fmodex:+$(LC_ALL=C pacman -Q $_fmodex | sed -r 's/ /=/;s/-.*$//')}
+depends=(${_fmodex:+$(LC_ALL=C pacman -Q $_fmodex | sed -r 's/ /=/;s/-.*$//')}
'gtk2'
'libgl'
'libgme'
- ${_openal:+'libsndfile'}
- ${_openal:+'mpg123'}
- ${_openal}
+ 'libsndfile'
+ 'mpg123'
'sdl2')
makedepends=('cmake'
'desktop-file-utils'
+ 'fluidsynth'
'git'
'imagemagick'
+ 'openal'
'xdg-utils')
optdepends=('blasphemer-wad: Blasphemer (free Heretic) game data'
'chexquest3-wad: Chex Quest 3 game data'
'doom1-wad: Doom shareware game data'
- 'freedoom: FreeDoom game data'
+ 'fluidsynth: FluidSynth MIDI device'
+ 'freedm: FreeDM game data'
+ 'freedoom1: Freedoom: Phase 1 game data'
+ 'freedoom2: Freedoom: Phase 2 game data'
'gxmessage: crash dialog (GNOME)'
'hacx-wad: HacX game data'
'harmony-wad: Harmony game data'
'heretic1-wad: Heretic shareware game data'
'hexen1-wad: Hexen demo game data'
- 'kdebase-kdialog: crash dialog (KDE)'
+ 'kdialog: crash dialog (KDE)'
+ 'openal: OpenAL sound backend'
'strife0-wad: Strife shareware game data'
'square1-wad: The Adventures of Square, Episode 1 game data'
+ 'timidity++: Timidity MIDI device'
'urbanbrawl-wad: Urban Brawl: Action Doom 2 game data'
'xorg-xmessage: crash dialog (other)')
provides=("${_name}")
conflicts=("${_name}")
source=("${_name}::git://github.com/coelckers/${_name}.git"
'launcher.desktop')
-_srcsubdir="${_name}"
sha256sums=('SKIP'
'59122e670f72aa2531aff370e7aaab2d886a7642e79e91f27a533d3b4cad4f6d')
pkgver() {
- cd "${_srcsubdir}"
+ cd $_name
git describe --long --tags --match '[Gg]*' | sed -r 's/^[Gg]//;s/([^-]*-g)/\1/;s/-/./g'
}
build() {
- cd "${_srcsubdir}"
+ cd $_name
- local _nofmod _noopenal _fmodincdir _fmodlib
+ local _nofmod _fmodincdir _fmodlib
if [[ -n "${_fmodex}" ]]; then
_nofmod=OFF
@@ -73,14 +72,7 @@ build() {
_nofmod=ON
fi
- if [[ -n "${_openal}" ]]; then
- _noopenal=OFF
- else
- _noopenal=ON
- fi
-
cmake -DNO_FMOD=${_nofmod} \
- -DNO_OPENAL=${_noopenal} \
-DGME_INCLUDE_DIR='/usr/include/gme' \
-DFMOD_INCLUDE_DIR="${_fmodincdir}" \
-DFMOD_LIBRARY="${_fmodlib}" \
@@ -107,7 +99,7 @@ EOF
}
package() {
- cd "${_srcsubdir}"
+ cd $_name
install -D "${_name}.sh" "${pkgdir}/usr/bin/${_name}"
@@ -117,10 +109,6 @@ package() {
if [[ -n "${_fmodex}" ]]; then
install 'liboutput_sdl.so' "${pkgdir}/usr/lib/${_name}/"
fi
- ln -s '/usr/share/doom/doom.wad' "${pkgdir}/usr/lib/${_name}/freedoomu.wad"
- ln -s '/usr/share/doom/doom2.wad' "${pkgdir}/usr/lib/${_name}/freedoom.wad"
- ln -s '/usr/share/doom/heretic.wad' "${pkgdir}/usr/lib/${_name}/blasphemer.wad"
- ln -s '/usr/share/doom/hexen.wad' "${pkgdir}/usr/lib/${_name}/hexendemo.wad"
mkdir -p "${pkgdir}/usr/share/${_name}"
install -m644 'brightmaps.pk3' "${pkgdir}/usr/share/${_name}/"