summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD33
2 files changed, 23 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2a4ebed353a2..c3a93a7a03d1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = r-abind
pkgdesc = Combine Multidimensional Arrays
pkgver = 1.4.5
- pkgrel = 1
+ pkgrel = 10
url = https://cran.r-project.org/package=abind
arch = any
- license = LGPL2
- license = LGPL2.1
- license = LGPL3
- depends = r>=1.5.0
+ license = LGPL
+ depends = r
source = https://cran.r-project.org/src/contrib/abind_1.4-5.tar.gz
+ md5sums = 136f981e1c4f618b64a87faaa7797c97
sha256sums = 3a3ace5afbcb86e56889efcebf3bf5c3bb042a282ba7cc4412d450bb246a3f2c
pkgname = r-abind
diff --git a/PKGBUILD b/PKGBUILD
index 065572c38ce1..fdfaf071afd2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,31 @@
-# Maintainer: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
+# Maintainer: Pekka Ristola <pekkarr [at] protonmail [dot] com>
+# Contributor: Guoyi Zhang <guoyizhang at malacology dot net>
+# Contributor: Viktor Drobot (aka dviktor) linux776 [at] gmail [dot] com
# Contributor: Taekyung Kim <Taekyung.Kim.Maths@gmail.com>
# Contributor: Alex Branham <branham@utexas.edu>
-_cranname=abind
-_cranver=1.4-5
-pkgname=r-${_cranname,,}
-pkgver=${_cranver//[:-]/.}
-pkgrel=1
+_pkgname=abind
+_pkgver=1.4-5
+pkgname=r-${_pkgname,,}
+pkgver=${_pkgver//[:-]/.}
+pkgrel=10
pkgdesc="Combine Multidimensional Arrays"
arch=(any)
-url="https://cran.r-project.org/package=${_cranname}"
-license=(LGPL2 LGPL2.1 LGPL3)
-depends=('r>=1.5.0')
-source=("https://cran.r-project.org/src/contrib/${_cranname}_${_cranver}.tar.gz")
+url="https://cran.r-project.org/package=${_pkgname}"
+license=(LGPL)
+depends=(
+ r
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+md5sums=('136f981e1c4f618b64a87faaa7797c97')
sha256sums=('3a3ace5afbcb86e56889efcebf3bf5c3bb042a282ba7cc4412d450bb246a3f2c')
build() {
- R CMD INSTALL ${_cranname}_${_cranver}.tar.gz -l "${srcdir}"
+ mkdir -p build
+ R CMD INSTALL "$_pkgname" -l build
}
package() {
- install -dm0755 "${pkgdir}/usr/lib/R/library"
-
- cp -a --no-preserve=ownership "${_cranname}" "${pkgdir}/usr/lib/R/library"
+ install -d "$pkgdir/usr/lib/R/library"
+ cp -a --no-preserve=ownership "build/$_pkgname" "$pkgdir/usr/lib/R/library"
}