summarylogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD39
2 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7e28f4692e80
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = r-ashr
+ pkgdesc = Methods for Adaptive Shrinkage, using Empirical Bayes
+ pkgver = 2.2.54
+ pkgrel = 3
+ url = https://cran.r-project.org/package=ashr
+ arch = x86_64
+ license = GPL
+ depends = r
+ depends = r-etrunct
+ depends = r-invgamma
+ depends = r-mixsqp
+ depends = r-rcpp
+ depends = r-squarem
+ depends = r-truncnorm
+ optdepends = r-ggplot2
+ optdepends = r-knitr
+ optdepends = r-rebayes
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://cran.r-project.org/src/contrib/ashr_2.2-54.tar.gz
+ sha256sums = ea39ad1d4fcb2f7a331c6629f8d69d1038abd1271be3338ef1de307bd5d0fd9c
+
+pkgname = r-ashr
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7e5b83eb119e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=ashr
+_pkgver=2.2-54
+pkgname=r-${_pkgname,,}
+pkgver=2.2.54
+pkgrel=3
+pkgdesc='Methods for Adaptive Shrinkage, using Empirical Bayes'
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-etrunct
+ r-invgamma
+ r-mixsqp
+ r-rcpp
+ r-squarem
+ r-truncnorm
+)
+optdepends=(
+ r-ggplot2
+ r-knitr
+ r-rebayes
+ r-rmarkdown
+ r-testthat
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('ea39ad1d4fcb2f7a331c6629f8d69d1038abd1271be3338ef1de307bd5d0fd9c')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: